GELÖST XP-Umzug von IDE- auf S-ATA-Festplatten per Image-Restore

Diskutiere XP-Umzug von IDE- auf S-ATA-Festplatten per Image-Restore im WinXP - Installation Forum im Bereich Windows XP Forum; Hallo Leute, ich habe ein ziemlich umfangreiches und gut gepflegtes Windows XP Professional auf meinem alten Rechner laufen. Das...
T

Tilvaltar

Threadstarter
Mitglied seit
10.03.2010
Beiträge
5
Hallo Leute,

ich habe ein ziemlich umfangreiches und gut gepflegtes Windows XP Professional auf meinem alten Rechner laufen. Das Windows-Verzeichnis heißt noch c:\win95, weil ich es seit 1996 immer wieder geschafft habe, Windows zu aktualisieren statt neu zu installieren, wenn eine neue Version rauskam.

Der alte Rechner läuft mit IDE-Festplatten, hat eine AMD-CPU mit 2100 MHz und ein Gigabyte-Mainboard mit VIA-Chipsatz. Jetzt habe ich mir einen neuen Rechner zusammengebaut, der zwei S-ATA-Festplatten, ein MSI-Board mit AMD-770-Chipsatz und eine Phenom-X2-CPU hat.

Mit Acronis True Image habe ich vom alten Rechner ein Komplettbackup gemacht und das Image auf die beiden S-ATA-Festplatten des neuen Rechners übertragen. Diese Methode habe ich bisher immer angewandt, wenn ich Festplatten austauschen musste. Das hat auch immer geklappt.

Diesmal, so war mir klar, würde auf jeden Fall der Chipsatz-Treiber falsch sein und zu Problemen führen, vielleicht auch der Grafiktreiber (wobei der Wechsel von einer Geforce 7900 GS auf eine Geforce GTS 250 nicht so gravierend sein dürfte). Deshalb dachte ich, ich könnte nach der Übertragung des Images einfach in den abgesicherten Modus von Windows XP hochfahren, im Gerätemanager alles rausschmeißen, was mit Mainboard, Grafik und anderer Hardware zu tun hat und anschließend die neuen Treiber nachinstallieren.

So ungefähr hat das bei meinen letzten Mainboard-Wechseln auch funktioniert, aber diesmal hatte ich keinen Erfolg. Sowohl beim normalen Hochfahren als auch beim Start in den abgesicherten Modus bekomme ich einen Bluescreen ohne sonderlich viel Informationen:



Kann mir jemand einen Tipp geben, woran es liegen könnte - und wie ich das Problem löse, ohne Windows XP neu installieren zu müssen? Würde es helfen, von der auf meinem alten Rechner laufenden XP-Version eine Art Rip-Off zu erstellen, also im abgesicherten Modus alle Hardware-Treiber aus dem Gerätemanager zu schmeißen, dann ein Image von diesem Zustand zu machen und den neuen Rechner damit zu versehen? Ich bin mir sicher, dass es eine Möglichkeit gibt, Windows wieder zum Laufen zu bringen, ohne es neu zu installieren. Hat ja bisher auch immer geklappt! Vermutlich ist diesmal der Wechsel auf S-ATA-Festplatten schuld an dem Problem, weil die Bluescreens schon zwei Sekunden nach dem Hochfahren erscheinen, und das ist verdammt früh ...

(Oder sind die CPU und das Mainboard zu schnell für Windows XP? Nee, oder?)

Vielen Dank fürs Lesen.
Noch mehr Dank für konstruktive Tipps. :)
 
M

Manuel79

Mitglied seit
14.07.2007
Beiträge
141
Standort
Mosbach
Hi,
also XP läuft schon auf deinem Rechner. Aber ich glaube du wirst um eine Neuinstalation nicht herum kommen. Ich habe auch mal versucht eine Festplatte mit XP in einem anderen Rechner zu booten und hatte das selbe ergebnis.

mfg
Manuel
 
HaraldL

HaraldL

Mitglied seit
26.07.2006
Beiträge
5.835
Standort
Niederbayern
Der Bluescreen 7B kommt vom fehlenden SATA-Treiber. Was du machen kannst wenn du keine Neuinstallation willst (was natürlich die sauberste Lösung wäre) ist eine Reparaturinstallation. Dabei wird nur die Hardware neu konfiguriert, es gehen lediglich die Windows-Updates verloren seit dem Servicepack der auf der für die Rep.-Inst. verwendeten CD drauf ist. Installierte Programme, Dateien, Einstellungen bleiben komplett erhalten (Ausnahme: Manche Programme die als Kopierschutz eine hardwareabhängige Aktivierung/Freischaltung brauchten merken evtl. daß sich die Hardware geändert hat und müssen neu freigeschaltet werden).

Anschließend muß man halt wie bei einer Neuinstallation die Treiber für Chipsatz, Graka usw. installieren und die fehlenden Windows-Updates nachholen.

Hier im Board gibt es eine Schritt-für-Schritt-Anleitung (wobei du das SP2 dort gedanklich durch SP3 ersetzt solltest).

Dabei hast du aber ebenfalls das SATA-Problem, oder besser gesagt vermutlich sogar zwei:
1. XP hat Probleme von einem SATA-DVD-Laufwerk installiert zu werden (gilt auch für die Rep.-Inst.). Selbst das Laden einer Treiberdiskette mit F6 hilft hier oft nicht, es kommt dann wieder der Bluescreen 7B. Einfachste Lösung ist wenn man ein altes IDE-CD/DVD-Laufwerk greifbar hat und dieses nur für die Installation ansteckt. Nachher kann man wieder zurückwechseln.

2. Ohne SATA-Treiber findet XP keine Festplatte zum installieren/reparieren. Hier kann man entweder kurzzeitig ein Diskettenlaufwerk anschließen falls greifbar und eine Diskette mit dem SATA-Treiber beim Start mit F6 laden. Treiber von CD oder USB-Stick geht bei XP leider noch nicht, ausschließlich Disketten.

Eine Alternative für beide Probleme ist, per z.B. nLite eine angepaßte Windows-CD zu basteln wo der SP3 und der zum Board passende SATA-Treiber schon integriert sind.

Die letzte Möglichkeit wäre, im BIOS den SATA-Controller von "SATA", "AHCI" oder "RAID" umzustellen auf "IDE" oder "Compatible" falls das möglich ist. Dann findet Windows die Platte(n) auch ohne SATA-Treiber, allerdings verzichtest du damit auf ein paar SATA-Features. Vielleicht bringst du das System aber so wenigstens zum Laufen und es gibt Anleitungen wie man Windows nachträglich dann wieder auf AHCI umstellt.
 
T

Tilvaltar

Threadstarter
Mitglied seit
10.03.2010
Beiträge
5
Die letzte Möglichkeit wäre, im BIOS den SATA-Controller von "SATA", "AHCI" oder "RAID" umzustellen auf "IDE" oder "Compatible" falls das möglich ist. Dann findet Windows die Platte(n) auch ohne SATA-Treiber, allerdings verzichtest du damit auf ein paar SATA-Features. Vielleicht bringst du das System aber so wenigstens zum Laufen und es gibt Anleitungen wie man Windows nachträglich dann wieder auf AHCI umstellt.
Danke für deine ausführliche Antwort. Vielleicht hilft sie mir später weiter. Mich interessiert aber vor allem das, was du zuletzt schriebst, denn die Festplatten laufen von Anfang an im IDE-Modus. Und wenn ich in den abgesicherten Modus starten will, wird am unteren Bildschirmrand eine Zeile der boot.ini gezeigt und man sieht, dass das startende Windows auf Systemdateien im System32-Verzeichnis zugreift. Das geht zu schnell zum Merken, welche Dateien das sind, aber ich erkenne manche wieder. Ein Festplattenzugriff findet also statt. Aber dann kommt schon der Bluescreen. Das deutet für mich eher auf ein Chipsatz-Treiber-Problem hin, denn ich habe ja das Windows XP, welches auf einem Gigabyte-Board mit VIA-Chipsatz läuft, einfach in ein MSI-System mit AMD-Chipsatz gepackt. Klar, dass das nicht reibungslos weiterläuft, aber ich hatte gedacht, wenigstens der abgesicherte Modus würde funktionieren. Tut er nicht. Warum?Wenn ich das rausfinden könnte, wäre mir schon geholfen. Alles andere ginge dann quasi von selbst ...
 
HaraldL

HaraldL

Mitglied seit
26.07.2006
Beiträge
5.835
Standort
Niederbayern
Am sichersten ist aber dennoch die Reparaturinstallation (an zweiter Stelle nach der sauberen Neuinstallation natürlich ;) ). Damit werden auch alle fürs Booten nötigen Einstellungen und Dateien wieder korrekt hergestellt. Vor allem wenn du dabei den SATA-Treiber mitlädst oder integriert hast wird dieser korrekt mitinstalliert. Und du verlierst nichts außer den Windows-Updates die dann halt wieder neu installiert werden, denn die neuen Treiber für Mainboard und Co. mußt du ja sowieso installieren.
 
T

Tilvaltar

Threadstarter
Mitglied seit
10.03.2010
Beiträge
5
T

Tilvaltar

Threadstarter
Mitglied seit
10.03.2010
Beiträge
5
Erst einmal versuche ich das hier:
http://support.microsoft.com/kb/314082/de
Die Fehlerbeschreibung dort passt exakt zu meinem Problem.

Die Reparatur hebe ich mir dann für später auf. Erst einmal soll XP einfach wieder laufen, meinetwegen auch nur im IDE-Modus.
ES HAT GEKLAPPT!
Die Anleitung von Microsoft war genau das, was ich brauchte. Die Lösung war so einfach! Der Rechner läuft, ich muss nur noch ISDN- und TV-Karte rüberstecken, dann kommt der alte hier in den Keller. Später schaue ich dann, wie ich die Platten aus dem IDE-Modus raushole (Reparaturinstallation oder so). Aber das erst, wenn ich Zeit und Lust habe.

Danke für jeden Tipp!

:blush
 
Thema:

XP-Umzug von IDE- auf S-ATA-Festplatten per Image-Restore

Sucheingaben

windows xp auf sata umziehen bluescreen

XP-Umzug von IDE- auf S-ATA-Festplatten per Image-Restore - Ähnliche Themen

  • Aktivierung nach Umzug in virtuelle Maschine

    Aktivierung nach Umzug in virtuelle Maschine: Guten Tag, es ist erforderlich ein Windows 8.1 System in eine virtuelle Maschine umziehen zu lassen. Nach dem Umzug wird es zur neuen...
  • Umzug von Lenovo I3 nach Intel NUC 15 Win10 pro _digitale Lizenz

    Umzug von Lenovo I3 nach Intel NUC 15 Win10 pro _digitale Lizenz: Hallo Ich bin ob der vielen Suchergebnisse irritiert:-( Ich habe: Lenovo Ideacentre mit Windows10 pro Digitale Lizenz Ich bekomme nun etwas...
  • nach Umzug auf neuen PC ruft Outlook keine nachrichten mehr vom POP3 Konto ab. Fehler: "Der Vorgang konnte nicht ausgeführt werden. Ein Objekt wurde n

    nach Umzug auf neuen PC ruft Outlook keine nachrichten mehr vom POP3 Konto ab. Fehler: "Der Vorgang konnte nicht ausgeführt werden. Ein Objekt wurde n: Hallo zusammen, nach Umzug von Outlook 2007 auf neuen Win 10 PC, sind zwar alle Daten, Einstellungen und Verbindungen korrekt rübergekommen...
  • Welche hilfe (in Form von Programm) brauche ich beim umzug von Alten auf Neuen PC

    Welche hilfe (in Form von Programm) brauche ich beim umzug von Alten auf Neuen PC: Hallo, gibt es ein Hilfsprogramm mit den ich alle notwendigen Einstellungen und Programme auf ein Zwischenschpeicher kopieren und anschliesend...
  • Windows XP Umzug von IDE nach SATA

    Windows XP Umzug von IDE nach SATA: Ich möchte meine Windows XP Partition von IDE nach SATA verschieben (Klonen). Muss ich die boot.ini anpassen und wenn ja wie? Gibt es sonst noch...
  • Ähnliche Themen

    Oben