Umstellung WinXP auf AHCI

Diskutiere Umstellung WinXP auf AHCI im Win7 - Installation Forum im Bereich Windows 7 Forum; Hier meine Notebook Daten: Servicetag Nummer 4MG1Y4J Dell Latitude E6400, mit Mainboard: 0W620R Prozessor: Intel Core 2 Duo P8700 2,53GHz, Bios...

gt44

Threadstarter
Dabei seit
08.02.2021
Beiträge
22
Hier meine Notebook Daten: Servicetag Nummer 4MG1Y4J

Dell Latitude E6400
, mit Mainboard: 0W620R

Prozessor: Intel Core 2 Duo P8700 2,53GHz, Bios Version A24

BIOS: Brand Dell Inc., Version: A24 von 5.6.2010, Bios Update A34 16.7.2013
RAM: DDR2, Dual, 2x2GB

Chipsatz: Intel GM45 Southbridge 82801(ICH9-M) Rev. 03,

Grafikkarte: Intel GMA 4500MHD, 1280x800(WXGA)


Das CD ROM Laufwerk existiert nicht mehr, dafür die 160GB Festplatte eingebaut
IDE ATA/ATAPI-Controller „Intel® ICH9M/M-E Family 4 Port SATA AHCI Controller-2929“, 3GB/s

Multibootsystem Win10,Win7 auf SSD u. WinXP auf HDD.

Betreibe kein RAID System!



Hatte die SSD ausgebaut um auf die Festplatte WinXP zu installieren.

Im IDE-ATA Modus läuft alles super, jedoch bei der Umstellung auf SATA-AHCI habe ich
keinen Erfolg. WinXP wurde im IDE-ATA Modus installiert.

Habe verschiedene Möglichkeiten ausprobiert, bisher ohne Erfolg

von dieser Dell Downloadseite
https://www.dell.com/support/home/de-de/product-support/servicetag/0-bWNQdHhuR3dLenBOOTMySU80TXlrZz090/drivers

unter Angabe der Servicetag Nr., SATA u. WinXP die Datei

SATA_DRVR_WIN_R264763.exe 13,5MB, Version 9.6.0.104, A04 vom 5.1.2012

(Name: Intel Rapid Storage Technology Driver, Kategorie: Seriell ATA, vom 5.1.2012)

ausgewählt u. runter geladen, angeklickt, den Button „Extract“ angeklickt u. nach
C:\Dell\Drivers\sata\sata_dvvr_win_r264763 abgespeichert u. dort die setup.exe

ausgeführt. Ergebnis: Fehlermeldung:

„Dieses System erfüllt nicht die Mindestanforderungen für die Installation der Software.

Hatte vorher das Programm .NET Framework 3.0 erfolgreich installiert gehabt.
Dies war eine Forderung von der Anwendung „Intel Rapid Storage- Technologie“.

Wer kann weiterhelfen? Suche den passenden SATA AHCI Treiber.

Anbei die Bilder 3935, 3937,3907, 3911
Schaut euch mal dieses Bild an!
Schaut euch mal dieses Bild an!
Schaut euch mal dieses Bild an!
Schaut euch mal dieses Bild an!
 

XP-Fan

Dabei seit
29.11.2008
Beiträge
1.612
Nimm mal den Treiber für den Intel Matrix Storage Manager

Entpacke diesen und stelle beim Installieren den Treiber über F6 zur Verfügung.
 

HerrAbisZ

Dabei seit
09.08.2014
Beiträge
3.882
Ort
Noch Wien
Der sollte es sein

Challenge Page

1615633606420.png
 

gt44

Threadstarter
Dabei seit
08.02.2021
Beiträge
22
Habe die Datei A08 R304948.exe runter geladen u. ausgeführt. Der Inhalt wurde nach C:\Dell\Driver\7F9C7 gespeichert u. als Meldung kam, dass alle Dateien entpackt wurden. (9 Dateien einschließlich iaAHCI.inf).Bin in den Geräte-Manager gegangen, habe die Kategorie

IDE ATA/ATAPI-Controller“ aufgeklappt(siehe Bild 3907).

  1. Rechtsklicken auf den oberen Eintrag Standard-Zweikanal-PCI-IDE-Controller u. auf
Treiber aktualisieren“ geklickt.

„Nein, diesmal nicht“ gewählt u. auf „ Weiter“ geklickt.

  1. „Software von einer Liste oder bestimmten Quelle installieren“ ausgewählt u. auf „ Weiter“ geklickt
  2. „Nicht suchen, sondern den zu installierenden Treiber selbst wählen“ ausgewählt u.auf „Weiter“ geklickt.
  3. Standard-Zweikanal-PCI-IDE-Controller“ gewählt u. auf „Weiter“ geklickt.
  4. auf „Fertig stellen“ geklickt u. dann die Frage, ob nach der Hardwareänderung der PC neu gestartet werden soll mit „ Ja“ beantwortet um das System neu zu starten.

  5. Dann erneut in Geräte-Manager gegangen, habe die Kategorie „IDE ATA/ATAPI-Controller“ aufgeklappt(siehe Bild 3907)
  6. Rechtsklick auf den oberen Eintrag Standard-Zweikanal-PCI-IDE-Controller u. auf „Treiber aktualisieren“ geklickt.
  7. „Nein, diesmal nicht“ gewählt u. auf „ Weiter“ geklickt.
  8. „Software von einer Liste oder bestimmten Quelle installieren“ ausgewählt.
  9. Auf „ Weiter“ geklickt
  10. „Nicht suchen, sondern den zu installierenden Treiber selbst wählen“ ausgewählt
  11. auf „Weiter“ geklickt.
  12. Standard-Zweikanal-PCI-IDE-Controller“ markiert
  13. auf die Schaltfläche „ Datenträger“. geklickt
  14. auf „Durchsuchen“ geklickt u. den Treiberordner C:\Dell\Driver\7F9C7 gegangen u. die Treiber-INF-Datei „iaAHCI.inf“. ausgewählt u. unter Dateiname sollte C:\Dell\Driver\7F9C7 stehen
  15. auf „Öffnen“ geklickt u. dann auf „OK“.
  16. Nun erscheint „Intel® NM10 Express Chipset
  17. Die zugehörige Datei für den Chipset Treiber „ r182522.exe“ hatte ich bereits unter C:\Dell\Driver\M16YG abgespeichert
  18. auf „ Weiter“ geklickt u. und die Treiberinstallation sollte beginnen.
  19. Eine Warnung bezüglich des Treiber-Updates wird von Windows angezeigt, auf „Ja“ geklickt, um fortzufahren. Es beginnt die Installation.
  20. auf „Fertig stellen“ klicken, wenn die Installation abgeschlossen wurde.
  21. Wenn man aufgefordert wird einen Neustart durchzuführen, auf „Ja“ geklickt.
  22. AHCI-Modus“ im BIOS aktivieren
    Wähle den "AHCI"-Modus und drücke Apply u. EXIT, um zu speichern und zu beenden.
  23. Der PC startet mit folgender Meldung:
Internal hard disk drive not found.to resolve this issue:try to reset the drive.

Internes Festplattenlaufwerk nicht gefunden. Um dieses Problem zu beheben: Versuchen Sie, das Laufwerk zurückzusetzen.

Fragen:

1. Ist mein Vorgehen u. die Reihenfolge der Abarbeitung zur Installation des SATA Treibers korrekt?

2. muss ich für den 2. Eintrag „Standard-Zweikanal-PCI-IDE-Controller“ im Gerätemanager die gleiche Prozedur wiederholen.?
 

Anhänge

  • IMG_3907.JPG
    IMG_3907.JPG
    154,1 KB · Aufrufe: 29

HerrAbisZ

Dabei seit
09.08.2014
Beiträge
3.882
Ort
Noch Wien
Punkt 17. und 18. ist mir nicht klar - ist aber schon so lange her, als ich das einmal gemacht habe
 

gt44

Threadstarter
Dabei seit
08.02.2021
Beiträge
22
Hallo,
warum die Treiberistallation für Chipset Treiber , s. Pkt. 17 u. 18 kommt ist mir unklar.
Nach dem Neustart u. Umstellung im Bios auf AHCI kommt die Fehlermeldung 0x0000007B, siehe Bild 656

1615798642897.png



Eine Rückkehr zu WinXP ist nur über Rückstellen im Bios auf ATA u. Start der" zuletzt funktionierenden bekannten Konfiguration" möglich.
Also nachwievor keine Lösung in Sicht.
Was läuft hier falsch?
 

Alfiator

On Air
Dabei seit
27.11.2008
Beiträge
36.163
Alter
54
Ort
Thüringen
Er findet das Bootlaufwerk nicht, weil der Modus welcher eingestellt ist nicht passt. Deswegen 7B; typisch....
 

Alfiator

On Air
Dabei seit
27.11.2008
Beiträge
36.163
Alter
54
Ort
Thüringen
Einen Thread im Luxx eröffnen zum Beispiel....:knall
 

HerrAbisZ

Dabei seit
09.08.2014
Beiträge
3.882
Ort
Noch Wien
Mit NLite den AHCI Treiber in die XP CD / ISO einbinden noch einmal neu installieren

Oder auf eine Floppy Disk speichern - ja es gibt auch USB Floppy Laufwerke - und beim neu installiern auf F6 klicken

Oder alle drei nur den AHCI Treiber im GM installieren.
 

cardisch

Dabei seit
07.01.2013
Beiträge
689
Mit NLite den AHCI Treiber in die XP CD / ISO einbinden noch einmal neu installieren

Oder auf eine Floppy Disk speichern - ja es gibt auch USB Floppy Laufwerke - und beim neu installiern auf F6 klicken

Oder alle drei nur den AHCI Treiber im GM installieren.
So ist es richtig..... Aber nützen tut dir das dennoch wenig. Du MUSST auch das Allignement für XP anpassen, sonst zerschreibst du ratz fatz die SSD. Und Trim funktioniert trotzdem nicht unter XP, zumindest nicht mit Boardmitteln, das darfst du immer händisch durchführen.
Wenn du also ein DualBoot-System mit zwei HDDs hast würde ich das alles so belassen.
 

gt44

Threadstarter
Dabei seit
08.02.2021
Beiträge
22
Für die Neuinstallation von WinXP würde ich wieder die SSD abklemmen. Habe ich schon mal erfolgreich praktiziert.Ein Floppy Laugwerk habe ich nicht am Notebook.
Würde alles über Nlite reinpacken, d.h. die Treiber, SP3 für WinXP u. .Net Framework 3.0

Was ist ein Allignement? Bitte für den Laien etwas näher erläutern.
 

cardisch

Dabei seit
07.01.2013
Beiträge
689
SSDs müssen an einem durch 8 teilbaren Sektor ausgerichtet sein, sonst müssen jedes mal 2 Blöcke beschrieben und gelöscht werden. Dies bedeutet Leistungsverlust und erhöhtes Schreibaufkommen (wofür SSDs nicht gemacht sind). XP installiert sich jedoch ab dem Sektor 63, weswegen XP neu ausgerichtet werden MUSS.
Und Trim (u.A. die automatische Löschung nicht mehr genutzter Daten) wurde erst mit Windows 7 "richtig" eingeführt.
ICH würde keine SSD mit XP betreiben!!!
 

HaraldL

Dabei seit
26.07.2006
Beiträge
6.008
Ort
Niederbayern
Ich hab noch ein XP Pro (*) für alle Fälle als virtuelle Maschine in VMware (würde genauso mit Virtualbox funktionieren). In einer VM kann man XP meist einfacher ohne solche Treiberprobleme installieren. Und auf halbwegs aktuellem Rechner läuft das in Vollbild geschaltet genauso flüssig wie regulär installiert wenn man die Gasterweiterungen installiert hat.

(*) genau wie ein Windows 1.03, 2.03, 3.1, 95B, 98SE, 2000 Prof, Vista Ultimate, Win7 Pro, IBM OS/2 Warp 4, Novell Netware 3.12
 

gt44

Threadstarter
Dabei seit
08.02.2021
Beiträge
22
Auf der SSD ist ja bei mir kein WinXP installiert, sondern auf der HDD. Ein Lösung über VM ist die letzte Variante, wenn alle anderen Möglichkeiten ausgeschöpft wurden u. nicht zum Erfolg geführt haben.
 

gt44

Threadstarter
Dabei seit
08.02.2021
Beiträge
22
Hallo,
nur über eine Neuinstallation unter AHCI Modus ohne vorherige Einbindung der Treiber hat es funktioniert.
 

Anhänge

  • 20210329_053747.jpg
    20210329_053747.jpg
    219,5 KB · Aufrufe: 19

HerrAbisZ

Dabei seit
09.08.2014
Beiträge
3.882
Ort
Noch Wien
Ähm - und wie hast du den AHCI Treiber für XP geladen ?
 

gt44

Threadstarter
Dabei seit
08.02.2021
Beiträge
22
Hallo,
das größte Problem war ja, da ein nachträgliche Umstellung von IDE auf AHCI nicht möglich war. Es kam immer der Fehler 7B mit Bluescreen.
Nur eine Neuinstallation im AHCI Modus brachte den Erfolg. Die nachträgliche Installation der Treiber, wie Chipsatz, Video/Grafik, Wlan, Audio u. den SATA Treiber Intel_Rapid-Storage-Technolo_A08 R304948.exe, Version 9.6.4.1002 war kein Problem mehr.
 

Anhänge

  • 20210326_143247.jpg
    20210326_143247.jpg
    264,8 KB · Aufrufe: 18
  • 20210327_054249.jpg
    20210327_054249.jpg
    140,7 KB · Aufrufe: 18
Thema:

Umstellung WinXP auf AHCI

Umstellung WinXP auf AHCI - Ähnliche Themen

WinXP mittels USB Stick auf Notebook nach Win7/Win10 installieren: Hallo, habe Notebook Dell Latitude E6400 mit Mainboard: 0W620R Chipsatz: Intel GM45 Southbridge: 82801IM(ICH9-M) Rev.03 SSD 128GB Samsung 830...
BoD (DPC_WATCHDOG_VIOLATION / VIDEO_TDR_FAILURE) due to graphics driver or faulty hardware?: Since quite some time I regularly get BoDs with a DPC_WATCHDOG_VIOLATION (133) and after some driver changes VIDEO_TDR_FAILURE (116)...
Dpc_ Watchdog Violation: Guten Tag Ich habe einen neuen Computer gekauft und erhalte seit Anfang immer mal wieder einen Bluescreen mit folgender Fehlermeldung Dpc...
Probleme mit USB-Mikro: Hallo zusammen! In völliger Verzweiflung wende ich mich nun auch einmal an das Forum, vielleicht hat ja noch jemand eine Idee für mich. Ich bin...
Nach Windows 10 Pro-Funktionsupdate von RS2 (Version 1703) auf RS3 (Version 1709) werden Samsung SSD: Hallo, seit dem Einspielen des Windows 10 Pro Funktionsupdates im März, bei dem mein Betriebssystem von RS2 (Version 1703) auf RS3 (Version 1709)...
Oben