GELÖST Ubuntu 7.10 dazu bewegen kein automount bei NTFS?

Diskutiere Ubuntu 7.10 dazu bewegen kein automount bei NTFS? im Linux Forum im Bereich Weitere Betriebssysteme; Hallöchen, bin seit 7.10 auf Ubuntu als Dualboot mit XP umgestiegen. Hab zwar als Anfängerin noch so meine Probleme,aber so langsam gehts :up...
Sandra22

Sandra22

Threadstarter
Mitglied seit
17.05.2006
Beiträge
156
Standort
Berlin
Hallöchen,
bin seit 7.10 auf Ubuntu als Dualboot mit XP umgestiegen.
Hab zwar als Anfängerin noch so meine Probleme,aber so langsam gehts :up
Jetzt zu meinem Problem: Wenn ich Ubuntu starte mountet er automatisch meine NTFS Partitionen. Will aber aus Sicherheitsgründen nur das eine von vier NTFS Partition gemoutet werden soll. Wie stelle ich das am besten an?

Und wie kann ich sie dann wieder fon Hand mounten wenn ich doch mal drauf zugreifen will?

Hier mal meine fstab: Soweit bin ich schon mal :hm

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda9
UUID=f064472c-1cb9-47ed-a844-063bd5079425 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda11
UUID=7d82a79c-feee-43e5-bfd2-625e904f6484 /home ext3 defaults 0 2
# /dev/sda1
UUID=E2F8874DF8871EC3 /media/sda1 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda5
UUID=EE2CAFCB2CAF8D61 /media/sda5 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda6
UUID=D8284A122849EFD4 /media/sda6 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda7
UUID=6A98AB2998AAF2AD /media/sda7 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda8
UUID=8F9E-30E5 /media/sda8 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/sda10
UUID=67626c8c-1947-47b7-b220-dfd5775051bd none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0

Lg
Sandra22
 
Mike

Mike

i7-6700HQ
Team
Mitglied seit
21.09.2006
Beiträge
24.376
Standort
in der Nähe eines Rechners
Jetzt zu meinem Problem: Wenn ich Ubuntu starte mountet er automatisch meine NTFS Partitionen. Will aber aus Sicherheitsgründen nur das eine von vier NTFS Partition gemoutet werden soll. Wie stelle ich das am besten an?
Hab grad kein Ubuntu am Laufen -- anderer PC, aber einfach nach dem Starten alle die nicht eingebunden werden sollen rausnehmen und nicht automatisch mounten lassen. Dass kannst du in der Volumenverwaltung (genaues Wort weiß ich jetzt nicht) einfach einstellen, ohne direkt in der fstab arbeiten zu müssen. :)

vllt seh ich noch nach, aber das kann dauern. Vllt hat jemand Ubuntu grad laufen, der wird sicher sicher melden.
 
Sandra22

Sandra22

Threadstarter
Mitglied seit
17.05.2006
Beiträge
156
Standort
Berlin
Hallo MikeK

Danke für die schnelle Antwort,aber leider weis ich nich genau wo ich sie nach dem Start rausnehmen soll !? :blush

Hoffe das sich noch jemand meldet der mir das noch mal genau erklären kann...

Lg
Sandra22
 
D

dlonra

Mitglied seit
19.10.2005
Beiträge
1.149
Also am einfachsten ist, wen man die entsprechende Zeile mit einem "#" aus-
komentiert.
Wenn man das Dateisystem wieder "mounten" möchte muss man die # entfernen.
Mehr weiß ich nicht, hab das mal so gemacht und es hat funktioniert.
Zuvor aber die Laufwerke aushängen mit.

sudo umount /media/sda5
.
.
# /dev/sda5
##UUID=EE2CAFCB2CAF8D61 /media/sda5 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda6
##UUID=D8284A122849EFD4 /media/sda6 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda7
##UUID=6A98AB2998AAF2AD /media/sda7 ntfs defaults,umask=007,gid=46 0 1
 
Hups

Hups

Katzennarr
Team
Mitglied seit
01.07.2007
Beiträge
18.315
Standort
D-NRW
Das sollte doch auch ohne umount gehen?
Also als Root die fstab bearbeiten und den Rechner neu starten.
Dazu gibst du im Terminal
sudo gedit
ein.
Damit öffnest du einen Texteditor und kannst die fstab laden und bearbeiten.
 
Sandra22

Sandra22

Threadstarter
Mitglied seit
17.05.2006
Beiträge
156
Standort
Berlin
Danke Leute ihr seit mal wieder die Besten :up

Genau so wollt ichs haben :sing

Lg
Sandra22
 
Cyron

Cyron

SPONSOREN
Mitglied seit
25.12.2004
Beiträge
3.280
Alter
30
Standort
far beyond /dev/null
Am einfachsten wär wohl bei den Optionen "noauto" hinzuzufügen, einfach mit Komma dahinter hängen, damit bleiben alle Informationen gespeicher und du brauchst dem Mount-Befehl nur den Einhängepunkt oder das Laufwerk angeben, die restlichen Informationen holt er sich aus der fstab :)

In deinem Fall sähe das dann so aus:
# /dev/sda5
UUID=EE2CAFCB2CAF8D61 /media/sda5 ntfs defaults,umask=007,gid=46,noauto 0 1
# /dev/sda6
UUID=D8284A122849EFD4 /media/sda6 ntfs defaults,umask=007,gid=46,noauto 0 1
# /dev/sda7
UUID=6A98AB2998AAF2AD /media/sda7 ntfs defaults,umask=007,gid=46,noauto 0 1
Greetz Cyron
 
D

dlonra

Mitglied seit
19.10.2005
Beiträge
1.149
@Cyron
Danke :D
hoffentlich sieht sie es noch ;)
 
Sandra22

Sandra22

Threadstarter
Mitglied seit
17.05.2006
Beiträge
156
Standort
Berlin
@Cyron
Danke :D
hoffentlich sieht sie es noch ;)
Ja, war zum Glück grad noch im Board am Lesen :D

Hi Cyron

Was meinst du genau,mit:

Am einfachsten wär wohl bei den Optionen "noauto" hinzuzufügen, einfach mit Komma dahinter hängen, damit bleiben alle Informationen gespeicher und du brauchst dem Mount-Befehl nur den Einhängepunkt oder das Laufwerk angeben, die restlichen Informationen holt er sich aus der fstab. :confused

Meinst du wenn ich sie dann über die Konsole mounten möchte,als über Computer?

Sorry, für die blöde Frage bin noch Anfängerin was Linux angeht :blush
 
Cyron

Cyron

SPONSOREN
Mitglied seit
25.12.2004
Beiträge
3.280
Alter
30
Standort
far beyond /dev/null
@Sandra22

Nein, ich meine in die Optionsspalte in der fstab bei den NTFS Einträgen die du nicht automatisch mounten möchtest :)


Greetz Cyron
 
Sandra22

Sandra22

Threadstarter
Mitglied seit
17.05.2006
Beiträge
156
Standort
Berlin
Hi,
und was is genau der unterschied zu dem hier?

# /dev/sda5
##UUID=EE2CAFCB2CAF8D61 /media/sda5 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda6
##UUID=D8284A122849EFD4 /media/sda6 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda7
##UUID=6A98AB2998AAF2AD /media/sda7 ntfs defaults,umask=007,gid=46 0 1

ausser das hinten ,noauto anders is???

Lg
Sandra22

Hat eins nach oder vorteile? versteh das grad nich? Lieb Frag!
 
Cyron

Cyron

SPONSOREN
Mitglied seit
25.12.2004
Beiträge
3.280
Alter
30
Standort
far beyond /dev/null
Nun, noauto ist die Option die du suchst, es sorgt dafür dass du nur explizit mit dem Mount-Befehl auf diese eine Partition diese Partition mounten kannst, und nicht via "mount -a" (mounte alle Dateisysteme) welches in etwa beim Systemstart ausgeführt wird.

Auszug aus "man mount":
noauto Can only be mounted explicitly (i.e., the -a option will not cause the file system to be mounted).
Greetz Cyron
 
Sandra22

Sandra22

Threadstarter
Mitglied seit
17.05.2006
Beiträge
156
Standort
Berlin
Vielen Dank,
jetzt hab ichs auch verstanden :blush
Sitz heut schon zu lange am PC und bin nich mehr so aufnahmefähig :D

Lg
Sandra22
 
Sandra22

Sandra22

Threadstarter
Mitglied seit
17.05.2006
Beiträge
156
Standort
Berlin
So ich nochmal :blush

Hab festgestellt, wenn man das mit den ## macht is das für Anfänger leichter :D
Wenn man unter Computer, aufs laufwerk klickt muss man nur sein Passwort eingeben,um es zu mounten.

Wenn man das mit ,noauto macht fehlen wieder die Rechte,und man muss es in dem Terminal machen mit, sudo mount /media/sda?

Lg
Sandra22
 
Cyron

Cyron

SPONSOREN
Mitglied seit
25.12.2004
Beiträge
3.280
Alter
30
Standort
far beyond /dev/null
Versuch mal zusätzlich "users,exec,dev,suid" dran zu hängen :)

Eigentlich ist nur users wirklich benötigt, nur dadurch werden einige Funktionen die du benötigen könntest aus Vorsichtsmaßnahmen deaktiviert weil jetzt jeder normale Benutzer das Dateisystem einbinden kann, mit den restlichen Einträgen machst du das rückgängig :)

Nun solltest du es ohne Problem einhängen dürfen, glaub der Mount-Punkt muss dir auch noch zum schreiben verfügbar gemacht werden ... ist aber nur ne Vermutung.

Btw: Um die fstab zu editieren brauchst du auch SuperUser-Rechte, deshalb dürfte dennoch die Möglichkeit mit noauto und ohne users dem Auszitieren in der fstab vorgezogen werden.

Greetz Cyron
 
Sandra22

Sandra22

Threadstarter
Mitglied seit
17.05.2006
Beiträge
156
Standort
Berlin
Hi,
werd das mal Morgen Testen...

Aber so wie ich es jetzt hab (##) ist das doch gut oder? Aus Sicherheitstechnichen gesichts Punkten mein ich?

Also ohne Pass leuft nichts ;)

Lg
Sandra22
 
Cyron

Cyron

SPONSOREN
Mitglied seit
25.12.2004
Beiträge
3.280
Alter
30
Standort
far beyond /dev/null
Es gibt keine sicherheitstechnische Bedenken weder gegen die eine noch gegen die andere Methode.

Es ist nur eine Vorsichtsmaßname, das ein normaler Benutzer binäre Dateien aus ungeprüften Datenträgern laden (ausführen) könnte wenn er eine Festplatte im Rechner ersetzt und eben diese mounten kann ohne Systemverwalterrechte. Da aber jede habwegs moderne Linuxdistribution USB-Medien automatisch einbindet macht es keinen Unterschied ;)


Greetz Cyron
 
Sandra22

Sandra22

Threadstarter
Mitglied seit
17.05.2006
Beiträge
156
Standort
Berlin
Achsooo
Danke da hab ich wieder was dazugelert,mann(Frau)lernt ja nich aus :blush

Wünsch dir noch eine gute Nacht...

Bis zu nächsten Problem :D

Lg
Sandra22
 
Thema:

Ubuntu 7.10 dazu bewegen kein automount bei NTFS?

Ubuntu 7.10 dazu bewegen kein automount bei NTFS? - Ähnliche Themen

  • Nach Mainboardtausch startet Ubuntu 18.04 LTS. aber Windows 10 nicht (INACCESSIBLE BOOT DEVICE)

    Nach Mainboardtausch startet Ubuntu 18.04 LTS. aber Windows 10 nicht (INACCESSIBLE BOOT DEVICE): Ich habe mir einen PC zusammengebaut, auf dessen Harddisk Linux und Windows 10 installiert sind. Beim Systemstart kann ich über den Bootloader...
  • InstallationsUSBStick mit Win 10 unter Ubuntu Gnome erstellen

    InstallationsUSBStick mit Win 10 unter Ubuntu Gnome erstellen: Ich bin wahrscheinlich zu dumm, um einen bootfähiges USB-Stick zu erstellen. Habe schon unterschiedliche Möglichkeiten ausprobiert. Leider...
  • Ubuntu auf dem Surface Laptop 2

    Ubuntu auf dem Surface Laptop 2: Hallo, gibt es irgendeine Möglichkeit Ubuntu (egal welcher Version) auf dem Surface Laptop 2 zum Laufen zu bringen? Ich habe schon allerlei...
  • 1809 Update löscht Ubuntu Bootloader und Partition

    1809 Update löscht Ubuntu Bootloader und Partition: Hi, Vielleicht hat hier jemand einen Tipp wie man sowas in Zukunft vermeiden kann. Ich hatte Windows 10 installiert und parallel dazu ein...
  • Ubuntu Mate auf USB Stick installiert / Boot nicht moeglich

    Ubuntu Mate auf USB Stick installiert / Boot nicht moeglich: Hallo wollte Ubuntu Mate auf einem USB Stick installieren, damit Ubuntu an jedem Rechner booten kann. Habe mir die ISO auf einen anderen Stick...
  • Ähnliche Themen

    Oben