SuSE 8.1 DMA aktivieren

Diskutiere SuSE 8.1 DMA aktivieren im Linux Forum im Bereich Linux; Wie kann ich unter SuSE 8.1 den DMA Modus aktivieren? YaST 2 gibt den Fehler 'Gerät /dev/... : DMA kann nicht auf den Wert 1 gesetzt werden' aus...
#1
M

morpheus2051

Dabei seit
13.02.2002
Beiträge
376
Wie kann ich unter SuSE 8.1 den DMA Modus aktivieren? YaST 2 gibt den Fehler 'Gerät /dev/... : DMA kann nicht auf den Wert 1 gesetzt werden' aus.

Chipsatz : Via KT 333 und VT8235
Board: MSI KT3 Ultra 2
Festplatten: 2x IBM 80 GB als Primary Master und Slave
CD Rom/DVD: Toshiba 16x DVD/Teac 552E
 
#2
stpe

stpe

Dabei seit
14.11.2001
Beiträge
2.729
die wichtigste angabe hast Du vergessen: fuer welches geraet denn?
 
#3
M

morpheus2051

Dabei seit
13.02.2002
Beiträge
376
Ich kann den DMA Mudus für alle Geräte nicht aktivieren. Das heißt für beide Festplatten (/dev/hda; /dev/hdb) und das DVD- (/dev/hdd) und CD-Rom Laufwerk (/dev/hdc).
 
#4
stpe

stpe

Dabei seit
14.11.2001
Beiträge
2.729
versuch mal einen:
Code:
hdparm -d1 /dev/hda
als root. wenn das funktioniert, ist der dma-mode aktiv.

ueberpruefen kannst Du die einstellung mit einem:
Code:
hdparm -v /dev/hda
. ausserdem kannst Du mit dem parameter
Code:
-X [mdma2|sdma1|udma2]
den dma-mode einstellen.

lies Dir hierzu aber auf JEDEN fall! die man-page zu hdparm durch!
 
#5
M

morpheus2051

Dabei seit
13.02.2002
Beiträge
376
Ich habs probiert.

Ich hatte folgende Ausgaben (als root angemeldet):

deepthought:~ # hdparm -d1 /dev/hdb

/dev/hdb:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)



deepthought:~ # hdparm -v /dev/hdb (Ist meine Linux Festplatte)


dev/hdb:
multcount = 16 (on)
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 10011/255/63, sectors = 160836480, start = 0


deepthought:~ # hdparm -X66 /dev/hdb

/dev/hdb:
setting xfermode to 66 (UltraDMA mode2)
Segmentation fault

Mein IDE Controller schafft Ultra DMA 133/100/66/33 und Bus Master zu verfügung. 66 war der einstigste wert den hdparm annahm. Beim rest gab er 'setting xfermode to 133 (unknown, probaly not vailid)'.

Das sollte ich mir doch durchlesen, oder?

man page
 
#6
G

Guest

Gast
Hab noch was gefunden:

deepthought:~ # hdparm -i /dev/hdb | grep DMA
IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 *udma2 udma3 udma4 udma5
 
#7
M

morpheus2051

Dabei seit
13.02.2002
Beiträge
376
Das oben war ich.
Auf meinem System ist hdparm 5.2 drauf.
 
#8
stpe

stpe

Dabei seit
14.11.2001
Beiträge
2.729
dann probier mal, die einstellungen beim booten zu setzen.

veraendern kannst Du diese in der datei: /etc/sysconfig/harddisks

setze einfach den parameter "USE_DMA" auf 1 und boote neu - pruefe danach noch einmal mit htparm -v /dev/hdb den dma-mode der platte.

danach kannst Du mit dem X-parameter testen und diesen bei erfolg spaeter in der harddisks-datei hinter EXTRA_PARAMS setzen.
 
#9
M

morpheus2051

Dabei seit
13.02.2002
Beiträge
376
in /etc/sysconfig/harddisks ist bei mir nicht vorhanden. Es ist eine /etc/sysconfig/hardware vorhanden mit dem Inhalt:

# force dma to on for following devices

DEVICES_FORCE_IDE_DMA_ON="hda hdb hdc hdd"

# force dma to off for the following devices

DEVICES_FORCE_IDE_DMA_OFF=""

Ich hab daran schon rumgespielt. Es ändert sich nur nichts. DMA bleibt deaktiviert.
 
#10
stpe

stpe

Dabei seit
14.11.2001
Beiträge
2.729
koennte sein, dass Du ein bios-problem hast - hat der dma-zugriff den bislang funktioniert?
 
#11
M

morpheus2051

Dabei seit
13.02.2002
Beiträge
376
Unter Win2k läuft alles Problemlos, auch der UDMA 5 Modus.
 
#12
M

morpheus2051

Dabei seit
13.02.2002
Beiträge
376
Ich habs gefunden wie man den DMA Support auf einem VT8235 Chipsatz aktiviert.
Mann muss nur zwei Systemfiles patchen und alles soll funktionieren.

Hier die Links zum patchen:

Zum manuellen patchen:
http://www.faqchest.com/linux/KERNEL/kern-...901_03414.html/

Original Via Patch (allerdings ohne Busmastering):
http://downloads.viaarena.com/drivers/IDE/...tchFile-V20.zip

Damit alles funktioniert (Was nach Via der Fall ist) muss man nur noch sich einen neuen Kernel compilieren. Und da fangen bei mir die Probleme an.

Mein original Kernel hat als Dateityp 'Unbekannt'. Den den ich compiliert hat hat als
Dateityp 'Programm'.

Ich hab den in meinen Bootmanager eingetragen. Wenn ich den jetzt booten will, meldet grub
'Error 13: Invalid or unsupported executable format'.

Ich hab einfach mal um den Bootmanger zu testen meinen "alten" Kernel kopiert und umbennant
und auch eingetragen. Den kann ich dann ohne Probleme booten.

Wie groß darf eigendlich ein Kernel werden?

Hat jemand eine Idee zur Lösung meine Problems?
 
Thema:

SuSE 8.1 DMA aktivieren

SuSE 8.1 DMA aktivieren - Ähnliche Themen

  • SQL Server vNext: Neue Preview bietet Unterstützung für SUSE Linux Enterprise

    SQL Server vNext: Neue Preview bietet Unterstützung für SUSE Linux Enterprise: <p>Ab sofort steht die <a href="https://blogs.technet.microsoft.com/dataplatforminsider/2017/01/20/sql-server-next-version-ctp-1-2-now-available/"...
  • Suse Linux 13.2 und Rapberry Pi NAS

    Suse Linux 13.2 und Rapberry Pi NAS: Hallo zusammen Habe schon seit einiger Zeit einen Raspberry Pi als NAS in Betrieb wo ich über meinen Windows PC, und auch von Ubuntu Linux...
  • UEFI Secure Boot für Suse-Linux

    UEFI Secure Boot für Suse-Linux: Quelle und ganzer Bericht auf Heise.de
  • GELÖST Linux Suse 11

    GELÖST Linux Suse 11: Hallo, ich hab mir gestern ein Laptop mit Linux Suse 11 gekauft. Da ich aber ein Freund von Windows bin will ich das gern auf dem Laptop...
  • Suse 9.3 -> kein DMA-Zugriff nach Systemumbau

    Suse 9.3 -> kein DMA-Zugriff nach Systemumbau: Hallo nochmal, haben die Linux-Platte am Wochenende aus unserem alten System in ein neues System übertragen. SuSE 9.3 startet einwandfrei, hat...
  • Ähnliche Themen

    Oben