Start Problems for own applications (VS 2017 C# .NET 4.5 App)

Diskutiere Start Problems for own applications (VS 2017 C# .NET 4.5 App) im Windows 10 Forum im Bereich Microsoft Community; Hallo liebe Community, ich habe eine Anwendung entwickelt (mit MS Visual Studio Community 2017 Version 15.7.2 - C# .NET 4.5 - Verwendung von...
M

MS-User

Threadstarter
Dabei seit
20.09.2016
Beiträge
94.184
Hallo liebe Community,

ich habe eine Anwendung entwickelt (mit MS Visual Studio Community 2017 Version 15.7.2 - C# .NET 4.5 - Verwendung von AForge für Imaging und DirectShow Funktionen).

Die Anwendung ist noch im Beta Modus, läuft aber auf dem Entwicklungsrechner schon ziemlich brauchbar in 95 % aller Funktionen.
Nun habe ich aber ein Problem, bei dem ich nicht mehr weiterkomme.
Solange ich in der Entwicklungs- und Testumgebung auf meinem Desktop Rechner (AMD Ryzen 7 X1800 8 Kerne , 16 Threads) im VS Debugg Modus arbeite, also die Anwendung im Visual Studio Testmodus aufrufe, funktioniert alles recht zufriedenstellend.

Wenn ich die Anwendungsmodule (aus dem "bin/Release" Ordner in einen Anwenungsordner - für die Programmverteilung) übertrage und auf die EXE Datei in diesem Ordner klicke tut sich nichts.
Wenn ich einen Shortcut auf die Exe erzeuge und die Anwedung (auf meinem Entwicklungsrechner) über diesen Shartcut starte, dann läuft sie wie erwartet an und arbeitet normal.
Wenn ich die Programmbibliothek auf einen anderen Rechner übertrage, dann lässt die Exe File sich nicht starten (d.h. konkret, sie bleibt vor der ersten Anwendungsanweisung stecken - bei bestimmten Rechnern egal ob durch Aktivierung direkt über die EXE oder über einen ShortCut. Es regt sich nichts,
bei aanderen Rechnern lässt sich die EXE über ein Verknüpfung öffnen.

Das ist der CodeBlock des "Program" Modules. Kann es am Auffangen der Exception liegen, dass keine Reaktion erfolgt ?

namespace CineFrameGrabber
{
static class Program
{
///
/// Der Haupteinstiegspunkt für die Anwendung.
///
[STAThread]
static void Main(string[] parms)
{
Application.EnableVisualStyles();
Application.SetCompatibleTextRenderingDefault(false);
try
{
Application.Run(new CineFrameGrabber(parms[0],parms[1]));
}
catch (Exception ex)
{
Console.WriteLine("Program 025 ex=" + ex);
}
}
}
}


Alle Rechner haben Win 10 Home - 64 Bit V1803 installiert. Manche Rechner haben einen Intel Prozessor (mindestens 4 Kerne), andere haben AMD Prozessoren (auch mindestens 4 Kerne)..

Hat irgend jemand eine Idee, was die Ursache sein kann.

Gruß
Wolfgang

PS: ein Bitte: wenn die Frage in der falschen Kategorie ist, dann lieber Administrato, schiebe sie in dei richtige Kategorie.
Wenn es "Sonstiges" gegeben hätte, hätte ich darunter gepostet.
 
Thema:

Start Problems for own applications (VS 2017 C# .NET 4.5 App)

Oben