Schriftart stellt keine Umlaute dar

Diskutiere Schriftart stellt keine Umlaute dar im Internet Forum Forum im Bereich Internet Forum; Hallo, ich habe folgende Homepage erstellt: http://teuro.te.funpic.de/daslebendesfabian/default.htm. Die Schriftart (ich glaube, es ist Verdana...
#1
A

Avicenna

Threadstarter
Dabei seit
08.03.2007
Beiträge
151
Hallo,
ich habe folgende Homepage erstellt: http://teuro.te.funpic.de/daslebendesfabian/default.htm. Die Schriftart (ich glaube, es ist Verdana ref) ist ziemlich weit verbreitet, und trotzdem werden Sonderzeichen (ä, ö, ü, ß) nicht dargestellt. Kann man das irgendwie ausmerzen? Ich will die Schriftart ungern ändern.
Bei euch werden auf der Webseite ja auch die Umlaute so komisch dargestellt, oder (rä)?

Viele Grüße,
Avicenna
 
#2
R

Ronny

SPONSOREN
Dabei seit
07.08.2004
Beiträge
12.311
Ort
Rheinland
Also weder bei unserer Seite noch bei dir werden die Umlaute falsch dargestellt (siehe Screenshot). Die Ursache, dass sich das auf deinem Bildschirm so darstellt, wie Du schreibst, muss also woanders liegen. :blush
 

Anhänge

#3
A

Avicenna

Threadstarter
Dabei seit
08.03.2007
Beiträge
151
Hallo,
das ist ja interessant; bei mir ist es auch nur bei die genannt Webseite, sonst keine.

Wieso ist das bei mir so, und wie kann ich das Problem lösen?

Viele Grüße,
Avicenna
 

Anhänge

#5
H
Dabei seit
15.02.2007
Beiträge
273
wenn du in Mozilla die Zeichencodierung auf UTF8 stellst dann wird die Seite richtig angezeigt. (das geht unter Ansicht)
 
#6
A

Avicenna

Threadstarter
Dabei seit
08.03.2007
Beiträge
151
Hallo,
ich habe die Webseite mit Expression erstellt. Wenn ich die Zeichenkodierung auf Unicode umstelle, klappt es wieder :).
Aber es ändert sich jedesmal wieder zurück. Wie kann ich machen, dass es bei Unicode bleibt?
 
#7
H
Dabei seit
15.02.2007
Beiträge
273
das musst do wohl bei deinenprogramm einstellen. Wo da genau weiß ich nicht.
Da musst du irgendwo dem Programm sagen das er als codierung die "iso 8859" einstellen soll.
 
#8
H
Dabei seit
15.02.2007
Beiträge
273
Im Quelltext deiner Hauptseite steht dieser Eintrag
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

und die Einstellung kommt von deinen Programm
 
#9
D

dago

Dabei seit
05.09.2005
Beiträge
269
Alter
34
Ort
Rheinland-Pfalz
Hi, bei dir im Code ganz am Anfang ist ein Zeichen, der da nicht stehen darf. Wird bei mir jetzt so dargestellt:
HTML:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr">

<!-- #BeginTemplate "master.dwt" -->

<head>
...
Also das vor <!DOCTYPE ... entfernen!


Bezüglich deines Problems. Du musst nachschauen welchen Zeichensatz dein Editor verwendet. Es gibt welche bei denen es einstellbar ist. Wenn nicht, dann wird es wohl meist der Standart sein: ISO-8859-1

Mit dem Zeichensatz mit welchem du deine Dateien erstellt hast, musst du dann auch bei der META Angabe eintragen:
HTML:
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
Dann wird auch alles richtig dargestellt. ;)


Wenn du UTF-8 verwenden möchtest, dann musst du auch die Dateien als UTF-8 speichern! :blush


EDIT: Hab das jetzt nochmal nachgeschaut. Der Zeichensatz in dem es Codiert ist scheint doch UTF-8 zu sein. Da arbeitet entweder dein Editor nicht richtig oder der Webserver.

Kannst noch probieren diese Zeile vorne einzufügen:
HTML:
<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE ...
Bei IE wird alles korrekt dargestellt. Bei Firefox allerdings trifft man auf dieses Problem.
 
Zuletzt bearbeitet:
#10
A

Avicenna

Threadstarter
Dabei seit
08.03.2007
Beiträge
151
Hallo,
vielen Dank für eure Antworten. Dank dem Eintrag von
Code:
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
scheint es nun zu klappen. Das ist doch typisch Microsoft - lässt die Webseiten im Internet Explorer richtig darstellen und im Firefox nicht. Ich muss wohl nun eine Alternative zu Expression suchen - wobei das schwierig wird. Ich will auf jeden Fall ein Programm, was man vorher testen kann.

Viele Grüße,
Avicenna
 
Thema:

Schriftart stellt keine Umlaute dar

Sucheingaben

word wechselt schriftart umlaute

,

schriftart umlaute als potenz

,

schriftart umlaute

,
laptop schrift umlaute
, xml fonts umlaute werden nicht dargestellt

Schriftart stellt keine Umlaute dar - Ähnliche Themen

  • Benutzerdefinierten Schriftarten werden nicht vollständig angezeigt

    Benutzerdefinierten Schriftarten werden nicht vollständig angezeigt: Hallo, ich habe bestimmte benutzerdefinierte Schriftarten heruntergeladen (Schulschriften). Diese wurden auch installiert. Allerdings werden...
  • Nicht alle Schriftarten unter Windows 10 werden angezeigt, bzw. lassen sich ausführen.

    Nicht alle Schriftarten unter Windows 10 werden angezeigt, bzw. lassen sich ausführen.: Es werden die meisten Schriftarten nicht mehr angezeigt. Weder in den Officeprogrammen noch in anderen Programmen. Bei word kommt die folgende...
  • Lizenz von Microsoft Schriftarten

    Lizenz von Microsoft Schriftarten: Hi Microsoft Community, darf ich die Windows Schriftarten wie z.B Segoe UI Symbol oder Segoe UI Emoji für den kommerziellen gebrauch nutzen...
  • Schriftart Desktop / Unterschrift Icons

    Schriftart Desktop / Unterschrift Icons: Benutze ein SURFACE PRO 4. Desktopschrift unter Icons ist eine Schatten-Schrift. Schlecht lesbar. Wie und wo kann ich das ändern? Beste Grüße...
  • Probleme mit Schriftarten - gelöscht nach Neustart

    Probleme mit Schriftarten - gelöscht nach Neustart: Sehr geehrte Community, ich habe ein Problem bei einem Windows 10 PC. (Windows 10 1803 Pro x64) Hier werden diverse Schriften in...
  • Ähnliche Themen

    Oben