routing einträge

Diskutiere routing einträge im Linux Forum im Bereich Weitere Betriebssysteme; Hallo Leute! Kann mir jemand bei folgendem problem helfen? SuSe SLES 10 hat einige Routingeinträge und die verliert das Teil stets nach einem...
R

rainer11

Threadstarter
Dabei seit
01.04.2006
Beiträge
65
Hallo Leute!
Kann mir jemand bei folgendem problem helfen? SuSe SLES 10 hat einige Routingeinträge und die verliert das Teil stets nach einem Neustart; das heißt, im Yast stehen sie noch drin, aber sie greifen nicht mehr. Erst wenn ich sie mit "route add..." manuell nachtrage, funktionieren sie wieder.
Hat jemand eine Ahnung, was das sein könnte?
Rainer
 
HaraldL

HaraldL

Dabei seit
26.07.2006
Beiträge
6.031
Ort
Niederbayern
Hatte ich auch schon, zwar bei OpenSuse aber das dürfte gleich sein. Grund war in der /etc/sysconfig/network/routes daß für die Route kein Interface zugeordnet war. So wird anscheinend gleich nach dem Aktivieren des ersten Netzwerkinterfaces versucht alle Routen zu definieren obwohl evtl. eine weitere Netzwerkkarte noch gar nicht aktiviert wurde die für die Route aber notwendig ist. Es kam während des Hochfahrens beim Start des Netzwerks eine entsprechende Meldung daß die Route nicht gesetzt werden konnte. Da diese aber meist schnell nach oben rollt nimmt man sie evtl. nicht zur Kenntnis.

Man kann das Interface für jede Route mit Yast zuordnen, oder aber in der obigen Konfigurationsdatei manuell eintragen.

Beispiel:

Code:
192.168.46.0  192.168.1.4  255.255.255.0  eth-id-00:04:75:52:12:c2
default  192.168.2.1  -  eth2

Als 4. Parameter kann das Interface wahlweise in der Schreibweise "eth-id-..." oder einfach "ethX" stehen. Seit ich jeder Route ein Interface zugeordnet habe gibts keine Probleme mehr.
 
Thema:

routing einträge

routing einträge - Ähnliche Themen

Ping funktioniert, Internet Zugriff nicht: Hallo liebes Forum, aktuell bin ich dabei mir einen neuen PC zusammen zu bauen. Da die Teile relativ teuer sind, dachte ich, dass ich mal etwas...
Laptop geht regelmäßig aus dem WLAN und verbindet sich nicht mehr!?: Hallo erstmal, Ich habe einen Asus Laptop und mit diesem folgendes Problem: ich bin normal mit unserem private WLAN verbunden und alles läuft...
WLAN-Verbindung bricht nach ein paar Minuten ab - DNS FEHLER 1014: Hallo. Ich habe das Problem, dass aus unerfindlichen Gründen meine Wirelessverbindung ständig nach ca. 5 bis 10 Minuten (kein gleichbleibendes...
Fehlerhafte Einträge im Startmenü, löschen/verändern/nutzen unmöglich: Guten Tag liebe Community! häufig drücke ich die Windows Taste, das Startmenü öffnet und ich tippe einige Buchstaben um über die Suche schnell...
Surface Pro 3 verliert (seit Update) alle 1-2 Minuten WLAN-Verbindung: Remotedesktopverbindung Die Sitzung von Remotedesktopdienste wurde beendet. Die Verbindung mit dem Remotecomputer wurde vermutlich aufgrund von...
Oben