Probleme mit Framework 2.0 und Installer 3.1

Diskutiere Probleme mit Framework 2.0 und Installer 3.1 im WinXP - Software Forum im Bereich Windows XP Forum; Hallo, Leute. Ich brauche mal dringend Hilfe von ein paar Profis oder Solchen, die mir helfen können. Ich benötige für ein DVD-Tool Microsoft...
P

PARALAX

Threadstarter
Dabei seit
04.04.2007
Beiträge
14
Hallo, Leute.

Ich brauche mal dringend Hilfe von ein paar Profis oder Solchen, die mir helfen können. Ich benötige für ein DVD-Tool Microsoft Framework 2.0, welches ich jedoch nur mit Windows Installer 3.0 installieren kann. Genau hier liegt das Problem, denn sobald ich versuche, dies auf meinem Windows XP SP1 (nicht SP2) zu installieren, bekomme ich während der Installation die Meldung "Zugriff verweigert". Danach wird die Installation rückgängig gemacht und angezeigt das die Installation nicht richtig durchgeführt werden konnte, danach wird ein Neustart ausgeführt.

Ich habe mich schon stundenlang im Netz umgeschaut aber nichts hat geholfen, nichtmal das Unregistrieren und erneutem Registrieren des alten Installers.

Denn sobald ich "msiexec /unregister" und danach "msiexec /regserver" eingebe, bekomme ich nur die Meldung "Ein Ereignis konnte keine Abonennten aufrufen" angezeigt. Das Problem mit dem Installer besteht weiterhin.

Nun habe ich mir einen genauen LOG ausgeben lassen durch Eingabe von folgender Funktion:

WindowsInstaller-KB893803-v2-x86.exe /passive /norestart /log:c:\msifile.log

mit folgendem Ergebnis:

[msifile.log]
0.109: ================================================================================
0.109: 2007/04/04 15:28:28.718 (local)
0.109: f:\ab0c4a73b3a884662b8169b5\UPDATE\update.exe (version 6.1.22.4)
0.125: Hotfix started with following command line: /passive /norestart /log:c:\msifile.log
3.234: In Function TestVolatileFlag, line 11660, RegOpenKeyEx failed with error 0x2
3.234: In Function TestVolatileFlag, line 11692, RegOpenKeyEx failed with error 0x2
3.234: DoInstallation: CleanPFR failed: 0x2
3.250: SetProductTypes: InfProductBuildType=BuildType.Sel
3.250: SetAltOsLoaderPath: No section uses DirId 65701; done.
3.297: DoInstallation: FetchSourceURL for f:\ab0c4a73b3a884662b8169b5\update\update_wxp.inf failed
3.297: CreateUninstall = 1,Directory = C:\WINDOWS\$MSI31Uninstall_KB893803v2$
3.297: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll failed: 0xe0000102
3.297: BuildCabinetManifest: update.url absent
3.297: Starting AnalyzeComponents
3.297: AnalyzePhaseZero used 0 ticks
3.297: No c:\windows\INF\updtblk.inf file.
3.297: SetupFindFirstLine in LoadExclusionList Failed with error: 0xe0000102
3.297: SetupFindFirstLine in LoadExclusionList Failed with error: 0xe0000102
5.875: SetupOpenInfFile in IsThirdPartyInf Failed with error 0x2
9.422: SetupVerifyInfFile failed with error 0x490 for c:\windows\inf\oem32.inf of device PCI\VEN_10DE&DEV_0052&SUBSYS_0C111458&REV_A2\3&2411E6FE&0&09
10.078: SetupVerifyInfFile failed with error 0x490 for c:\windows\inf\oem26.inf of device PCI\VEN_10DE&DEV_005E&SUBSYS_50001458&REV_A3\3&2411E6FE&0&00
10.766: SetupVerifyInfFile failed with error 0x490 for c:\windows\inf\oem10.inf of device PCI\VEN_1102&DEV_7003&SUBSYS_00401102&REV_04\3&267A616A&0&49
10.828: SetupVerifyInfFile failed with error 0x490 for c:\windows\inf\oem10.inf of device PCI\VEN_1102&DEV_7003&SUBSYS_00401102&REV_04\4&13699180&0&4148
10.922: Failed to query DriverPath of PCI\VEN_1106&DEV_3188&SUBSYS_00000000&REV_01\3&267A616A&0&00 0x2
10.922: Failed to query DriverPath of PCI\VEN_1106&DEV_3227&SUBSYS_00000000&REV_00\3&267A616A&0&88 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_AFD\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_ARP1394\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_ATMARPC\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_BEEP\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_CTAC32K\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_CTPRXY2K\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_CTSFM2K\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_DMBOOT\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_DMLOAD\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_ELBYCDIO\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_EMUPIA\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_ENTECH\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_FASTTX2K\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_FIPS\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_GDRV\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_GPC\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_GVCPLDRV\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_HA10KX2K\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_HAP16V2K\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_IPNAT\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_IPSEC\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_IRDA\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_KSECDD\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_MNMDD\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_MODEM\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_MOUNTMGR\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_NDIS\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_NDISTAPI\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_NDISUIO\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_NDPROXY\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_NETBT\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_NULL\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_OSSRV\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_PARTMGR\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_PARVDM\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_PFMODNT\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_PFSVGAE\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_PRODRV06\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_PROHLP02\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_PROSYNC1\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_QDFSDRV\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_RASACD\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_RDPCDD\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_SECDRV\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_SFDRV01\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_SFHLP01\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_SFHLP02\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_SFSYNC02\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_SFVFS02\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_TCPIP\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_TEEFER\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_U3SHLPDR\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_VGASAVE\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_VIAIDE\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_VIASRAID\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_VOLSNAP\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_WANARP\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_WG3N\0000 0x2
11.188: Failed to query DriverPath of ROOT\LEGACY_WPSDRVNT\0000 0x2
14.016: SetupVerifyInfFile failed with error 0x490 for oem6.inf of device USB\VID_2001&PID_400B\5&3278073A&0&1
15.625: OEM file scan used 12328 ticks
15.953: AnalyzePhaseOne: used 12656 ticks
15.953: AnalyzeComponents: Hotpatch analysis disabled; skipping.
15.953: AnalyzeComponents: Hotpatching is disabled.
15.953: AnalyzePhaseTwo used 0 ticks
15.953: AnalyzePhaseThree used 0 ticks
15.953: AnalyzePhaseFive used 0 ticks
15.953: AnalyzePhaseSix used 0 ticks
15.953: AnalyzeComponents used 12656 ticks
15.953: Downloading 0 files
15.953: bPatchMode = FALSE
15.953: Inventory complete: ReturnStatus=0, 12656 ticks
15.953: Num Ticks for invent : 12656
15.953: Conditional load of section MSI.Reg.Install.Condition succeeded
15.953: Allocation size of drive C: is 4096 bytes, free space = 35490312192 bytes
15.953: AnalyzeDiskUsage: Skipping EstimateDiskUsageForUninstall.
15.953: Drive C: free 33846MB req: 10MB w/uninstall: NOT CALCULATED.
15.953: CabinetBuild complete
15.953: Num Ticks for Cabinet build : 0
15.953: DynamicStrings section not defined or empty.
15.969: FileInUse:: need to restart already, turn off
15.969: FileInUse:: Add to list - Service Name: msiserver
16.969: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll failed: 0xe0000102
17.031: Num Ticks for Backup : 1078
17.438: Num Ticks for creating uninst inf : 407
17.438: Registering Uninstall Program for -> KB893803v2, KB893803v2 , 0x0
17.438: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll failed: 0xe0000102
17.594: Kopierte Datei: C:\WINDOWS\System32\spmsg.dll
17.594: PFE2: Not avoiding Per File Exceptions.
17.625: GetCatVersion: Failed to retrieve version information from C:\WINDOWS\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\KB893803v2_wxp.cat with error 0x57
17.625: GetCatVersion: C:\WINDOWS\KB893803v2_wxp.cat has version of 0, this may indicate error converting version string.
18.078: Kopierte Datei: C:\WINDOWS\System32\msi.dll
18.094: Kopierte Datei: C:\WINDOWS\System32\msiexec.exe
18.125: Kopierte Datei: C:\WINDOWS\System32\msihnd.dll
18.156: Kopierte Datei: C:\WINDOWS\System32\msimsg.dll
18.172: Kopierte Datei: C:\WINDOWS\System32\msisip.dll
18.203: Kopierte Datei: C:\WINDOWS\System32\DllCache\msi.dll
18.203: Kopierte Datei: C:\WINDOWS\System32\DllCache\msiexec.exe
18.219: Kopierte Datei: C:\WINDOWS\System32\DllCache\msihnd.dll
18.219: Kopierte Datei: C:\WINDOWS\System32\DllCache\msimsg.dll
18.234: Kopierte Datei: C:\WINDOWS\System32\DllCache\msisip.dll
18.234: DoInstallation: Installing assemblies with source root path: f:\ab0c4a73b3a884662b8169b5\
18.234: Num Ticks for Copying files : 796
18.281: DoRegistryUpdates:UpdSpInstallFromInfSection Failed for MSI.Reg.Install: 0x5
18.281: DoInstallation:DoRegistryUpdates failed
18.641: Zugriff verweigert
18.641: Die Installation des KB893803v2 wurde nicht abgeschlossen.

Klicken Sie auf "OK", um die durchgeführten Änderungen zurückzunehmen.
18.641: Prozess wird gestartet: C:\WINDOWS\$MSI31Uninstall_KB893803v2$\spuninst\spuninst.exe /~ -u -z
20.141: Software Update Rollback has completed with return code 0xbc2. This rollback requires a reboot.
20.141: Die Installation des KB893803v2 wurde nicht abgeschlossen.

Windows Installer wurde teilweise aktualisiert und funktioniert eventuell nicht richtig.
20.141: Update.exe extended error code = 0x5
20.141: Update.exe return code was masked to 0x643 for MSI custom action compliance.
Leider bringt mich das überhaupt nicht weiter. Nichtmal das Installer-Reperaturprogramm "msicuu2" bekomme ich an's Laufen, da es angeblich einen "ActiveX-Komponenten kann kein Object erstellen: 'Scripting.FileSystemObject' - Laufzeitfehler in Microsoft VBScript" gibt (Code 800A01AD).

Was kann ich überhaupt noch tun? Bitte helft mir, ich bin für jede Info dankbar!
 
T

thecaptain

Dabei seit
19.06.2006
Beiträge
1.631
Alter
37
Ort
Nordthüringen
bist du admin?

und was ansich noch viel wichtiger ist: wieso installierst du dir denn kein sp2?

mfg
 
P

PARALAX

Threadstarter
Dabei seit
04.04.2007
Beiträge
14
Ja klar, habe das System ja nur unter meinem Namen installiert. Unter Benutzerkonten stehe ich dort auch als "Computeradministrator". Und SP2 vermeide ich wegen der Windows Firewall und einigen anderen Dingen, die ich für unnötig halte. Bisher war das auch nie das Problem...bis heute.

Wie kann ich die Einstellungen überprüfen? Gibt es keine andere Möglichkeit ausser dieses Service Pack?
 
T

thecaptain

Dabei seit
19.06.2006
Beiträge
1.631
Alter
37
Ort
Nordthüringen
sieht ganz schlecht aus. ausserdem ist das sp2 nicht unnötig sondern viel eher essenziell für einen sicheren betrieb. auf nem anderen weg wirst du das problem wohl nicht hinbekommen.

mfg
 
spacelord

spacelord

Dabei seit
26.06.2006
Beiträge
887
Alter
52
Ort
Nürnberg
genau SP2 ist einfach notwendig.
Allerdings kann man den Installer3.1 auch ohne SP2 installieren.
und die FW kann man ausmachen wenn man sie einfach nicht will
 
P

PARALAX

Threadstarter
Dabei seit
04.04.2007
Beiträge
14
3.0 ist die Version, die von Framework verlangt wird aber weder 3.0 noch 3.1 lässt sich bei mir installieren. Ich kann mir auch ehrlich gesagt nicht vorstellen, das man das Problem nicht auch anders lösen könnte. Da muß doch irgendwo der Wurm in der Registry sein. Mit SP2 direkt hat das sicher nichts zu tun.
 
P

PARALAX

Threadstarter
Dabei seit
04.04.2007
Beiträge
14
Jetzt hab Ich's

secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose /areas REGKEYS

Setzt die Registry-Zugriffsrechte wieder auf Standardwerte zurück-

Trotzdem Danke, hat sich somit erledigt.:blush
 
Thema:

Probleme mit Framework 2.0 und Installer 3.1

Probleme mit Framework 2.0 und Installer 3.1 - Ähnliche Themen

  • Probleme bei der Installation von .NET Framework(jegliche Version)

    Probleme bei der Installation von .NET Framework(jegliche Version): Schönen guten Tag, Ich habe heute ,mich dazu entschieden, mein .NET Framework zu updaten, da ein Programm welches ich Installieren wollte, meinte...
  • Probleme mit .NET Framework 3.5 (Fehlercode 0x8007000D)

    Probleme mit .NET Framework 3.5 (Fehlercode 0x8007000D): Guten Tag, Beim Start eines Programmes, erscheint mit die Meldung, dass .NET Framework 3.5 (enthält .NET 2.0 und 3.0) nicht installiert ist...
  • Programme nicht mehr installierbar wegen Net. Framework problemen

    Programme nicht mehr installierbar wegen Net. Framework problemen: Hallo zusammen, seit ich Windows neu aufgesetzt habe kann ich viele Programme nicht neu installieren, da die Microsoft .NET Framewok version 4.5...
  • Probleme mit Interneteinstellungen,IE,Framework

    Probleme mit Interneteinstellungen,IE,Framework: Hallo, versuche nun seit 3 stunden irgendwas zum laufen zu bringen. es lässt sich nichts öffnen es weil die interneteinstellungen es nicht...
  • Ähnliche Themen
  • Probleme bei der Installation von .NET Framework(jegliche Version)

    Probleme bei der Installation von .NET Framework(jegliche Version): Schönen guten Tag, Ich habe heute ,mich dazu entschieden, mein .NET Framework zu updaten, da ein Programm welches ich Installieren wollte, meinte...
  • Probleme mit .NET Framework 3.5 (Fehlercode 0x8007000D)

    Probleme mit .NET Framework 3.5 (Fehlercode 0x8007000D): Guten Tag, Beim Start eines Programmes, erscheint mit die Meldung, dass .NET Framework 3.5 (enthält .NET 2.0 und 3.0) nicht installiert ist...
  • Programme nicht mehr installierbar wegen Net. Framework problemen

    Programme nicht mehr installierbar wegen Net. Framework problemen: Hallo zusammen, seit ich Windows neu aufgesetzt habe kann ich viele Programme nicht neu installieren, da die Microsoft .NET Framewok version 4.5...
  • Probleme mit Interneteinstellungen,IE,Framework

    Probleme mit Interneteinstellungen,IE,Framework: Hallo, versuche nun seit 3 stunden irgendwas zum laufen zu bringen. es lässt sich nichts öffnen es weil die interneteinstellungen es nicht...
  • Oben