Problem mit net use auf WindowsXP Client

Diskutiere Problem mit net use auf WindowsXP Client im Windows Server 2000 Forum im Bereich Server Systeme; Hallo, bevor ich mein Problem schildere möchte ich kurz meine Umgebung beschreiben: Ich arbeite mit einem Windows 2000 Server (Name: ORION)...
M

martin2002

Threadstarter
Mitglied seit
23.08.2005
Beiträge
5
Hallo,

bevor ich mein Problem schildere möchte ich kurz meine Umgebung beschreiben:
Ich arbeite mit einem Windows 2000 Server (Name: ORION). Dieser fungiert als DHCP und DNS Server und als Domänencontroler. Im Netzwerk sind eigentlich nur Windows XP Clients angeschlossen, es ist lediglich ein Windows 2000 Client vorhanden.

Nun zum Problem:
Über ein Anmeldescript (batch) sollen neben einigen Netzlaufwerken auch ein Netzwerdrucker mit einen lokalen Port (lpt1) verbunden werden. Im Script werden dafür folgende Zeilen verwendet:
Code:
ECHO +---Verbinde Netzwerkdrucker-----------------+
net use lpt1 /DELETE
net use lpt1 \\ORION\KOPIERER /persistent:yes
Beim Ausführen dieser Zeilen verlangt die Konsole (an allen Windows XP Clients) nach der Eingabe von Benutzernamen und Kennwort um die Verbindung zu autoriesieren... Egal welchen Benutzer ich nehme (sogar der Domänen-Admin), die Verbindung wird verweigert!
Ausgabe der Konsole:
>net use lpt1 \\orion\kopierer
Das Kennwort für \\orion\kopierer ist ungültig.

Geben Sie den Benutzernamen für "orion" ein: KRELLMANN\Administrator
Geben Sie das Kennwort für "orion" ein:
Systemfehler 5 aufgetreten.

Zugriff verweigert
Am Windows 2000 Client wird man aber weder zur Eingabe eines Logins aufgefordert, noch schlägt die Verbindung fehl... Hier funktioniert es tadellos.

Ist es möglich das der Fehler daraus resultiert, dass ich das Anmeldescript auf den Windows XP Clients lokal per Autostart des Benutzers ausführe? Ist eine Notlösung, weil die XP-Clients es nicht automatisch ausführen, so wie es eigentlich in der Gruppenrichtlinie für die Domäne angegeben ist. Könnte das eigentliche problem hier liegen?
Die Richtlinie wird an den XP-Clients nur bei Anmeldung als Domänen-Admin übernommen und demzufolge das Anmeldescript automatisch ausgeführt - hier wird auch keine Eingabe von einem extra Login verlangt.
Außerdem gilt auch hier wieder: Der Win2k rechner übernimmt die Richtlinie für alle User ohne murren - nicht nur für den Admin!

Wie kann ich herausfinden, wie diese Fehler zusammenhängen, bzw. wie finde ich heraus warum die Gruppenrichtlinie der Domäne an den XP-Clients nur für Domänen-Admins übernommen wird, nicht aber für Domänen-User. Ich vermute nämlich, dass die beiden Probleme zusammenhängen da ja beim Admin kein extra Login in der Konsole verlangt wird.

thx
Martin
 
M

martin2002

Threadstarter
Mitglied seit
23.08.2005
Beiträge
5
Eine Anmerkung:
Nachdem ich diesen Thread erstellt hatte, hab ich noch einen Einfall gehabt:
Ich habe das mal in einem neuen Thread im XP-Board festgehalten, weil das meiner Meinung nach eher die XP-Clients betrifft als Einstellungen auf dem Server:
http://www.winboard.org/index.php?showtopic=33810

Ich habe nämlich mal testweise die Gruppe Domänen-Benutzer zu den lokalen Administratoren an einem Client hinzugefügt und die oben beschriebenen Porbleme waren verschwunden.

thx
Martin
 
Andy

Andy

Administrator
Team
Mitglied seit
16.08.2001
Beiträge
12.370
Alter
44
Standort
Wilder Süden
Mit NET USE LPT1 willst du praktisch einen lokalen Drucker installieren, was nur Administratoren dürfen. Deshalb schlägt das Ganze mit "Systemfehler 5" fehl.

Verwende statdessen das Tool CON2PRT aus dem ResourceKit.
con2prt /cd \\server\printername

Oder den folgenden Befehl
rundll32 printui.dll,PrintUIEntry /in /y /n\\server\printername


Wegen der Kannwortabfrage solltest du mal die Rechte auf den Drucker prüfen. Sind die Clients in der gleichen Domäne wie der Rpintserver ?
 
M

martin2002

Threadstarter
Mitglied seit
23.08.2005
Beiträge
5
der printserver ist quasi der domänencontroller...

dann ist es doch aber sehr seltsam, dass es auf dem win2k client auch ohne admin rechte funktioniert?
 
Thema:

Problem mit net use auf WindowsXP Client

Problem mit net use auf WindowsXP Client - Ähnliche Themen

  • Problem bei der Installation des 2019-02 Sicherheits- und Qualitätsrollup für .NET Framework ... (KB4487080)

    Problem bei der Installation des 2019-02 Sicherheits- und Qualitätsrollup für .NET Framework ... (KB4487080): Hallo, beim Versuch das o.g. Update bzw. die optionalen Updateszu installieren erhalte ich immer die Fehlermeldung 80073712. Auch die...
  • LÖSUNG ZUM PROBLEM .NET FRAMEWORK 3.5 BEI VERSION 1709 (Bulid 16299.64)

    LÖSUNG ZUM PROBLEM .NET FRAMEWORK 3.5 BEI VERSION 1709 (Bulid 16299.64): Also die Lösung zu meinem Problem ist die ihr ladet euch MediaCreationTool runter und geht auf Updaten so das ihr auf eine neue Version kommt im...
  • Problem mit net use-batch in Autostart

    Problem mit net use-batch in Autostart: Servus, habe ein kleines Phänomen bei meinem PosReady2009-Rechner: es soll automatisch eine bestimmte Netzwerkverbindung gemappt werden...
  • .NET Framework 4 Problem

    .NET Framework 4 Problem: Hallo :D Ich habe ein Problem :wut Undzwar kann ich .NET Framework 4 nicht installieren :cheesy Es klappt einfach nicht :mad Ich habs schon 4x neu...
  • GELÖST net use batch datei problem

    GELÖST net use batch datei problem: hallo, ich habe von einem bekannten den auftrag bekommen, seinen seine 2 notebooks mit seinem lokalen drucker zu verbinden. er hat auf seinem...
  • Ähnliche Themen

    Oben