Problem mit IDE und SATA (schlechte Performance)

Diskutiere Problem mit IDE und SATA (schlechte Performance) im WinXP - Hardware Forum im Bereich Windows XP Forum; Hallo Ich habe mir vor kurzem den SATA-Controller Promise SATA300 TX2plus mit einer Samsung SATA500 GB Platte gekauft um diese zu meinen...

basti23

Threadstarter
Dabei seit
07.06.2007
Beiträge
16
Alter
41
Hallo

Ich habe mir vor kurzem den SATA-Controller Promise SATA300 TX2plus mit einer Samsung SATA500 GB Platte gekauft um diese zu meinen bisherigen IDE-Platten zu hängen (Mainboard hat keinen SATA-Anschluss, ASUS A7N8X-X). Seit das passiert ist lässt die Performance extrem zu wünschen übrig, bei einfachen Zugriffen wie Abspielen von Musikdateien von der SATA Platte wird das ganze System extrem langsam (CPU-Last auf dem jeweiligen Programm, zB Winamp, Mauszeiger bewegt sich ruckelartig). Hat jemand ne Idee was das Problem sein könnte?
Es befindet sich ein frisch aufgesetztes Windows auf der IDE-Platte, mit allen Updates und den aktuellsten Treibern für das Mainboard und den Promise Controller.

Danke im vorraus
Basti
 

HWFlo

Dabei seit
04.09.2005
Beiträge
5.271
Alter
32
Du solltest mal prüfen ob das ganze auch im DMA Modus läuft
 

Mike

i7-6700HQ
Dabei seit
21.09.2006
Beiträge
24.384
Ort
Outdoor oder vorm Rechner
Das Problem wird sein, dass die Verwaltung des Kontrollers eine ziemliche Belastung für den Computer ist.

Mach mal mehr Angaben zu deiner Rechnerleistung (CPU, RAM ...)

Sind irgendwelche Fehler im Gerätemanager ? (ausgeblendete Objekte auch überprüfen!)
 

basti23

Threadstarter
Dabei seit
07.06.2007
Beiträge
16
Alter
41
Also Danke euch erstmal für die Antworten!!!!

Das ist ein Athlon XP2600 mit 1,5 GB Ram. Dass SATA und PATA in Kombination nicht so optimal sind da der CPU von seriell auf parallel umrechnen muss hab ich gewusst, aber ich dachte eben dass der Controller nen grossen Teil dieser Arbeit übernimmt. Fehler im Gerätemanager treten keine auf.
 

APFEL 2c

Dabei seit
22.05.2007
Beiträge
565
Hallo

Ich habe mir vor kurzem den SATA-Controller Promise SATA300 TX2plus mit einer Samsung SATA500 GB Platte gekauft um diese zu meinen bisherigen IDE-Platten zu hängen (Mainboard hat keinen SATA-Anschluss, ASUS A7N8X-X). Seit das passiert ist lässt die Performance extrem zu wünschen übrig, bei einfachen Zugriffen wie Abspielen von Musikdateien von der SATA Platte wird das ganze System extrem langsam (CPU-Last auf dem jeweiligen Programm, zB Winamp, Mauszeiger bewegt sich ruckelartig). Hat jemand ne Idee was das Problem sein könnte?
Es befindet sich ein frisch aufgesetztes Windows auf der IDE-Platte, mit allen Updates und den aktuellsten Treibern für das Mainboard und den Promise Controller.

Danke im vorraus
Basti


SATA1/2 über den ohnehin durch andere Komponenten belasteten und langsamen PCI BUS zu betreiben ist nicht wirklich eine glückliche Lösung.

Da auch dein Sockel-A System anscheinend sehr instabil wird, würde ich einmal sehen ob es für deinen Promise SATA Controller eventuell ein Firmware Update gibt und eventuell noch andere Versionen des System-Treibers, um einfach einmal zu testen welcher in deinem System die beste Performance bietet und bei welchen dein System am stabilsten läuft!

Die Datenrate deiner Laufwerke kann man gut über einen System-Benchmark mit SiSoftware Sandra Standard (Freeware) testen und vergleichen.

Auf meinen CAD-Systemen lasse ich auch noch ein älteres und sehr stabil laufendes SCSI Backup-System (2x Laufwerke in Wechselrahmen) über einen SYMBIAN Controller (PCI) mit etwa 40MB/sec. arbeiten, aber das ist dann auch als "kurze" Last und im Zugriff über den PCI BUS so meine Schmerzgrenze!

Kenne nicht den Preis deines Promise SATA Controllers und habe nur Daten von anderen ähnlichen, die irgendwo als preiswertes Produkt zwischen 40 und 100 Euro liegen!

Wenn er um die 80 Euro gekostet hat und du ihn noch umtauschen kannst!

Ein gutes schnelles AM2 Board mit PCI & AGP (z.B.: ASRock AM2NF3 VSTA AM2 DDR2/AGP/SATA/LAN/7.1 oder ein MSI K9MM-V AM2 DDR2/SATA/AGP/K8M800) mit einem mittleren Prozessor (Athlon 64 3000+) und 512 MB DDR2 Speicher kosten heute auch nicht mehr als 100-120 Euro und du kannst deine SATA HDD wirklich benutzen!

MfG
 

Honni

Hardwarepapst
Dabei seit
12.09.2005
Beiträge
424
Hallo basti23,

ich hätte evtl. noch eine Lösung für dich:

Da sich einige PCI-Steckplätze mit dem AGP und auch anderen Systemkomponenten (Controllern, SoundonBoard etc.) die IRQs teilen müssen, können bei gleichzeitiger Inanspruchnahme des selben IRQ heftige Perfomanceeinbrüche die Folge sein. Also stecke den SATA-Controller mal abwechselnd in die anderen PCI-Slots und prüfe dann, wie sich dein System verhält.

Ein Firmware-Update des Controllers sollte aber, wie schon von APFEL 2c empfohlen, auch durch geführt werden, evtl. neuere bzw. ältere (hilft manchmal!) Treiber für den SATA-Controller installieren.
Ich denke die aktuellen Chipsatztreiber für dein Mainboard hast du ja schon drauf...

cu Honni
 

basti23

Threadstarter
Dabei seit
07.06.2007
Beiträge
16
Alter
41
Hi

Dass ich durch den Flaschenhals PCI nicht das maximum rausholen kann ist klar, jedoch sollten ca 80-100 MB/s machbar sein da der Bus ja 133 MB/s schafft (32 bit x 33 Mhz). Der PCI Bus ist auch nicht durch andere Komponenten belastet, da hängt wirklich nur der Controller. Treiber hab ich schon alle ausprobiert die der Hersteller anbietet und auch die Firmware ist aktuell. Der Preis des Controllers lag bei 50 €. Das mit dem neuen Mainboard ist ne überlegung wert, jedoch würde mich interessieren woher diese groben Aussetzer bei meinem momentanen System kommen.

Danke für eure Bemühungen!!!!!!!!!
 

basti23

Threadstarter
Dabei seit
07.06.2007
Beiträge
16
Alter
41
@Honni

Das mit dem IRQ ist ne gute Idee, danke vielmals für den Tip
 

basti23

Threadstarter
Dabei seit
07.06.2007
Beiträge
16
Alter
41
Bin leider noch nicht zuhause, werde es machen sobald ich da bin
 

basti23

Threadstarter
Dabei seit
07.06.2007
Beiträge
16
Alter
41
Super! Scheint geklappt zu haben, lasse gerade mal Benchmarks laufen und werde heute Abend noch mal ein update schreiben.

Vielen Dank für alle eure Bemühungen,

Basti
 
Thema:

Problem mit IDE und SATA (schlechte Performance)

Problem mit IDE und SATA (schlechte Performance) - Ähnliche Themen

GELÖST Energiespar-Plattform für Netzlaufwerk "Server"?: Hallo Leute, ich stecke in der Zwickmühle. Ich beschreibe mal alles, vielleicht brauch ich nichts neues? IST: Asus A7N8X-E Deluxe REV.2 Duron...
ständig versch. Bluescreens! Welche Treiber? vielleicht AHCI-Problem?: Hi Leute, ich habe folgendes Problem: Habe mir einen neuen PC gekauft (selbst zusammengestellt), windows 7 64 bit und treiber installiert und...
Problem mit doubleboot XP/XP64 (IDE und SATA): Hallo zusammen, ich habe ein großes Problem, nachdem ich auf meinem PC Windows XP 64 installiert habe. In meinem Rechner ist eine IDE-Festplatte...
Sechs Festplatten-Imager im Test: Karsten Violka Sicherheits-Klone Sechs Festplatten-Imager für die Systemsicherung Indem Sie ein Abbild Ihrer Systempartition anfertigen und es...
Oben