[OpenSuse] Yast hässlich bis unbenutzbar über Putty

Diskutiere [OpenSuse] Yast hässlich bis unbenutzbar über Putty im Linux Forum im Bereich Linux; Hi, weiß jemand was ich in Putty umstellen muss damit Yast nicht mehr so hässlich aussieht wie auf dem Screenshot? :unsure: Die Zeichen des...
#1
DiableNoir

DiableNoir

Threadstarter
Dabei seit
18.01.2004
Beiträge
6.069
Hi,

weiß jemand was ich in Putty umstellen muss damit Yast nicht mehr so hässlich aussieht wie auf dem Screenshot? :unsure:

Die Zeichen des Menüs werden durch andere Buchstaben ersetzt und verursachen, dass man viele Einträge in einigen Modulen gar nicht mehr richtig erkennen kann. (Für die Zeichencodierung verwende ich eigentlich bereits UTF)

Auf der lokalen Konsole werden die Zeichen richtig dargestellt. Auch die Linux-Clients stellen alles normal dar. Es muss also an Putty bzw. sogar Windows liegen.
 

Anhänge

#2
automatthias

automatthias

vernunftgeplagt
Dabei seit
21.04.2006
Beiträge
7.281
Ich glaube, Yast braucht ISO 8859-1

Ich habe leider gerade nur ein altes SuSe zur Hand. Da habe ich das so eingestellt (s. Bild)
2009-09-10_080558.jpg

Und es hängt m.E. auch vom verwendeten Font ab. Ein sehr schöner Terminal-Font ist übrigens Liberation Mono
 
Zuletzt bearbeitet:
#3
DiableNoir

DiableNoir

Threadstarter
Dabei seit
18.01.2004
Beiträge
6.069
:danke

Offenbar verwenden auch die "modernen" Versionen immer noch die alte ISO-Codierung. Eigentlich hätte ich auch selber darauf kommen können, aber ich hätte nicht gedacht, dass es noch Distris gibt die nicht UTF verwenden. :wacko:

Schon seltsam, dass die Clients unter Linux das offenbar automatisch erkennen, Putty dagegen nicht. Naja, mal sehen wie ich den SSH-Server auf UTF umstellen kann. Einige eigene Programme von mir setzen das nämlich voraus. :sleepy ...außerdem tragen einige Verzeichnisse bei mir japanische Namen. :D
 
#4
HaraldL

HaraldL

Dabei seit
26.07.2006
Beiträge
5.733
Ort
Niederbayern
Ich habe es jetzt gerade mal aus Jux mit PuTTY probiert, bei mir klappt das:
- OpenSuse 11.0
- PuTTY Release 0.60
- Font "Liberation Mono" (danke automatthias für den Tipp, der ist wirklich super!)

Ich habe in den Einstellungen folgendes umgestellt:
- Terminal/Keyboard: Function Keys and keypad: "Linux"
- Window/Appearance: Font "Liberation Mono"
- Window/Translation: Character Set UTF-8
- Window/Translation: Handling of drawing characters: "Use Unicode line drawing ..."
- Connection/Data: Terminal-type string: "linux" (das dürfte das Entscheidende sein)

Mit dem Default-Terminal-type string "xterm" bekam ich auch den Buchstabensalat, offensichtlich sagt das dem Server daß der Client wohl kein UTF kann. Normalerweise verwende ich nicht PuTTY sondern VanDyke SecureCRT 6, und das eigentlich schon lange mit UTF wobei ich hier nichts umstellen mußte, der sendet wohl gleich den richtigen Terminal-Typ.
 

Anhänge

#5
DiableNoir

DiableNoir

Threadstarter
Dabei seit
18.01.2004
Beiträge
6.069
- Connection/Data: Terminal-type string: "linux" (das dürfte das Entscheidende sein)
Stimmt...Das ändert die Darstellung. :danke:

Seltsam...Debian war das ziemlich egal und Aptitude setzt ja auch diese Linien ein. Außerdem wurden ja auch die japanischen Verzeichnisnamen trotz "xterm" richtig angezeigt. :unsure:

Edit:
Ich verwende immer als Font "Lucida Console" für Putty, weil es auf jedem Windows-System vorhanden ist.
 
#6
H

h3r3tic

Dabei seit
14.02.2004
Beiträge
831
Alter
37
Ort
Berlin
Hallo ich habe dieses Problem auch unter Suse Linux Enterprise Server 10 und dort verhält es sich wie folgt.

Yast zeigt bei Latin 1 .. alles richtig an
MC zeigt die merkwürdigen Zeichen an wie bei DiableNoir unter Yast

Wenn ich das ganze umstelle auf UTF-8 dreht sich das ganze wieder
Yast zeigt merkwürdige Zeichen an
MC hat die richtige Darstellung.

Unabhängig von Latin1 oder UTF-8 ändert die Angabe des Terminals ("linux") bei mir nichts.

Daraus schließe ich eigentlich das der MC UTF-8 kompatibel ist und Yast nicht.

Wie sieht das unter OpenSuse aus?
 
#7
DiableNoir

DiableNoir

Threadstarter
Dabei seit
18.01.2004
Beiträge
6.069
Wie sieht das unter OpenSuse aus?
Unter OpenSuse hat bei mir die Angabe von "linux" statt "xterm" ausgereicht. Auch der MC wird richtig dargestellt. Als Zeichencode verwende ich aber noch zusätzlich UTF-8.

Ist bei dir unter Translation die Verwendung von Unicode für Linien (erste Option) eingstellt?

Wo werden den merkwürdige Zeichen angezeigt? (Screenshot?)
 
Thema:

[OpenSuse] Yast hässlich bis unbenutzbar über Putty

Sucheingaben

putty zeichensatz opensuse

,

sles putty double tab

,

putty yast anzeige

,
putty linux yast zeichen
, suse linux administration putty, yast, opensuse yast forum, putty yast darstellung

[OpenSuse] Yast hässlich bis unbenutzbar über Putty - Ähnliche Themen

  • Dualboot System Windows10Pro 1607 15063.608 und OpenSuse 42.3 amd64 inaccessible boot device / mbr /

    Dualboot System Windows10Pro 1607 15063.608 und OpenSuse 42.3 amd64 inaccessible boot device / mbr /: Hallo, ich habe auf meiner 256 GB SSC Festplatte 2 OS Windows 10Pro 15063.608 und OpenSuse 42.3 installiert, ich nutze noch mbr und nicht UEFI...
  • GELÖST Dualboot Windows 8.1 und openSUSE 13.1 UEFI

    GELÖST Dualboot Windows 8.1 und openSUSE 13.1 UEFI: Nabend zusammen, ich möchte openSUSE zusätzlich installieren...habe Windows 8.1 schon seit längerem drauf und wenn ich dann eine Live CD von...
  • Opensuse: Version 11.0 wird nicht mehr gepflegt

    Opensuse: Version 11.0 wird nicht mehr gepflegt: Marcus Meissner vom Opensuse-Team hat in einer E-Mail das Ende der Unterstützung für Opensuse 11.0 bestätigt. Ein letzter Patch war am 23. Juli...
  • Erster Meilenstein von OpenSuse 11.3 mit LXDE

    Erster Meilenstein von OpenSuse 11.3 mit LXDE: Quelle und ganzer Bericht bei Heise.de
  • GELÖST OpenSuse 11.2 via USB Stick installieren

    GELÖST OpenSuse 11.2 via USB Stick installieren: Hallo, wie oben schon beschrieben, würde ich gerne auf meinem Netbook (LG X110) OpenSuse 11.2 installieren. Ist dies überhaupt möglich? Die...
  • Ähnliche Themen

    Oben