Nvidia Kernel auf SuSE 8.0 installieren

Diskutiere Nvidia Kernel auf SuSE 8.0 installieren im Linux Forum im Bereich Weitere Betriebssysteme; Ich hab eine Geforce Grafikkarte und möchte den Kernel von Nvidia installieren. Ich hab die beiden Dateien runtergeladen nur ich kann sie nicht...

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Ich hab eine Geforce Grafikkarte und möchte den Kernel von Nvidia installieren. Ich hab die beiden Dateien runtergeladen nur ich kann sie nicht installieren. Wenn ich die Dateieen anklicke gibt er die Fehlermeldung Abfrage von /Daten/root/system/nvidia_kernel.rpm fehgeschlagen aus.
 

stpe

Dabei seit
14.11.2001
Beiträge
2.729
Du musst (z.b.) das programm kpackage starten, um rpm-dateien installieren zu können.
 

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Mit dem Programm gibts genau die gleiche Fehlermeldung
 

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Ich hab beide installiert bekommen, nur wo der Login-Screen war ist jetzt alles schwarz und oben links blinkt ein Cursor. Man kann nur nichts eingeben
 

stpe

Dabei seit
14.11.2001
Beiträge
2.729
ich denke, dann hast Du die falschen treiber installiert. jetzt musst Du die alten erstmal wieder loswerden:

drück bei dem von Dir beschriebenen bildschirm mal die tastenkombination
Code:
<strg>+<alt>+<f1>
.

dann solltest Du einen login bekommen. melde Dich als root an und wechselst erstmal mit
Code:
init 3
in den runlevel 3 (also ohne xfree).

suche danach mit dem befehl:
Code:
rpm -qa |grep -i nvidia
die treiber-pakete. danach deinstallierst Du die pakete mit:
Code:
rpm -e NVIDIA_GLX-1.0-2960
rpm -e NVIDIA_kernel-1.0-2960.rh73up
benutze hier natürlich die namen, die Du mit "rpm -qa ..." vorher ermittelt hattest!

anschliessend sollte Dein rechner mit:
Code:
init 5
wieder xfree starten können.

jetzt musst Du Dir von der nvidia-seite die richtigen treiber runterladen (für Deine distri wahrscheinlich die treiber mit der endung "up" (ein-prozessor). damit sollte die installation erfolgreich verlaufen.
 

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Ich hab mein System wieder am laufen. Nur ich hab auf nvidia.de und .com nur die Treiber gesehen, die ich schon runtergeladen hatte. Seit ich dieses GLX Package installiert hatte funktionierte nichts mehr. Der Kernel ging ohne Probleme.
 

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Sorry, ich habs doch gefunden. Man sollte auch auf den FTP-Server gucken!
 

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Ich habs nochmal versucht. Soblad ich die GLX installiert hab geht gar nichts mehr. Jetzt sogar mit dem entfernen nicht mehr. Will ich xfree starten kommt ein schwarzer Screen und geht wieder. Das 5 oder 6 mal und dann lande ich wieder in der Konsole.

Mein System:
SuSE 8.0
2*80GB IBM
AMD Thunderbird 900
MSI KT3 Ultra2 mit Via KT 333
Asus AGP-V6800 (Geforce DDR)
Typhoon Soundkarte
Toshiba DVD-Rom
3Com Netzwerkkarte
 

mastermind

Dabei seit
02.02.2002
Beiträge
286
Hallo,

da du SuSE 8.0 benutzt gehe ich mal davon aus das du xFree 4.2.0 oder höher bereits installiert hast... ?!

Ansonsten ist auch noch wichtig das du keine alten Mesa Treiber installiert hast ! Entferne diese wenn, bitte.

Ansonsten mußt du noch in der X config, zu finden unter /etc/X11/Xf86config
(ohne Gewähr..)

Die beiden zeilen hinzufügen:
Einmal unter Module

Load "glx"

und noch etwas...... aber das hab ich vergessen .... :nixweis
mhh sollte es mir einfall medle ich mich ...

Versuche das bitte mal ... wenn es dann noch nicht geht meld dich noch mal ...
 

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Ja ich nutzte XFree4.2.0. Ich habs probiert, ging aber trozdem nicht.

Kann mir mal jemand sagen welchen Kernel und welche GLX ich genau brauche. Unter nvidia.de und auf dem FTP-Server gibts mehrere und zwei Versionsnummern einmal 2960 und 3123.
 

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Ich hab meine grafische Benutzteroberfläche wieder! Mit SaX2, allerdings ohne 3D Hadware Support, gings wieder.

Frage: Wie kann ich den 3D Hardware Support aktivieren ohne wieder "alles kaputt zu machen"?

Kernel:

NVIDIA_kernel-1.0-3123.suse80.rpm
NVIDIA_GLX-1.0-3123.suse80.rpm
 

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Im Kontrollzentrum auf der Startseite steht unter Maschine i686.
Muss ich dann vielleicht den Kernel mit der Endung i686 runterlanden??
 
Thema:

Nvidia Kernel auf SuSE 8.0 installieren

Nvidia Kernel auf SuSE 8.0 installieren - Ähnliche Themen

Windows 10 Crash BugcheckCode 278: Guten Tag, seit ein paar Tagen, habe ich das Problem, dass sich mein PC, 5min nach dem ersten Start, plötzlich crasht und neustartet ohne...
Kann Ge-Force Grafikkarte nicht in Betrieb nehemen: Hallo allerseits, nachdem ich Windows neu installiert habe (Daten dabei entfernt); findet das System zwar die Vorinstallierte Grafikkarte sowie...
Windows 10 erkennt nach Update die GTX 680M 4GB nicht: ich habe ein Clevo P170H Notebook - das hat noch Sandy Bridge BIOS: AMI (OEM) 4.6.4 07/13/2011 Intel(R) Core(TM) i7-2630QM CPU Grafikkarte: NVIDIA...
System-reservierte Partition SICHTBAR machen: Guten Tag 2 Probleme, die vermutlich zusammenhängen. Problem 1: Ich benutze Windows 10 und kann es seit einem Jahr nicht mehr updaten, weil...
Windows 10 1909 Update auf 2004 schlägt fehl: Hallo miteinander, ich weiß mir nicht mehr zu helfen und muss hier nun nachfragen, da das Update auf 2004 einfach nicht klappen mag. Zuerst zu...
Oben