GELÖST Microsoft .NET Framework 1, 2, 3, 3.5...

Diskutiere Microsoft .NET Framework 1, 2, 3, 3.5... im WinXP - Allgemeines Forum im Bereich Windows XP Forum; Kann mir jemand sagen, wofür ich Microsoft .NET Framework benötige und ob ich alle Versionen (1.1, 2.0, 3.0, 3.5) nebst den dazugehörigen...
B

bertom

Threadstarter
Dabei seit
25.08.2007
Beiträge
44
Alter
53
Ort
Augsburg
Kann mir jemand sagen, wofür ich Microsoft .NET Framework benötige und ob ich alle Versionen (1.1, 2.0, 3.0, 3.5) nebst den dazugehörigen Servicepacks (z.B. 1.1 SP1, 2.0 SP1) installieren soll?

Danke für Eure Antwort!
 
Michel

Michel

Dabei seit
09.11.2006
Beiträge
12.595
Alter
39
Ort
Wetterau
.NET ist eine Entwicklungsplattform von Microsoft, die mittlerweile von vielen Programmierern/Softwareanbietern genutzt wird. Das .NET-Framework brauchst du, damit Programme, die mit .NET erstellt wurden, bei dir laufen können. Es ist empfehlenswert, die Versionen 2 und 3 mit den jeweiligen SPs zu installieren.
 
Peter Schirmer

Peter Schirmer

Dabei seit
14.04.2006
Beiträge
7.060
Alter
40
Ort
7th Avenue, Ecke XP und Vista, 8ter Stock, Wohnung
Ergänzung:

Die Pakete laufen alle selbstständig nebeneinander. Du kannst also bequem .NET 1.1, 2.0, 3.0 und 3.5 installieren.

Somit gehst du sicher, dass ein Programm, welches das .NET-FW benötigt, auch korrekt läuft.

.NET-FW 3.0 und insb. 3.5 sind noch recht selten, da v3.5 erst mit erscheinen von VS 2008 vor ein paar Tagen offiziell verfügbar ist. Erst dann dürfte sich so langsam das Paket durchsetzen.

Peter
 
gman24

gman24

Dabei seit
13.07.2006
Beiträge
1.860
ganz so kann man das nicht sehen.

man braucht ein framework nur, wenn man programme auf dem pc installiert, die dafür programmiert sind (wie z.b. PAINT.NET braucht das framework 2). aber wenn ein programm das benötigt, dann sagt es dir das schon.

für framework 3 gibt es bislang fast überhaupt keine programme, mir ist jedenfalls keines bekannt.

ausserdem gibt es noch reichlich anwendungen, die das framework 1.1 benötigen.

ich würde im falle des threaderstellers abwarten, ob bei der installation eines programms nach einem framework gefragt wird und es dann installieren (und vor allem auch erst dann bei microsoft runterladen, weil man dann die neueste version hat). so ein framework ist ein ding, das sich tief in das system eingräbt und ohne triftigen grund sollte man sich das nicht unbedingt auf das system hauen.
 
Michel

Michel

Dabei seit
09.11.2006
Beiträge
12.595
Alter
39
Ort
Wetterau
ganz so kann man das nicht sehen.

man braucht ein framework nur, wenn man programme auf dem pc installiert, die dafür programmiert sind (wie z.b. PAINT.NET braucht das framework 2). aber wenn ein programm das benötigt, dann sagt es dir das schon.

für framework 3 gibt es bislang fast überhaupt keine programme, mir ist jedenfalls keines bekannt.

ausserdem gibt es noch reichlich anwendungen, die das framework 1.1 benötigen.

ich würde im falle des threaderstellers abwarten, ob bei der installation eines programms nach einem framework gefragt wird und es dann installieren (und vor allem auch erst dann bei microsoft runterladen, weil man dann die neueste version hat). so ein framework ist ein ding, das sich tief in das system eingräbt und ohne triftigen grund sollte man sich das nicht unbedingt auf das system hauen.
Hast du eine ATI-Grafikkarte? Z.B. wird für den Betrieb des Catalyst Control Centers (Treibersteuerung) mittlerweile das Framework in Version 3 benötigt. ;)
 
Peter Schirmer

Peter Schirmer

Dabei seit
14.04.2006
Beiträge
7.060
Alter
40
Ort
7th Avenue, Ecke XP und Vista, 8ter Stock, Wohnung
ich würde im falle des threaderstellers abwarten, ob bei der installation eines programms nach einem framework gefragt wird und es dann installieren (und vor allem auch erst dann bei microsoft runterladen, weil man dann die neueste version hat). so ein framework ist ein ding, das sich tief in das system eingräbt und ohne triftigen grund sollte man sich das nicht unbedingt auf das system hauen.
In der Regel stehen die Anforderungen auf der Website des Herstellers.

Es trägt sich zwar tief ins System ein, aber wird nur dann geladen, wenn ein Programm es anfordert. Die meisten Programme dürften dann in v1.1 vorliegen oder 2.0.

Ich habe mir zunächst nur das FW installiert, welches meine Programme benötigen. Im laufe der Zeit ist eben das FW 2 dazugekommen und wohl demnächst 3 und 3.5.

Die Aussage "ohne triftigen Grund" halte ich für übertrieben; viele Programme oder Programmbestandteile (Ergänzungen, z.B. für den IE von MS) verlangen schon das FW. Da würde ich schon gar nicht mehr drüber nachdenken und das FW gleich draufhauen. Kaputt wird nichts gehen. :D

Peter
 
Michel

Michel

Dabei seit
09.11.2006
Beiträge
12.595
Alter
39
Ort
Wetterau
In der Regel stehen die Anforderungen auf der Website des Herstellers.

Die Aussage "ohne triftigen Grund" halte ich für übertrieben; viele Programme oder Programmbestandteile (Ergänzungen, z.B. für den IE von MS) verlangen schon das FW. Da würde ich schon gar nicht mehr drüber nachdenken und das FW gleich draufhauen. Kaputt wird nichts gehen. :D

Peter
*zustimm* :up

Bei der Vista Installation ist auch schon das Framework 3.0 enthalten und lässt sich im Übrigen auch gar nicht deinstallieren. ;)
 
Peter Schirmer

Peter Schirmer

Dabei seit
14.04.2006
Beiträge
7.060
Alter
40
Ort
7th Avenue, Ecke XP und Vista, 8ter Stock, Wohnung
Bei der Vista Installation ist auch schon das Framework 3.0 enthalten und lässt sich im Übrigen auch gar nicht deinstallieren. ;)
Ist ja schon fast wie der IE bei Windows 98 damals. :D

Übrigens lässt sich der Windows Installer 4 unter Vista ebenso nicht deinstallieren. Es wird aber irgendwann eine Version 4.5 geben, so zumindest bei MS-Connect angekündigt. Die müsste auch für beide Systeme (Vista und XP) sein.

Peter
 
gman24

gman24

Dabei seit
13.07.2006
Beiträge
1.860
gerade gestern habe ich von meinem laptop manuell das framework 2 heruntergekratzt, weil sich der framework-sicherheitsupdate kb928365 nicht installieren liess (alte framework-installation) und bei der automatischen deinstallation das framework sich total verabschiedet hat. erst das aktuell bei ms herunterladbare framework 2 verarbeitet diesen patch, ansonsten bekommt man an jedem patchday eine fehlermeldung ( http://www.microsoft.com/communitie...work&tid=932ec0c8-2626-4854-8589-a9093a7e6e08). das war eine arbeit, die ein anfänger garantiert nicht schafft.

deswegen installiere ich solche sachen erst wenn es nötig wird und nicht im voraus.
 
Fireblade

Fireblade

Grüßt die Winboarder
Dabei seit
10.12.2004
Beiträge
19.623
@bertom
Normal reicht die Version 2,die 3,5er kannst ja noch zusätzlich installkeren,ist ja keine Beta mehr. ;)
 
F

fireball85

Dabei seit
29.09.2007
Beiträge
319
Ich würde auch warten, bis ein Programm es wirklich benötigt. Warum jetzt das System modifizieren, wenn es dann doch wieder veraltet ist, wenn es WIRKLICH benötigt wird, dass kann ja noch ein jährchen dauern, dann sind die komponenten teils schon wieder veraltet, und bei ms würde ich auch nicht jeden schnickschnack installieren. bestes bsp. win xp sp2, erst ab da war xp wirklich gut.
 
B

bertom

Threadstarter
Dabei seit
25.08.2007
Beiträge
44
Alter
53
Ort
Augsburg
DANKE für Eure Antworten

Hallo an alle!

Ich danke Euch allen für Eure zahlreichen Antworten. Hat mir sehr weitergeholfen.

VG aus Augsburg FCA :D
 
Thema:

Microsoft .NET Framework 1, 2, 3, 3.5...

Microsoft .NET Framework 1, 2, 3, 3.5... - Ähnliche Themen

  • Automatisches Update "Microsoft .NET Framework 4.8 für Windows 10 Version 1803 für x64 (KB4486153)" hängt seit Stunden bei 74% der Installation

    Automatisches Update "Microsoft .NET Framework 4.8 für Windows 10 Version 1803 für x64 (KB4486153)" hängt seit Stunden bei 74% der Installation: Es geht NICHT um das Upgrade von einer älteren Windows-Version auf Win 10! Ich setze gerade ein neues Notebook von MSI auf und habe die...
  • Microsoft .NET Framework 4.7.2 für Windows 8.1 für x64 (KB4054566)

    Microsoft .NET Framework 4.7.2 für Windows 8.1 für x64 (KB4054566): Guten Tag Jeder Installationsversuch von obigem Update ergibt folgende Fehlermeldung: Was ist da zu tun ?
  • Microsoft .NET Framework 4.7.2 für Windows 8.1 für x64 (KB4054566)

    Microsoft .NET Framework 4.7.2 für Windows 8.1 für x64 (KB4054566): Guten Tag Dieses Update ist schon alt jedoch bei mir noch immer nicht installiert, gibt bei jedem Installationsversuch eine Fehlermeldung...
  • Microsoft. NET Framework Unbehandelte Ausnahme in der Anwendung

    Microsoft. NET Framework Unbehandelte Ausnahme in der Anwendung: Hallo Mir erscheint seit ein paar Tagen die folgende Fehlermeldung in Netbook. Könnt ihr mir helfen diese zu beheben ? Gruss Aida...
  • Ähnliche Themen
  • Automatisches Update "Microsoft .NET Framework 4.8 für Windows 10 Version 1803 für x64 (KB4486153)" hängt seit Stunden bei 74% der Installation

    Automatisches Update "Microsoft .NET Framework 4.8 für Windows 10 Version 1803 für x64 (KB4486153)" hängt seit Stunden bei 74% der Installation: Es geht NICHT um das Upgrade von einer älteren Windows-Version auf Win 10! Ich setze gerade ein neues Notebook von MSI auf und habe die...
  • Microsoft .NET Framework 4.7.2 für Windows 8.1 für x64 (KB4054566)

    Microsoft .NET Framework 4.7.2 für Windows 8.1 für x64 (KB4054566): Guten Tag Jeder Installationsversuch von obigem Update ergibt folgende Fehlermeldung: Was ist da zu tun ?
  • Microsoft .NET Framework 4.7.2 für Windows 8.1 für x64 (KB4054566)

    Microsoft .NET Framework 4.7.2 für Windows 8.1 für x64 (KB4054566): Guten Tag Dieses Update ist schon alt jedoch bei mir noch immer nicht installiert, gibt bei jedem Installationsversuch eine Fehlermeldung...
  • Microsoft. NET Framework Unbehandelte Ausnahme in der Anwendung

    Microsoft. NET Framework Unbehandelte Ausnahme in der Anwendung: Hallo Mir erscheint seit ein paar Tagen die folgende Fehlermeldung in Netbook. Könnt ihr mir helfen diese zu beheben ? Gruss Aida...
  • Sucheingaben

    microsoft net framework 3.5.1 windows 7 fix

    ,

    brauch man microsoft .netframwork.3.5.1

    ,

    wozu braucht paint.net framework.net

    ,
    wozu braucht man NET Framework
    Oben