Kein AutoLogin trotz Änderung der Registry

Diskutiere Kein AutoLogin trotz Änderung der Registry im WinXP - Allgemeines Forum im Bereich Windows XP Forum; Hallo, um eine Remoteverbindung zu einem XP-System erstellen zu können musste ich ein Benutzerpasswort vergeben. Für den Autologin habe ich die...
U

user01

Threadstarter
Dabei seit
19.12.2009
Beiträge
34
Hallo,

um eine Remoteverbindung zu einem XP-System erstellen zu können musste ich ein Benutzerpasswort vergeben. Für den Autologin habe ich die nötigen Registry-Änderungen wie hier http://www.tippscout.de/autoadminlo...-benutzer-automatisch-anmelden_tipp_2028.html beschrieben durchgeführt. Der Autologin geht aber nicht, es wird nach dem PW gefragt. Ich habe mehrfach alles auf rechtschreibfehler geprüft, passt aber. Hab mal einen Screenshot gemacht und Benutzernamen und PW rausgelöscht - ist jetzt leer da steht aber was.

Was passt denn nicht?
 

Anhänge

Bullayer

Bullayer

Schwergewicht
Dabei seit
19.07.2006
Beiträge
24.163
Ort
DE-RLP-COC
Trag unter DefaultDomainName den Computernamen ein, unter DefaultUser den Benutzer, den du anmelden willst und unter DefaultPassword das entsprechende Passwort.
 
Andy

Andy

Administrator
Team
Dabei seit
16.08.2001
Beiträge
12.714
Alter
45
Ort
Wilder Süden
Außerdem muss der Wert "AutoAdminLogon" ein REG_SZ Wert sein.
Nicht wie im Screenshot zu sehen ein REG_DWORD
 
U

user01

Threadstarter
Dabei seit
19.12.2009
Beiträge
34
Es lag an dem REG_SZ-Wert.

Jetzt gehts, dabke. Mal sehen ob ich das Problem des langsamen bootens unter Windows 7 mit Autologin auch nioch hinbekomme.
 
U

user01

Threadstarter
Dabei seit
19.12.2009
Beiträge
34
Ich hab noch 2 weitere störende Sachen festgestellt:

  • wenn ich auf dem Remoterechner das Programm Mediaportal im Vollbild starte (es läuft IMMER im Vollbild), habe ich einen schwarzen Bildschirm an steuernden Rechner. Die Verbindung ist aber noch aktiv, denn am LCD-Bildschirm habe ich nichts außer die Anzeige des Benutzernamens.
  • wenn ich die Remoteverbindung beendet (schließen des Fensters) wäre es schön, wenn sich der Benutzer am XP-rechner automatisch wieder anmeldet. Bisher musste ich erst wieder eine VNC-Verbindung herstellen und so den benutzer anmelden.

Gehts das zu machen?
 
M

microsoft

Dabei seit
22.01.2007
Beiträge
4.510
Hallo

Verwendest du den RemoteDesktop (mstsc.exe) oder die Remoteunterstützung ? :hm

Und seit wann ist für ein AutoLogin ein Kennwort nötig ? :blink Du setzt in der Registry einfach den Wert DefaultPassword und lässt ihn leer.

Durch eine Aenderung in der Gruppenrichtlinie erlaubt der RemoteDesktop auch Benutzer ohne Kennwort.

Zum übrigen Problem lässt sich nicht viel sagen. Der RemoteDesktop ist dazu gedacht, dass sich der Benutzer entweder Lokal oder eben Remote anmeldet. Sitzt der Benutzer nicht vor dem System, kann sich dieser nach einer Remote Session auch nicht lokal anmelden.

Mich würde aber interessieren wozu bzw. was du machen möchtest. :hm
 
U

user01

Threadstarter
Dabei seit
19.12.2009
Beiträge
34
microsoft;1056839}Verwendest du den RemoteDesktop (mstsc.exe) oder die Remoteunterstützung ? :hm[/QUOTE schrieb:
Remotedesktop

Und seit wann ist für ein AutoLogin ein Kennwort nötig ? :blink Du setzt in der Registry einfach den Wert DefaultPassword und lässt ihn leer.
http://www.winboard.org/forum/win7-...e-sperrung-des-bildschirms-2.html#post1052917

Bezieht sich zwar auf Win7, ich bin aber davon ausgegangen, dass Remotedesktop auch unter XP ein Passwort voraussetzt. Und nur wegen des Passwortes mach ich den Autologin überhaupt.

Durch eine Aenderung in der Gruppenrichtlinie erlaubt der RemoteDesktop auch Benutzer ohne Kennwort.
Das heißt für mich? Es geht doch ohne Passwort? Wie? Ich hab mal versucht eine Verbindung herzustellen und bei der Benutzerkontenabfrage hab ich einfach kein PW eingegeben, klappte nicht.

Sitzt der Benutzer nicht vor dem System, kann sich dieser nach einer Remote Session auch nicht lokal anmelden.
Beim Autologin gehts aber auch automatisch.

Mich würde aber interessieren wozu bzw. was du machen möchtest. :hm
Das was ich geschrieben habe, eine Remoteverbindung (weil VNC und Teamviewer zu langsam sind) und keien Passwortabfrage beim Windows-Start. Weiterhin halt das was ich später geschrieben hatte: Möglichst sollte er nach dem Ausschalten des Remotedesktop ohne Abfrage wieder angemeldet werden.
 
M

microsoft

Dabei seit
22.01.2007
Beiträge
4.510
Das File im Anhang entpacken und auf dem PC welcher ferngesteuert wird ausführen (REG-Datei). Anschliessend Neustart.

Das mit dem Wiederanmelden bin ich noch am studieren. Wenn du den RemoteDesktop einfach nur beendest (nicht den User abmelden), so bleiben geöffnete Programme aber weiterhin aktiv.
 

Anhänge

U

user01

Threadstarter
Dabei seit
19.12.2009
Beiträge
34
Was bewirkt denn die Reg-Datei anderes als das was ich manuell eingestellt habe?

Die Programme laufen im Hintergrund, ich habe aber keinen Desktop sondern das Bild mit dem Benutzernamen in der Mitte.
 
Andy

Andy

Administrator
Team
Dabei seit
16.08.2001
Beiträge
12.714
Alter
45
Ort
Wilder Süden
Der Eintrag "LimitBlankPasswordUse" in der Regdatei bewirkt, dass bei der RDP Verbindung auch ein leeres Kennwort möglich ist.
 
U

user01

Threadstarter
Dabei seit
19.12.2009
Beiträge
34
Ich komme wahrscheinlich erst am Mittwoch dazu, den Reg zu testen. Ich würde dann Bescheid geben.

Wenn du noch eine Idee wegen des Zurückkehren zum destop nach dem Ende der Verbindung hast wäre das toll.
 
U

user01

Threadstarter
Dabei seit
19.12.2009
Beiträge
34
So, funktioniert erstmal alles.

Hast du eine Möglichkeit gefunden, wie man zum Desktop zurückkehren kann ohne das Passwort neu eingeben zu müssen?
 
M

microsoft

Dabei seit
22.01.2007
Beiträge
4.510
So, funktioniert erstmal alles.

Hast du eine Möglichkeit gefunden, wie man zum Desktop zurückkehren kann ohne das Passwort neu eingeben zu müssen?
Eigentlich nein :unsure, ausser der PC wird neu gestartet (z.B. über shutdown /m \\192.x.x.x /r /t 0). Danach wirkt der AutoLogin wieder.

Aber wie schon gesagt ist es vom Prinzip her nicht möglich. VNC ist nicht RemoteDesktop. Wenn niemand vor dem PC sitzt, kann sich auch niemand Lokal anmelden.
 
Thema:

Kein AutoLogin trotz Änderung der Registry

Kein AutoLogin trotz Änderung der Registry - Ähnliche Themen

  • Fehlende Einträge und Möglichkeiten zum Autologin von Windows

    Fehlende Einträge und Möglichkeiten zum Autologin von Windows: Liebe Community ich habe ein Problem, bei welchem ich einfach nicht mehr weiterkomme. Ich habe nach einer Möglichkeit gesucht, wie ich Windows...
  • Doppeltes Benutzerkonto bei Autologin

    Doppeltes Benutzerkonto bei Autologin: Ich bekomme beim Autologin immer ein zweites Benutzerkonto . Was kann ich machen? hab schon alles versucht.
  • Sperrbildschirm Autologin abschalten

    Sperrbildschirm Autologin abschalten: Hi, ich habe seit einiger Zeit ein sehr merkwürdiges Problem. Ich habe vor einiger Zeit (ca. 4 Monate) mal wieder Windows 10 auf einer neuen...
  • Batch mit einem Autologin an einen anderen PC

    Batch mit einem Autologin an einen anderen PC: Hallo Community, ich habe des öfteren zuhause die Situation das ich ich auf einen anderen Rechner aufschalten möchte. ich dachte mir ich kann...
  • Ähnliche Themen
  • Fehlende Einträge und Möglichkeiten zum Autologin von Windows

    Fehlende Einträge und Möglichkeiten zum Autologin von Windows: Liebe Community ich habe ein Problem, bei welchem ich einfach nicht mehr weiterkomme. Ich habe nach einer Möglichkeit gesucht, wie ich Windows...
  • Doppeltes Benutzerkonto bei Autologin

    Doppeltes Benutzerkonto bei Autologin: Ich bekomme beim Autologin immer ein zweites Benutzerkonto . Was kann ich machen? hab schon alles versucht.
  • Sperrbildschirm Autologin abschalten

    Sperrbildschirm Autologin abschalten: Hi, ich habe seit einiger Zeit ein sehr merkwürdiges Problem. Ich habe vor einiger Zeit (ca. 4 Monate) mal wieder Windows 10 auf einer neuen...
  • Batch mit einem Autologin an einen anderen PC

    Batch mit einem Autologin an einen anderen PC: Hallo Community, ich habe des öfteren zuhause die Situation das ich ich auf einen anderen Rechner aufschalten möchte. ich dachte mir ich kann...
  • Oben