Gruppenrichtlinien deaktivieren für Remotedesktopbenutzer

Diskutiere Gruppenrichtlinien deaktivieren für Remotedesktopbenutzer im Windows Server 2003 Forum im Bereich Server Systeme; Hallo zusammen Wir haben folgendes System: Windows Server 2003 Small Business SP2. Es ist ein Domänencontroller eingerichtet. Die Benutzer wurden...
S

Samigasi

Threadstarter
Mitglied seit
01.06.2004
Beiträge
146
Alter
39
Hallo zusammen

Wir haben folgendes System:
Windows Server 2003 Small Business SP2. Es ist ein Domänencontroller eingerichtet.
Die Benutzer wurden in ganz normalen OU's und Sub OU's eingerichtet.
Jeder Benutzer hat ein Profilverzeichnis eingetragen (\\serverAB\users\mustermann\profiles) plus ein Terminaldienstprofilverzeichnis. Das Terminaldienstprofilverzeichnis befindet sich innerhalb des User Ordners (\\serverAB\users\mustermann\tsprofiles).
Vermutlich ist das nicht grad optimal, aber ich hab alles so vom Vorgänger übernommen...

Nun wurde mir die Aufgabe übertragen für alle Rechner das gleiche Hintergrundbild festzusetzen so dass es vom Benutzer nicht mehr geändert werden kann.
Das war kein Problem da ich eine GPO auf Benutzerebene eingerichtet habe und es mit den OU's der Benutzer verknüpft habe die davon betroffen sind.
Das JPG welches für den Hintergrund verwendet wird, liegt auf einer zweiten Serverfestplatte auf welchem das Verzeichnis mit dem Bild im Netzwerk freigegeben wurde.
Das hat bislang gut funktioniert (hie und da wird mal das Bild nicht oder nur teilweise geladen).

Nun ergibt sich folgendes Problem: wenn jemand von zuhause mittels Microsoft's Remotedesktop auf den Server verbindet, wird das Hintergrundbild ja auch geladen da sich die GPO auf den Benutzer bezieht. Nun klagen die User dass das laden des Bildes ewig dauert oder z.T. gar nicht richtig angemeldet werden kann.

Was kann man dagegen tun? Kann man GPO's auch Beispielsweise für Remotedesktopbenutzer deaktivieren? Oder muss ich wirklich die betroffenen Benutzer duplizieren und ständig synchronisieren? Oder kann die Hintergrundbild-GPO auch Computerbasiert eingerichtet werden?
 
tacky

tacky

Mitglied seit
20.05.2008
Beiträge
2.449
Standort
Dortmund
Hi Samigasi,

ist zwar keine Antwort auf deine Frage, aber vielleicht auch ein Ansatz.
Der Remotebenutzer kann unter Optionen -> Erweitert -> den Haken bei Desktophintergrund übertragen entfernen.
Vielleicht kann man das Entfernen des Hakens ja per Registry erzwingen.

T@cky
 
S

Samigasi

Threadstarter
Mitglied seit
01.06.2004
Beiträge
146
Alter
39
Gute Idee. Darauf bin ich nicht gekommen.
Werde ich heute Abend ausprobieren.

Danke für den Tipp.
 
S

Samigasi

Threadstarter
Mitglied seit
01.06.2004
Beiträge
146
Alter
39
Der Tipp hat leider nicht funktioniert. Das Hintergrundbild wird erzwungen egal ob ich es anzeigen möchte oder nicht. Ich schau mal ob ich per GPO statt eines Bildes die Hintergrundfarbe festlegen kann.
 
S

Samigasi

Threadstarter
Mitglied seit
01.06.2004
Beiträge
146
Alter
39
Interesannter Tipp. Irgendwie funktioniert es nicht richtig.
Folgendes hab ich gemacht: ich habe eine separate GPO erstellt in welcher die Loopbackverarbeitung aktiviert und sonst nichts (ich will ja dass die Regel des festgelegten Desktophintergrundes nicht gilt wenn User per Remotedesktop auf dem TS anmelden aber auf ihren Arbeitsmaschinen schon; TS und DC ist momentan noch auf der gleichen Maschine).
Der Server ist in einer separaten OU in welche ich die oben genannte GPO verlinkt habe.
Ich habe auch eingestellt dass diese Sicherheitsrichtlinie nur für Remotedesktopbenutzer gelten soll.
Leider ist nach anmelden der Remotesession das Hintergrundbild immer noch fixiert...

Hab ich da was falsch verstanden?
 
Sascha_R

Sascha_R

Junior-Sponsoren
Mitglied seit
01.12.2007
Beiträge
2.676
Standort
MYK
Was hast du denn in der GPO definiert? Wenn du nichts definierst dann kann auch nichts überschrieben werden. Eine Leere bzw unkonfigurierte GPO setzt keine Einstellungen zurück. Du müßtest schon die entsprechenden Einstellungen die nicht angewendet werden sollen in der Loopback-GPO rückgängig machen bzw etwas anderes (kein Hintergurndbild) definieren.
 
S

Samigasi

Threadstarter
Mitglied seit
01.06.2004
Beiträge
146
Alter
39
Ich habe eine neue GPO erstellt und folgendes definiert:
- Computerkonfiguration Administrative Vorlagen > System/Gruppenrichtlinien > Loopbackverarbeitungsmodus für Benutzerrichtlinie: Aktiviert => Modus: Ersetzen

- Benutzerkonfiguration > Administrative Vorlagen >
Desktop/Active Desktop > Active Desktop aktivieren: Aktiviert
- ... > Active Desktop-Hintergrund: Deaktiviert
- ... > Keine Änderungen zulassen: Aktiviert
Die User können meinetwegen die Farbe ändern können...

Wenn ich das jetzt richtig verstehe muss diese Richtlinie mit der Computer OU in welcher der Server ist verknüpft werden oder?

Allen Benutzern werden sonst das Hintergrundbild vorgegeben und die Änderungsrechte entzogen mit den obigen (gegenteiligen) Einstellungen.

Danke für deine Hilfe bislang.
 
Sascha_R

Sascha_R

Junior-Sponsoren
Mitglied seit
01.12.2007
Beiträge
2.676
Standort
MYK
Hallo,

entweder du verknüpfst die GPO mit direkt mit der Domäne oder mit der OU in der sich der Server befindet.

Im ersten Fall wird die GPO auf alle Computer angewandt deren OU die Vererbung nicht deaktivert hat und im zweiten Fall nur auf den Computern der jeweiligen OU.

Jenach AD Struktur ist mal das eine mal das andere sinnvoll. Kannst aber auch definieren dass nur ein bestimmter Computer / Benutzer (Benutzer ist hier nicht so sinnvoll) die GPO lesen darf.
 
S

Samigasi

Threadstarter
Mitglied seit
01.06.2004
Beiträge
146
Alter
39
Danke für die Hilfe, Sascha.

Leider hat es nicht geklappt. Egal was ich einstelle, egal ob Loopback eingestellt ist oder nicht; das Hintergrundbild wird geladen sobald ich als normalen Benutzer per RDP auf den Server verbinde.
Irgendwie doof dass ausgerechnet diese Richtlinienart nicht auf die Maschine bezogen werden kann so wie die meisten anderen auch...

Gut, dann bleibt mir wohl oder übel nichts anderes übrig als meinem Chef zu sagen dass dass Hintergrundbild weg muss...

Da der Server bis ca. Sommer durch ein 2011er SBS abgelöst wird, versuche ich es dann nochmals. Möglicherweise klappt es dann besser da sich ja ein paar Dinge verändert haben seit Win 2003.

Danke für alle Hilfen.
 
Sascha_R

Sascha_R

Junior-Sponsoren
Mitglied seit
01.12.2007
Beiträge
2.676
Standort
MYK
...

- Benutzerkonfiguration > Administrative Vorlagen >
Desktop/Active Desktop > Active Desktop aktivieren: Aktiviert
- ... > Active Desktop-Hintergrund: Deaktiviert
- ... > Keine Änderungen zulassen: Aktiviert
Die User können meinetwegen die Farbe ändern können...
...
Ich sehe grade "Active Desktop-Hintergrund" ist nicht gleich Desktophintergrund! Vielleicht liegt dein Fehler ja hier.
 
S

Samigasi

Threadstarter
Mitglied seit
01.06.2004
Beiträge
146
Alter
39
Vielen Dank für eure Hilfe.

Ich habe es nun auf dem Windows Small Business Server 2011 so gelöst:
Benutzerkonfiguration > Richlinien > Administrative Vorlagen > Desktop > Desktop > Active Desktop aktivieren = HTML- und JPG Hintergrundbild zulassen

und

Benutzerkonfiguration > Richlinien > Administrative Vorlagen > Desktop > Desktop > Desktophintergrund = ein Link zum Server bzw. Bild eingegeben welches nicht exisitiert z.B.: \\server\freigaben\bla.jpg

Somit versucht Windows XP und Win 7 ein Bild anzuzeigen aber da kein Bild da ist, wird nichts angezeigt, aber mann kann auch kein Bild mehr auswählen. Die Farbe kann noch gewählt werden, der rest ist gesperrt.
 
S

Samigasi

Threadstarter
Mitglied seit
01.06.2004
Beiträge
146
Alter
39
Einmal zuviel geantwortet....
 
S

Samigasi

Threadstarter
Mitglied seit
01.06.2004
Beiträge
146
Alter
39
Ich habe es nun so gelöst dass ich per GPO einfach auf ein nicht vorhandenes JPG verweise. Zumindest bei den XP Clients klappt das wunderbar. Sie können lediglich die Farbe wählen. Bei den Windows 7 Clients klappt das nicht mehr. Muss ich noch rausfinden wie dort nur noch die Farbe ausgewählt werden kann.

Danke für eure Hilfe.
 
Thema:

Gruppenrichtlinien deaktivieren für Remotedesktopbenutzer

Gruppenrichtlinien deaktivieren für Remotedesktopbenutzer - Ähnliche Themen

  • [Windows 10 Home] GPResult kennt Parameter H für Gruppenrichtlinien-Bericht nicht

    [Windows 10 Home] GPResult kennt Parameter H für Gruppenrichtlinien-Bericht nicht: Hallo liebe Community, wenn ich unter Windows 10 Home Version 1909 Systembuild 18363.418 als Administrator in der Kommandozeile (CMD) den Befehl...
  • Gruppenrichtlinie auf vssadmin?

    Gruppenrichtlinie auf vssadmin?: Betrifft: Windows 10(x64), 1903 (19362.388) Hallo Seit mind. 2.10.19 arbeitet mein ashampoo backup-Programm nicht mehr. Nach meinen Recherchen...
  • Gruppenrichtlinien von Windows zum passenden Eintrag der Registry zuordnen mit GPSEARCH

    Gruppenrichtlinien von Windows zum passenden Eintrag der Registry zuordnen mit GPSEARCH: Heute mal ein kleine Tipp der für Einsteiger sicher völlig ungeeignet ist, aber es gibt ja eben nicht nur solche und so mancher will oder muss...
  • App vom Systemadministrator gesperrt, Programm wird durch Gruppenrichtlinie gesperrt

    App vom Systemadministrator gesperrt, Programm wird durch Gruppenrichtlinie gesperrt: Hallo, ich habe seit Wochen das Problem mit meinem Windows 10-Notebook, dass ich keine heruntergeladenen Programme (neue oder zu...
  • PC Piep per Gruppenrichtlinie deaktivieren!

    PC Piep per Gruppenrichtlinie deaktivieren!: Hi Leute, Per Registry kann man den PC Piep Deaktivieren: " Gehen Sie deshalb ins Startmenü und klicken Sie auf »Ausführen«. Mit »reg-edit«...
  • Ähnliche Themen

    Oben