[gelöst] UDMA-Festplatte nur PIO-Mode

Diskutiere [gelöst] UDMA-Festplatte nur PIO-Mode im Windows 2000 Forum im Bereich Weitere Betriebssysteme; Hei. Primary Master: 120 GB Maxtor, UDMA 5 Primary Slave: 250 GB Samsung, UDMA 4 Secondary Master: DVD-Laufwerk Toshiba, UDMA 2 Secondary Slave...
M

mabuse

Threadstarter
Dabei seit
24.04.2006
Beiträge
9
Hei.

Primary Master: 120 GB Maxtor, UDMA 5
Primary Slave: 250 GB Samsung, UDMA 4
Secondary Master: DVD-Laufwerk Toshiba, UDMA 2
Secondary Slave: 250 GB Samsung, UDMA 4

Wird auch so vom Bios korrekt erkannt

Problem: Unter Windows 2000 laufen alle Laufwerke, so wie es sein sollte, außer der Primary Slave, der läuft nur im PIO-Mode.
Was bedeutet, arschlangsam.

Ich hab's schon mit Master/Slave und Cable Select versucht, andere Kabel ausprobiert, die Platten ausgetauscht (die beiden Slaves sind identische Laufwerke) - nix zu wollen, der Primary Slave läuft immer nur im PIO-Mode.

Irgendjemand 'ne Idee, was es sein könnte?


Edit:
Im Gerätemanger stehen natürlich alle Ports auf "DMA, wenn verfügbar". Nur scheint Windows der Meinung zu sein, das DMA an diesem Port eben nicht verfügbar ist . . .
 
Charles43

Charles43

Dabei seit
10.01.2006
Beiträge
145
Hallo mabuse,

unter Windows 2000 hatte ich das auch mal gehabt, eine Platte ging wunderbar bis plötzlich (und dauerhaft) der PIO-Modus aktiv war. Ich hatte dann im Kontrollermanager den IDE-Port deinstalliert, der wurde dann neu erkannt und danach ging es wieder eine Weile. Aber der PIO-Modus kam dann irgendwann wieder....

Eventuell hilft auch ein Chipsatz-Update, bei meinem Intel-Chipsatz konnte ich auch den "Application Accelerator" benutzen, damit trat das Problem auch nicht mehr auf, aber leider funktionierte danach das Wakeup aus dem Ruhemodus nicht mehr :eh

Bei mit steckt inzwischen ein zusätzlcher IDE-Controller von Promise drin, damit hatte ich keine Probleme mehr...
Übrigens könnten im Ereignisprotokoll Fehlermeldungen stehen, die zu dem Umstellen auf PIO geführt haben, evtl. hat Windows da eine Protokollfunktion, die bei Problemen am IDE-Port diesen einfach runterschaltet.


Grüße
Charles
 
R

Ronny

SPONSOREN
Dabei seit
07.08.2004
Beiträge
12.311
Ort
Rheinland
Benutzt Du auch ein 80poliges Kabel? Das ist nämlich in dem Fall nötig.
 
oldie007

oldie007

Dabei seit
26.07.2004
Beiträge
235
Ort
Oldenburg
Ich würde behaupten, das beide 250GB Festplatten vom BIOS schon falsch erkannt werden, denn ich kann mir nicht vorstellen, daß eine 250GB Festplatte nur UDMA4 hat, sie sollte als UDMA5 erkannt werden! :prof
Also entweder, wie Ronny2 meinte, sind die falschen Kabel dran, oder das BIOS muß ein Update haben.
Viel Erfolg
 
D

duesso

Dabei seit
15.12.2005
Beiträge
4.324
Ort
Mettmann
DMA fällt zurück auf PIO
Das stotternde DVD-Laufwerk
Allgemeine Beschreibung

Dieser Artikel trifft auch auf Windows 2000 zu. (Peter Frank berichtete eine erfolgreiche Anwendung auf Windows 2000 mit Service Pack 4.)
DMA ist eine Abkürzung für Direct Memory Access, ein Zugriffsverfahren für externe Geräte, bei dem die Datenübertragung nicht durch den Prozessor erfolgt, sondern durch einen kleinen Spezialprozessor, den DMA-Controller. Dieser benutzt ein Verfahren namens Cycle Stealing (Stehlen von Zyklen), bei dem der Prozessor für einzelne Speicherzugriffszyklen, also sehr kurz, aufgehalten wird, damit der DMA-Controller eine kleine Datenmenge vom oder zum Hauptspeicher übertragen kann. Die neueren, schnelleren DMA-Modi heißen UDMA (Ultra DMA).
Der alternative, langsame und wenig effiziente Datenübertragungsmodus heißt PIO, Programmed Input-Output, bei dem der Prozessor Byte für Byte oder Wort für Wort übertragen muss, was pro Datenwort viele Programmbefehle erfordert und daher zu einer hohen und unerwünschten Prozessorbelastung führt.
Mögliche Ursachen für den Rückfall auf PIO
Die häufigste Ursache dafür, dass ein IDE-Port von DMA auf PIO zurückfällt, ist eine zerkratzte oder anderweitig unlesbare CD oder DVD.
Allerdings gibt es noch andere Gründe, warum ein Computer PIO statt DMA verwendet. Z.B. berichtete David Duberman 2005, dass einige Dell-Computer als Standardeinstellung im BIOS DMA für die zweite Festplatte deaktiviert haben. Es ist daher eine gute Idee, zuerst die BIOS-Einstellungen zu prüfen.
Other reasons can show up in the event log, so check this first and see if you can find repeated Atapi errors recorded. If so, you likely have a hardware defect. You can use the procedure described below, but your computer will probably fall back to PIO mode again and again, until you solve the underlying problem, which may be located inside the device, on the motherboard, or in the IDE data cable and its connectors.
Andere Ursachen können in der Ereignisanzeige auftauchen, also prüfen Sie diese zuerst und sehen Sie nach, ob Sie wiederholte Atapi-Fehler darin finden. Wenn ja, dann liegt wahrscheinlich ein Hardware-Fehler vor. Sie können die im Folgenden beschriebene Prozedur verwenden, aber Ihr Computer wird wahrscheinlich immer wieder in den PIO-Modus zurückfallen, bis Sie den zugrundeliegenden Fehler beheben. Dieser kann sich im Laufwerk befinden, auf der Hauptplatine (Motherboard), oder im IDE-Datenkabel und seinen Anschlusskontakten.
Die Falle
Windows enthält eine Falle, in die viele Computer früher oder später einmal hineintappen. Diese Falle wurde in einem Artikel (und auch in einem weiter unten erwähnten) genauer beschrieben.
Die entscheidenden Absätze (ins Deutsche übertragen) lauten:
Der PIO-Modus wird automatisch in den folgenden Situationen aktiviert:
...
Bei wiederholten DMA-Fehlern. Windows XP schaltet den DMA-Modus für ein Gerät aus, nachdem bestimmte Fehler beim Datentransfer auftraten. Wenn mehr als sechs DMA-Transfer-Zeitüberschreitungen auftreten, dann deaktiviert Windows DMA und benutzt für dieses Gerät den PIO-Modus.
In diesem Falle kann der Benutzer DMA für dieses Gerät nicht mehr einschalten. Die einzige Möglichkeit für den Benutzer, der DMA wieder aktivieren möchte, ist, das Gerät zu deinstallieren und neu zu installieren.
Windows XP schaltet den Ultra-DMA-Transfermodus herunter, nachdem es mehr als sechs CRC-(Cyclic Redundancy Check)-Fehler erhalten hat. Wenn immer möglich, schaltet das Betriebssystem den DMA-Modus jedes Mal nur um eine Stufe herunter (von UDMA-Modus 4 auf UDMA-Modus 3 usw.).
...
Natürlich ist es bei der heutzutage ziemlich komplizierten Geräte-Firmware (fest eingebaute Software), die mit an Sicherheit grenzender Wahrscheinlichkeit selbst auch Programmfehler enthält, nicht allzu schwierig, solche Fehler zu erzeugen. In meinem Falle genügte eine zerkratzte DVD und später noch einmal eine unlesbare (overburn) CD, um das Laufwerk sich verschlucken zu lassen, und um Windows dazu zu bringen, für immer auf den PIO-Modus zurückzuschalten.
Ich hatte meinen Laptop schon jahrelang zum Anschauen von DVDs benutzt, bis ich eine geborgte und schwer zerkratzte DVD einlegte. Das DVD-Abspielprogramm und auch das Lauferk stolperte über die vielen Fehler, und als ich die DVD schließlich zum Abspielen brachte, fand ich, dass der Film ruckelte und die Prozessorleistung auf 100% anstieg, von dem etwa die Hälfte System-Overhead war.
Dies zeigt an, dass das Laufwerk vom sonst üblichen UDMA-Modus 2 auf PIO zurückgefallen war. Alle Versuche, dies zurückzusetzen oder die relevanten Registry-Einträge von 1 (DMA versuchen) auf 2 (DMA erzwingen), schlugen fehl. Störrisch beharrte das Laufwerk auf dem PIO-Modus, und Windows stellte sogar die Registry-Parameter auf 0 (Nur PIO benutzen) zurück.
Der folgende Text bezieht sich auf den sekundären IDE-Port, weil dieser am häufigsten betroffen ist, aber dasselbe gilt im Prinzip auch für den primären IDE-Port, an dem in den meisten Computern die Festplatte angeschlossen ist. Nur treten dort nicht so häufig Fehler auf, denn wer benutzt schon zerkratzte Festplatten?
Bevor Sie beginnen, am Problem zu arbeiten, loggen Sie sich als Administrator oder als ein Benutzer mit Administratorrechten ein.
Prüfen Sie den Übertragungsmodus Ihres IDE-Ports
Prüfen Sie zuerst, in welchem Modus Ihr sekundärer IDE-Port gerade arbeitet. Wenn er in einem schnellen UDMA-Modus läuft, dann können Sie den Rest dieses Kapitels vorläufig ignorieren, sollten aber im Kopf behalten, dass dieser Fehler Sie in der Zukunft noch treffen kann. Dann sollten Sie wissen, was zu tun ist.
Sie brauchen dazu den Geräte-Manager. Ein Weg, diesen zu öffnen, ist der folgende. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz und wählen Sie Eigenschaften. Klicken Sie auf den Reiter Hardware und dort auf den Knopf Geräte-Manager. Klicken Sie auf das Pluszeichen links neben dem IDE ATA/ATAPI-Controller. Doppelklicken Sie auf Sekundärer IDE-Kanal. Ein neues Fenster Eigenschaften von Sekundärer IDE-Kanal öffnet sich.
Dort klicken Sie auf den Reiter Erweiterte Einstellungen. Sie sehen nun die beiden Geräte, die am sekundären IDE-Kanal angeschlossen sein können. Gerät 0 ist das Gerät, dessen Jumper auf Master gesteckt ist, Gerät 1 das mit dem Jumper in der Position Slave, falls überhaupt ein zweites Gerät angeschlossen ist.
Normalerweise möchte man, dass jedes der beiden Geräte so eingestellt ist, dass DMA, wenn verfügbar, verwendet wird. Unter dieser Einstellung sehen Sie ein graues Feld, in dem angezeigt wird, welchen DMA- oder PIO-Modus das Gerät tatsächlich verwendet. Dort möchten Sie den höchstmöglichen DMA- oder UDMA-Modus sehen und zumindest bei CD- oder DVD-Laufwerken auf keinen Fall PIO.
Normalerweise brauchen Sie hierfür den Registry-Editor nicht, weil die normalen Einstellungen auch durch diesen Eigenschaften-Dialog für die IDE-Ports verfügbar sind, aber wenn Sie trotzdem dort hineinschauen möchten, finden Sie die Parameter für den sekundären IDE-Port mittels regedit.exe bei
HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1
Er wird nur aus historischen Gründen Scsi genannt. Scsi Port 0 ist der primäre IDE-Port, an dem wahrscheinlich Ihre Festplatte angeschlossen ist.
Nachdem ich—vergeblich—verschiedene Einstellungen zu ändern versuchte, fand ich den oben zitierten Artikel und machte mich mit diesen Informationen erneut an die Arbeit. Ich deinstallierte das DVD-Laufwerk im Geräte-Manager und bootete den Computer erneut, aber das half immer noch nicht.
Nach weiterer Informationssuche fand ich schließlich die Lösung.
DMA mit dem Registry Editor reaktivieren
Mein Dank gilt meinem MVP-Kollegen Alexander Grigoriev, der mich diese Methode lehrte.
Starten Sie den Registry Editor REGEDIT. Sie können diesen u.a. aufrufen, indem Sie auf den Start-Knopf klicken, dann auf den Befehl Ausführen... und dort das Wort regedit eingeben.
Suchen Sie jetzt, indem Sie auf die Pluszeichen links neben den Schlüsselnamen klicken, den Registry-Schlüssel:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}
Dieser enthält weitere Schlüssel namens 0000, 0001, 0002, usw. Normalerweise ist 0001 der primäre IDE-Kanal und 0002 der sekundäre, aber unter bestimmten Umständen können auch andere Nummern auftreten. Sie müssen daher durch diese Schlüssel gehen und den Wert DriverDesc (Treiber-Beschreibung) anschauen, der eine lesbare Bezeichnung des jeweiligen Kanals enthält. So können Sie sicherstellen, dass Sie den richtigen IDE-Kanal gefunden haben.
Löschen Sie nun den Wert MasterIdDataChecksum oder SlaveIdDataChecksum, je nachdem, ob das fragliche Gerät als Master oder als Slave angeschlossen ist (Gerät 0 oder Gerät 1), aber es kann nicht schaden, einfach beide zu löschen. Sie können einen Wert löschen, indem Sie seinen Namen auswählen, indem Sie darauf klicken, und dann die Löschtaste [Entf] drücken. Windows wird beim nächsten Systemstart die DMA-Fähigkeiten des Laufwerks oder der Laufwerke neu feststellen. Booten Sie also Ihren Computer neu.
Öffnen Sie zur Sicherheit wie oben beschrieben noch einmal den Geräte-Manager und prüfen Sie, ob Ihr Gerät nun tatsächlich wieder den DMA-Modus verwendet. Wenn ja, Gratulation, Sie haben es geschafft (mindestens bis Windows das nächste Mal DMA wieder ausschaltet).
2005-10-24 – Tomáš Souček schrieb, wenn dies das Problem nicht löst, prüfen Sie auch den DWORD-Wert MasterDeviceTimingModeAllowed, dessen Standardwert hex 0xFFFFFFFF ist. Wenn Sie einen viel kleineren Wert vorfinden, dann können Sie versuchen, diesen für einen Test auf den Standardwert zurückzusetzen und dann neu zu booten.
Alternative Methode—Port deinstallieren
1. Deinstallieren Sie den sekundären IDE-Port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDA ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.
Um dies zu tun, öffnen Sie wie oben beschrieben den Geräte-Manager und finden Sie wieder den Zweig Sekundärer IDE-Kanal. Klicken Sie mit der rechten Maustaste auf Sekundärer IDE-Kanal und klicken Sie auf Deinstallieren. Deaktivieren reicht nicht.
Starten Sie Ihren Computer neu, um diese Änderung auszuführen.
After this first reboot Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.
Nach dem Neustart wird Windows automatisch den IDE-Kanal finden und den Treiber dafür neu installieren, ebenso wie die dort angeschlossenen Laufwerke (z.B. DVD oder CD). Dieser Plug-and-Play-Vorgang kann ein Weilchen dauern. Geben Sie dem Computer also eine extra Minute, nachdem der Bootvorgang beendet ist.
2. DMA reaktivieren
Aber dies ist nicht genug, weil Windows leider den DMA-Modus auf dem DVD- oder CD-Laufwerk nicht wieder automatisch reaktiviert. Sie müssen Windows erst noch mitteilen, dass es versuchen soll, DMA zu benutzen.
Um dies zu tun, gehen Sie noch einmal in den Geräte-Manager, klicken Sie dort auf das Pluszeichen links von IDE ATA/ATAPI-Controller, doppelklicken Sie auf Sekundärer IDE-Kanal, klicken Sie auf Erweiterte Einstellungen und stellen Sie die Einstellung von Nur PIO auf DMA, wenn verfügbar.
Starten Sie Ihren Computer noch einmal neu, gehen Sie wieder in den Geräte-Manager und prüfen Sie an derselben Stelle, ob das Laufwerk nun wirklich den DMA-Modus benutzt. Wenn ja, dann ist alles in Ordnung.
3. Treiber ist für diese Plattform nicht vorgesehen
Wenn Sie die folgende oder eine ähnliche Fehlermeldung erhalten:
Problem bei der Hardware-Installation
IDE-Kanal
Während der Geräteinstallation ist ein Fehler aufgetreten. Treiber ist für diese Plattform nicht vorgesehen.
2005-03-30 – Johannes B. schrieb: Der Grund für diese Meldung ist meistens, dass Daemon Tools oder Alcohol 120% auf dem betroffenen System installiert ist. In diesem Fall funktioniert der unten beschriebene Lösungsweg nicht. Wenn man aber diese Programme deinstalliert und dann Windows neu startet, installiert Windows problemlos die Gerätetreiber.
Wenn keines dieser beiden Programme installiert ist, dann ist ein möglicher Ausweg, die Treiberdatei C:\WINDOWS\system32\drivers\atapi.sys (oder ein ähnlicher Pfad auf Ihrem Computer) in atapi.old o.ä. umzubenennen.
Wenn das nicht möglich ist, dann versuchen Sie es von der Reparatorkonsole aus (Booten von der Windows-Installations-CD, dann Reparaturkonsole aufrufen).
Sollte Windows dann automatisch wieder eine Datei atapi.sys erstellen, dann können Sie noch versuchen, die Datei im Safe Mode oder von einem Kommandozeilenfenster aus umzubenennen, oder Sie können versuchen, die Datei auch im Treiber-Cache-Ordner umzubenennen oder zu entfernen.
Desensibilisieren Sie die IDE-Kanäle Ihres Computers
Es gibt noch etwas mehr, das Sie tun können, um dieses Problem wenigstens etwas abzuschwächen, obwohl es sich nicht ganz vermeiden lässt. Der folgende (englische) Artikel beschreibt die Lösung.
Sie besteht darin, Windows so einzustellen, dass es den Fehlerzähler nach jedem erfolgreichen Lese- oder Schreibvorgang wieder auf Null zurücksetzt. Das hat zur Folge, dass das Zurückschalten des DMA-Modus nur noch passiert, wenn Sie 6 Fehler hintereinander bekommen, statt 6 Fehler über eine Sitzung am Computer verstreut.
IDE ATA- und ATAPI-Laufwerke arbeiten nach mehreren Zeitüberschreitungs- und CRC-Fehlern im PIO-Modus
http://support.microsoft.com/kb/817472/de
Englische Version:
IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur
http://support.microsoft.com/kb/817472/
Lesen Sie den Artikel, denn er enthält eine langfristig wirkende Fehlerumgehung. Aber Sie müssen vorher die weiter oben beschriebene Prozedur absolvieren, um DMA erst einmal zu aktivieren, wenn es schon deaktiviert worden war.
Nachdem Sie das getan haben, setzen Sie die Registry-Werte ResetErrorCountersOnSuccess in die Registry-Schlüssel sowohl des primären als auch des sekundären IDE-Ports ein, wie im oben genannten Artikel beschrieben.
Leider ist auch dies nur eine halbe Lösung, weil Sie, wenn Sie eine unlesbare CD oder DVD einlegen, leicht 6 Fehler hintereinander bekommen können, aber wenigstens passiert es nun nicht mehr, wenn Sie die fehlerhafte CD oder DVD rechtzeitig aus dem Laufwerk nehmen und das nächste Mal eine bessere einlegen. Nach einem erfolgreichen Lesevorgang wird der Fehlerzähler nun zurückgesetzt, die magische Zahl 6 ist hoffentlich noch nicht erreicht worden, und so ist es wenigstens etwas schwieriger für Windows, Ihr Laufwerk mit PIO auszubremsen.
 
Z

ZULLI

Gast
1.bei Secondary Master schliest man kein Dvd Laufwerk an,wenn mann schon 3 Festplatten am Controllen hängen hat(immer das schnelste Laufwerk als Primary Master) . Primary Master: 250 GB Samsung,

Primary Slave: 250 GB Samsung

Secondary Master:120 GB Maxtor

Secondary Slave:DVD-Laufwerk Toshiba

Dein Dvd bremst die schnellen Laufwerke sonst aus da es ja nur im UDMA-Modus 33 läuft und bei dir als Master vor der schnelleren Festplatte hängt.Anschliesend ein Bios-Reset und Windows hochfahren,Controllertreiber installiert WINDOOF automatisch.
 
T

Toby

Dabei seit
07.12.2005
Beiträge
37
Lösche mal alle IDE Conroller aus dem Gerätemanger und starte dann neu, um die Controller neu erkennen zu lassen. Hat bei mir jedes mal geklappt.
 
Transe

Transe

BANNED
Dabei seit
27.08.2005
Beiträge
376
Alter
113
Ich schliesse mich Zulli an.

Wuerde aber so vorgehen!

1.)

Primary Master: 120 GB Maxtor

Primary Slave: 250 GB Samsung

Secondary Master: 250 GB Samsung

Secondary Slave:DVD-Laufwerk Toshiba

2.) Du verwendest auf sicher die Falschen Kabel
 
Z

ZULLI

Gast
Moin hab mich nochmal schlau gemacht:

Unterstützung für Ultra-ATA 100 aktivieren

Selbst mit dem Service Pack 1 unterstützt Win2000 den Ultra-ATA100-Modus (UDMA5) nicht, sondern stellt nur den Ultra-ATA66-Modus (UDMA4) ein. Erst SP2 unterstützt UDMA5.Abhilfe bei Microsoft Knowledg-Base versuchen und den Microsoft Patch installieren, den es aber nur auf Anfrage bei Microsoft gibt.
 
Y

Yanou

Dabei seit
07.12.2005
Beiträge
567
Alter
37
Ort
Berlin
Kabel könnens nicht sein ... da das bios alles richtig anzeigt ...
ob das dvd laufwerk am master oder slave am secondary hängt vollkomme egal ... der strang (primary oder secondary) ist immer so schnell wie daslangsamste mitglied ... egal ob slave oder master ...

desweiteren:

empfohlen wird trotzdem immer die festplatten zu erst anzuschließen und dann optische laufwerke ... weil so die adressierung anders bearbeitet wird und die 3. platte am secondary ein ganz wenig schnellere zugriffszeiten hat ... drauf achten 80 poll kabel zu nehmen (was du ja zumindest am primary bereits tust, da sonst im bios kein udma 5 stehen dürfte) ... bei den 80 polligen kabeln darauf achten das das richte ende im mainboard steckts ... (blauer stecker MB, grauer Master, schwarzer Slave) ... sonst gibbet den PIO mode (haste aber offensichtlich uch richtig weil dann auch im bios pio stehen würd)

ansonsten schließe ich mich meinen vorrednern an ... löschma den ide controller und dessen primary und secondary gefolgt von nem neustart ... versuchs auch mal mitm löschen der festplattentreiber in windows

ich empfehle auch des neueste service pack und diesen patch auf anfrage (siehe post von ZULLI)

Gruß Yanou
 
D

duesso

Dabei seit
15.12.2005
Beiträge
4.324
Ort
Mettmann
Gehe mal meine Anlteiung mit dem Reg-Schlüssel durch !
Bei mir hat es das gebracht, seitdem habe ich wieder UDMA auf allen HDD's !!! :prof
 
Z

ZULLI

Gast
Hallo duesso
Hier der Schlüssel:Um diesen zu aktivieren, muss in der Registry unter HKEY_LOCAL_MACHINE \ System \ CurrentControlSet \ Control \ Class \ {4D36E96A - E325 - 11CE - BFC1 - 08002BE10318} \ 0000 ein neuer Wert mit dem Namen "EnableUDMA100" als REG_DWORD hinzugefügt werden.
Mit dem SP2 wird dann auch von Haus aus DMA66 und DMA100 unterstützt.
Gruß ZULLI
 
D

duesso

Dabei seit
15.12.2005
Beiträge
4.324
Ort
Mettmann
ZITAT(ZULLI @ 08.05.2006, 17:42) Quoted post
Hallo duesso
Hier der Schlüssel:Um diesen zu aktivieren, muss in der Registry unter HKEY_LOCAL_MACHINE \ System \ CurrentControlSet \ Control \ Class \ {4D36E96A - E325 - 11CE - BFC1 - 08002BE10318} \ 0000 ein neuer Wert mit dem Namen "EnableUDMA100" als REG_DWORD hinzugefügt werden.
Mit dem SP2 wird dann auch von Haus aus DMA66 und DMA100 unterstützt.
Gruß ZULLI
[/b]

ICh nehme an du wolltest mir sagen ich hätte kein SP2 draufgehabt - IRRTUM ! War drauf und der Wert hat sich zurückgestellt - lies mal genau warum er das getan hat - denn das in meinem Beitrag oben stimmt so und war bei mir der Fall...
 
M

mabuse

Threadstarter
Dabei seit
24.04.2006
Beiträge
9
Sooo . . .
mit etwas Verzögerung (war länger offline) jetzt mal mein Feedback.

Grundsätzlich erst mal meinen Dank an alle, die sich zu Wort gemeldet haben.
Es geht auch wieder.
Dennoch möchte ich auch noch einige Kommentare loslassen, weil hier doch einges an Halbwissen verbreitet/zitiert wird, was ich so nicht stehen lassen kann.
  1. Wir reden von einem Win 2000 mit SP 4 und allen Patches. Also nix ist mit irgenein SP kann das nicht (Gut, das hätte ich vieleicht dabei schreiben sollen - mein Fehler).

  2. Natürlich benutze ich 80 polige Kabel - sonst würde das BIOS die Platten kaum richtig erkennen. Mit 40 Polen ist bei UDMA 33 Schluß.

  3. ZITAT(oldie007 @ 04.05.2006, 13:31) Quoted post
    Ich würde behaupten, das beide 250GB Festplatten vom BIOS schon falsch erkannt werden, denn ich kann mir nicht vorstellen, daß eine 250GB Festplatte nur UDMA4 hat, sie sollte als UDMA5 erkannt werden! :prof[/b]
    Sie hat nur UDMA 4.
    Zu deiner Information: Es gibt noch reichlich Platten mit UDMA 4 - besonders die "langsamen" von Samsung, und um solche handelt es sich hier. Mir ist Ruhe mittlerweile wichtiger als ein bischen Speed, das man eh nur messen, nicht aber spüren kann, darum kaufe ich nur noch Platten mit 5200 UpM - soweit erhältlich.

    Außerdem sollte man mal klarstellen, das die höheren UDMA-Modi völliger Humbug sind, reines Marketinggeklapper.
    Keine zur Zeit erhältliche IDE-Platte ist von Ihrer Datenübertragungsrate her in der Lage, auch nur den UDMA 66-Mode auszulasten!
    Ob eine Platte mit UDMA 66, 100 oder 133 läuft ist völlig Jacke! Bei meinen "langsamen" Samsung-Platten (36 MB/s Dauerübertragungsrate) würde selbst UDMA 33 nur 10% Geschwindigkeitsverlust bedeuten, selbst da könnte ich mit leben.

    Wichtig ist halt nur, das sie überhaupt in irgendeinem DMA-Mode läuft, denn nur in diesem Modus schaufelt der Controller die Daten selber in den Speicher. Beim PIO-Mode begrüßt die CPU höchstpersönlich jedes einzelne Byte mit Handschlag - und das zieht die ganze Kiste runter!
    (Wobei sich natürlich die Frage aufdrängt, wie es sein kann, das ein Pentium 100 im PIO-Mode Platten mit ~10-12 MB/s ohne Stress bedienen konnte, eine CPU mit der 30-fachen Leistung sich dagegen an einer gerade dreimal so schnellen Platte derartig einen abbricht. Naja, vermutlich mal wieder schlampige Programmierung bei M$)
  4. ZITAT(ZULLI @ 08.05.2006, 03:06) Quoted post
    Dein Dvd bremst die schnellen Laufwerke sonst aus da es ja nur im UDMA-Modus 33 läuft und bei dir als Master vor der schnelleren Festplatte hängt.Anschliesend ein Bios-Reset und Windows hochfahren,Controllertreiber installiert WINDOOF automatisch.
    [/b]
    Also erstens ist das am Thema vorbei - DVD hängt am sekundären Port, das Problem trat aber am primären Port auf. Also kein wirklich logischer Zusammenhang.

    Zweitens ist das völliger Unfug. Die Zeiten, in denen das optische Laufwerk eine Platte ausgebremst hat, sind lange vorbei.
    Jeder auch nur halbwegs aktuelle IDE-Controller (nicht älter als sechs (!!!) Jahre) ist durchaus in der Lage, die Geschwindigkeit des IDE-Busses bei jedem Zugriff neu einzustellen. Das ein CD/DVD-Laufwerk eine Platte ausbremst ist eine Weisheit aus dem vorigen Jahrtausend. Mal ganz davon abgesehen, das es in diesem Falle schnurzegal wäre, wer Master und wer Slave ist . . .

  5. @duesso:
    You are my man!
    Ich hätt's zwar ne ganze Ecke kürzer formuliert :D aber es war wirklich nur der Registry-Schlüssel. Löschen, neustarten - Kiste rennt wie die Hölle.

    Ich danke dir vielmals!
Und allen anderen natürlich auch, schon alleine für die Tatsache, das sie sich mein Problem angesehen haben. Macht weiter so!
 
Thema:

[gelöst] UDMA-Festplatte nur PIO-Mode

[gelöst] UDMA-Festplatte nur PIO-Mode - Ähnliche Themen

Lan Controller wird nicht erkannt: Guten Tag zusammen, Ich habe folgendes problem, vor 5 Tagen hat sich mein PC, nachdem ich in einem Spiele Ladevorgang versehentlich rausgetabt...
Sata-Festplatten werden nicht erkannt: Hallo liebe Community, bin kurz davor mit der Axt des [email protected]@@@@ PC zu zerlegen:wut Bevor ich die Axt aber hole, frage ich lieber mal Euch. Also...
GELÖST 2 Festplatte läuft immer im PIO Modus!!!! Hilfe: Hallo ich habe folgendes Problem meine 2 Festplatte will einfach nicht mehr im DMA 6 modus laufen sondern nur noch im PIO Modus , hab meine beiden...
Neue Platte: SATA oder IDE?: Hallo zusammen!!! meine jetzige Konfiguration sieht folgendermaßen aus: Systemplatte: 120 GB Samsung - Primary Master DVD-Brenner - Primary...
Windows XP startet nach erfolgreicher "Datenträgerkomprimierung" nacht mehr!: Hi! Ich habe ein sehr grosses Problem. Da der Speicherplatz auf meinen Systemlaufwerk "C:\" immer knapper wurde, habe ich versucht durch die...

Sucheingaben

makstor diamond plus 9 kein pio mode 4

,

aspire 5100 Festplatte nur pio mode

,

Festplatte nur als udma 33

Oben