[gelöst] PHP mit IIS läuft nicht

Diskutiere [gelöst] PHP mit IIS läuft nicht im Windows Server 2003 Forum im Bereich Windows Server 2003; Hi ich hätte heute auf meinen Homeserver PHP als ISAPI-Modul installiert. (Win32, Installer-Version) Es scheint auch alles zu funktionieren. In...
#1
DiableNoir

DiableNoir

Threadstarter
Dabei seit
18.01.2004
Beiträge
6.069
Hi

ich hätte heute auf meinen Homeserver PHP als ISAPI-Modul installiert. (Win32, Installer-Version)

Es scheint auch alles zu funktionieren. In der Computerverwaltung wird PHP als "Zugelassen" angezeigt.

Ich habe eine neue Website (Port 8123) eingerichtet, allerdings gibt der Server nur leere Seiten zurück...aber keine Fehler.

Das Internetgastkonto hat Lesezugriff auf das Programmverzeichnis von PHP.

Kann mir jemand weiterhelfen? :unsure
 
Zuletzt bearbeitet:
#2
BrandyJr

BrandyJr

Dabei seit
02.11.2003
Beiträge
3.707
Alter
37
Ort
Berlin
Bist du sicher mit den Rechten? Soweit ich mich errinnere, musste man irgendwo im IIS angeben, das man die PHP-Scripte lesen UND ausführen darf.
Ich hab allerdings weder einen W2k3 Server, noch irgendwo IIS am laufen, kann das also im Moment nicht reproduzieren.

Hier ist eine kleine Anleitung zu dem Thema: http://www.zdnet.de/builder/program/0,39023551,39148930-5,00.htm
 
#3
DiableNoir

DiableNoir

Threadstarter
Dabei seit
18.01.2004
Beiträge
6.069
Der Installer sollte das alles automatisch durchführen, hat er auch getan. Alles ist im IIS registriert, auch die PATH-Variable wurde aktualisiert.

Die Option bei der Website, dass Skripts ausgeführt werden dürfen wäre auch aktiviert.
 
#4
ae.eXe

ae.eXe

VIDEO-Team
Dabei seit
27.03.2007
Beiträge
219
Alter
34
Ort
ZH-CH
PHP auf nem IIS ist immer so eine Sache :) musst ich vor kurzem auch installieren.

hast du eine PHP Seite die du nicht angezeigt kriegst? ansonsten mach mal ne index.php in der du nur phpinfo() aufrufst. wenn diese seite dir dann die PHP konfiguration des Server anzeigt, dann is php korrekt installiert.

hast du als default Website die index.php eingetragen? ansonsten wird der Server keine einstiggseite finden und dir auch keine seite anzeigen.

Leider hab ich atm kein zugriff auf den meinen IIS mit php um die genauen Konfigurationseinstellungen zu prüfen werd ich am Montag dann jedoch machen.
 
#5
DiableNoir

DiableNoir

Threadstarter
Dabei seit
18.01.2004
Beiträge
6.069
Ja, also ich habe eigentlich nur eine index.php im Verzeichnis. In der ist nur ein Echo- und ein phpinfo-Aufruf zum Testen. In den Einstellungen der Website habe ich index.php eingetragen und ganz oben in die Liste gesetzt.

Wenn das Teil zumindest irgendwo einen Fehler anzeigen würde. :wut Führt der IIS für sowas irgendwo eine Protokolldatei?

Bei der ersten Verbindung nach dem Start des IIS-Services rattert die Festplatte auch lauter als sonst. (Ist bei ASP-Seiten auch immer so) Also irgendwas scheint er zu machen, aber er gibt einfach nichts aus...auch der Quelltext ist vollkommen leer. :cheesy

Hoffentlich bekomme ich das irgendwie hin...ich will nicht extra wegen dieser einen kleinen PHP-Page zusätzlich einen Apache aufsetzen. :flenn
 
#6
ae.eXe

ae.eXe

VIDEO-Team
Dabei seit
27.03.2007
Beiträge
219
Alter
34
Ort
ZH-CH
Hab mir eben mal kurz nen IIS mit PHP aufgesetzt. dazu als erstes den IIS mit den Grundsettings installiert. Da ich keine andere Website drauf hab läuft das bei mir über Port 80 und die Default Web Site. Dann von PHP.net das PHP Package geladen und installiert (bei der installation die php extension automatisch einrichten lassen.). Dann Settings in den Bildern im Anhang vorgenommen. extension überprüfen. als letztes n neues php File erstellt mit folgendem Inhalt:

PHP:
<?php
phpinfo();
?>
Dann auf die Default Web Site rechte Maustaste und Browse. dann wird rechts bei korrekter installation die PHPinfo angezeigt.

Wenn das klappt, solltest du auch vom Browser aus mit folgender adresse http://localhost/ auf die phpinfo Seite gelangen. für deinen speziellen fall, hängst du einfach den port an. sieht dann irgendwie so aus http://localhost:1234
 

Anhänge

#7
DiableNoir

DiableNoir

Threadstarter
Dabei seit
18.01.2004
Beiträge
6.069
Danke für die Mühe. :blush

Das hätte ich auch alles gemacht. Inzwischen habe ich auch herausgefunden woran es lag: Die eingebundene EXIF-Erweiterung von PHP funktionierte nicht. Der Fehler lag also beim PHP selber nicht beim Aufruf über IIS. Beim Deaktivieren dieser Erweiterung und einem Neustart des IIS spuckte er endlich die Seite brav aus.

Eigentlich wollte ich mir die manuelle Konfiguration der php.ini mit der automatischen Installation ersparen, aber anscheinend setzt diese einige Werte nicht so, wie ich sie haben will.

Was ich aber immer noch nicht verstehe, ist obwohl jetzt überall in der php.ini eingestellt ist, dass er jeden Fehler loggen und auch anzeigen soll, selbiges nicht macht, wenn ich diese Erweiterung wieder einbinde. Auch eine leere Seite gibt er dann wieder aus.

Die einzige Möglichkeit zu überprüfen ob er alle Eweiterungen laden kann, scheint der manuelle Start der php.exe zu sein. :unsure

Naja, zumindest funktioniert's wieder. :danke
 
#8
H

HSeiffert

Dabei seit
15.07.2007
Beiträge
1
Alter
66
Hatte das selbe Problem!

Hab mir eben mal kurz nen IIS mit PHP aufgesetzt. dazu als erstes den IIS mit den Grundsettings installiert. Da ich keine andere Website drauf hab läuft das bei mir über Port 80 und die Default Web Site. Dann von PHP.net das PHP Package geladen und installiert (bei der installation die php extension automatisch einrichten lassen.). Dann Settings in den Bildern im Anhang vorgenommen. extension überprüfen. als letztes n neues php File erstellt mit folgendem Inhalt:

PHP:
<?php
phpinfo();
?>
Dann auf die Default Web Site rechte Maustaste und Browse. dann wird rechts bei korrekter installation die PHPinfo angezeigt.

Wenn das klappt, solltest du auch vom Browser aus mit folgender adresse http://localhost/ auf die phpinfo Seite gelangen. für deinen speziellen fall, hängst du einfach den port an. sieht dann irgendwie so aus http://localhost:1234

:up Hat mir sehr geholfen, besser kann man es nicht erklären!
HSeiffert
 
Thema:

[gelöst] PHP mit IIS läuft nicht

Sucheingaben

iis zeigt kein html an

,

php extension iis funktioniert nicht

[gelöst] PHP mit IIS läuft nicht - Ähnliche Themen

  • [GELÖST] Ladezeit der Homepage mit PHP ermitteln

    [GELÖST] Ladezeit der Homepage mit PHP ermitteln: Hallo Forum, weiß zufällig jemand wie ich die Generationszeit von einem PHP File ermittelt??? Wie auf http://www.community.cback.de/ Ganz unten...
  • [GELÖST] Bilder wie bei CrystalXP und PHP zur verkleinerrung

    [GELÖST] Bilder wie bei CrystalXP und PHP zur verkleinerrung: Hallo, ich möchte ein kleines Bilderalbum anfertigen und habe die Frage wie es geht dass die Bilder sich im Vordergrund vergrößern. Siehe z.B...
  • [gelöst]kostenlose shopsoftware ohne php, mysql, asp

    [gelöst]kostenlose shopsoftware ohne php, mysql, asp: hi community, ich suche für meine firma eine kostenlose shopsoftware für einen internetshop. das problem an der sache ist, dass unser webserver...
  • [gelöst]Probleme bei der Php und Mysql programmierung

    [gelöst]Probleme bei der Php und Mysql programmierung: Hallo @all! Ich habe das Problem das ich Daten aus einer Mysql Datenbank auslesen soll und diese dann als Link darstellen soll. Leider gibt es...
  • [gelöst]Wie kann ich mit PHP mail's verschicken ?

    [gelöst]Wie kann ich mit PHP mail's verschicken ?: Hi, wie es der Titel verrät, wollte ich fragen, was ich machen muss um mit php mails zu verschicken ? PS: Ich habe ein e-mail script (es...
  • Ähnliche Themen

    Oben