gaim-0.7.5 compiliert auf SuSE 8.2 nicht

Diskutiere gaim-0.7.5 compiliert auf SuSE 8.2 nicht im Linux Forum im Bereich Weitere Betriebssysteme; Auf meinem einen SuSE 8.2 System compiliert gaim-0.7.5 nicht, obwohl es eine identische Installation wie bei meinem zweiten Rechner ist...
M

morpheus2051

Threadstarter
Mitglied seit
13.02.2002
Beiträge
376
Auf meinem einen SuSE 8.2 System compiliert gaim-0.7.5 nicht, obwohl es eine identische Installation wie bei meinem zweiten Rechner ist.

./configure bricht immer mit folgenden Ausgaben ab:

checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
*** GTK+ 2.0 is required to build Gaim; please make sure you have the GTK+
*** development headers installed. The latest version of GTK+ is
*** always available at http://www.gtk.org/.

$PATH ist folgendermaßen gesetzt (gleich wie beim zweiten Rechner auch):

bash: /usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome2/bin:/opt/gnome/bin:/opt/kde3/bin:
/usr/lib/java/bin:/opt/gnome/bin

Unter Stichpunkt 'gtk' habe ich folgende RPMs auf meinen Systemen installiert:
[Behalten] anjuta | 1.0.0-119 | 2.8 MB
[Behalten] gamix | 1.99.p13-167 | 104.4 kB
[Behalten] Geramik | 0.23-14 | 479.1 kB
[Behalten] glade | 0.6.4-398 | 3.7 MB
[Behalten] glade2 | 1.1.2-183 | 2.9 MB
[Behalten] glademm | 0.6.4-287 | 1.9 MB
[Behalten] glib | 1.2.10-372 | 352.0 kB
[Behalten] gob | 1.0.12-107 | 218.2 kB
[Behalten] gpsk31 | 0.2.4a-490 | 148.4 kB
[Behalten] gq | 0.6.0-194 | 418.1 kB
[Behalten] gtk | 1.2.10-546 | 2.4 MB
[Behalten] gtk2 | 2.2.1-29 | 6.7 MB
[Behalten] gtk2-devel | 2.2.1-29 | 1.3 MB
[Behalten] gtk2-doc | 2.2.1-29 | 7.1 MB
[Behalten] gtk2-engines | 2.2.0-39 | 197.4 kB
[Behalten] gtk2-themes | 0.1-347 | 181.9 kB
[Behalten] GtkAda | 2.0.1-155 | 11.1 MB
[Behalten] gtkam | 0.1.10-69 | 349.4 kB
[Behalten] gtkcomm | 0.5.13-585 | 438.6 kB
[Behalten] gtk-devel | 1.2.10-546 | 2.7 MB
[Behalten] gtkdoc | 0.10-50 | 320.6 kB
[Behalten] gtk-engines | 0.12-664 | 1.0 MB
[Behalten] gtkglarea | 1.2.2-552 | 85.9 kB
[Behalten] gtkhtml | 1.1.8-27 | 1.9 MB
[Behalten] gtkhtml-devel | 1.1.8-27 | 1.1 MB
[Behalten] gtkmm | 1.2.10-26 | 1.7 MB
[Behalten] gtkmm-devel | 1.2.10-26 | 3.2 MB
[Behalten] gtkref | nover-479 | 5.5 MB
[Geschützt -- nicht verändern] gtkspell | (null) | 47.6 kB
[Geschützt -- nicht verändern] gtkspell-devel | (null) | 24.2 kB
[Behalten] gtk-themes | 20001105-406 | 5.9 MB
[Behalten] gtkutils | 0.6.0-480 | 378.0 kB
[Behalten] guile-gtk_1_2 | 0.31-72 | 1.4 MB
[Behalten] gwget | 0.5.2-319 | 123.3 kB
[Behalten] gxmhtml | 1.4.1.7-256 | 1.0 MB
[Behalten] libexif-gtk | 0.3.3-49 | 154.2 kB
[Behalten] libgtkhtml | 2.2.0-35 | 664.2 kB
[Behalten] libgtkhtml-devel | 2.2.0-35 | 879.9 kB
[Behalten] mtr-gtk | 0.52-32 | 115.2 kB
[Behalten] nautilus2-gtkhtml | 0.3.2-400 | 85.0 kB
[Behalten] perl-Gtk-Perl | 0.7008-732 | 3.5 MB
[Behalten] powertweak-gtk | 0.99.4-212 | 63.3 kB
[Behalten] python-gtk | 1.99.14-37 | 4.6 MB
[Behalten] python-wxGTK | 2.4.0.2-21 | 10.1 MB
[Behalten] wxGTK | 2.4.0-45 | 10.7 MB
[Behalten] wxGTK-devel | 2.4.0-45 | 2.9 MB
[Behalten] wxGTK-gl | 2.4.0-45 | 47.6 kB

Leider kann ich auf meinem andern System auch keine RPM bauen, da der Vorgang immer mit
suche(rpm-requirements)...
suche(rpm-provides)...
exit0
abbricht.

Wenn jemand eine Lösung für das compilier Problem hat, wäre ich ihm sehr dankbar!

MfG, morpheus
 
stpe

stpe

Mitglied seit
14.11.2001
Beiträge
2.729
ein, zwei ideen:

- sind die header-dateien vorhanden? (vielleicht die devel-pakete nochmal nachinstallieren)
- wenn die header-files vorhanden sind: kannst Du dem configure-script das verzeichnis uebergeben, in dem diese stehen? (./configure --help)
- hast Du schon von www.gtk.org die aktuellste gtk+-version installiert?
 
M

morpheus2051

Threadstarter
Mitglied seit
13.02.2002
Beiträge
376
Ich habe die Lösung gefunden. Header waren nicht da.
Und jetzt zu dem RPM-build Problem. Anscheinend funktioniert die original gaim spec file nicht. Hier habe ich eine neue für gaim 0.77 erstellt.

Code:
Name: gaim
Summary: A Gtk+ based multiprotocol instant messaging client
Version: 0.77
Release: 0
License: GPL
Group: Applications/Internet
Source: %{name}-%{version}.tar
BuildRoot: %{_tmppath}/build-root-%{name}
Provides: gaim
Requires: gtk2 >= 2.0.0, gtkspell, audiofile, libao
Packager: gaim
Distribution: SuSE 8.2
Prefix: /usr
Url: gaim.sf.net
Vendor: gaim.sf.net

%description
Gaim allows you to talk to anyone using a variety of messaging
protocols, including AIM (Oscar and TOC), ICQ, IRC, Yahoo!,
MSN Messenger, Jabber, Gadu-Gadu, Napster, and Zephyr. These
protocols are implemented using a modular, easy to use design.
To use a protocol, just add an account using the account editor.

Gaim supports many common features of other clients, as well as many
unique features, such as perl scripting, TCL scripting and C plugins.

Gaim is NOT affiliated with or endorsed by America Online, Inc.,
Microsoft Corporation, Yahoo! Inc., or ICQ Inc.

%prep
rm -rf $RPM_BUILD_ROOT 
mkdir $RPM_BUILD_ROOT

%setup -q

%build
CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" \
./configure --prefix=%{prefix}
make -j 2

%install
make DESTDIR=$RPM_BUILD_ROOT install-strip

cd $RPM_BUILD_ROOT


find . -type d -fprint $RPM_BUILD_DIR/file.list.%{name}.dirs
find . -type f -fprint $RPM_BUILD_DIR/file.list.%{name}.files.tmp
sed '/\/man\//s/$/.gz/g' $RPM_BUILD_DIR/file.list.%{name}.files.tmp > $RPM_BUILD_DIR/file.list.%{name}.files
find . -type l -fprint $RPM_BUILD_DIR/file.list.%{name}.libs
sed '1,2d;s,^\.,\%attr(-\,root\,root) \%dir ,' $RPM_BUILD_DIR/file.list.%{name}.dirs > $RPM_BUILD_DIR/file.list.%{name}
sed 's,^\.,\%attr(-\,root\,root) ,' $RPM_BUILD_DIR/file.list.%{name}.files >> $RPM_BUILD_DIR/file.list.%{name}
sed 's,^\.,\%attr(-\,root\,root) ,' $RPM_BUILD_DIR/file.list.%{name}.libs >> $RPM_BUILD_DIR/file.list.%{name}

%clean
rm -rf $RPM_BUILD_ROOT
rm -rf $RPM_BUILD_DIR/file.list.%{name}
rm -rf $RPM_BUILD_DIR/file.list.%{name}.libs
rm -rf $RPM_BUILD_DIR/file.list.%{name}.files
rm -rf $RPM_BUILD_DIR/file.list.%{name}.files.tmp
rm -rf $RPM_BUILD_DIR/file.list.%{name}.dirs

%files -f ../file.list.%{name}
%defattr(-,root,root,0755)
 
M

morpheus2051

Threadstarter
Mitglied seit
13.02.2002
Beiträge
376
Sorry, dass das so lange gedauert hat. Hatte den Rechner verliehen. :D
 
stpe

stpe

Mitglied seit
14.11.2001
Beiträge
2.729
musst Dich doch nicht dafuer entschuldigen, was Du mit Deinem eigenen rechner anstellst ;) - war nur ein belustigter hinweis auf den schon etwas angestaubten beitrag :D
 
M

morpheus2051

Threadstarter
Mitglied seit
13.02.2002
Beiträge
376
Besser spät als nie! :D
 
Thema:

gaim-0.7.5 compiliert auf SuSE 8.2 nicht

gaim-0.7.5 compiliert auf SuSE 8.2 nicht - Ähnliche Themen

  • Gaim Dateitransfer

    Gaim Dateitransfer: Tag! Benutzt von euch einer Gaim im ICQ-Netz mit funktionierendem Dateitransfer? Scheitert bei mir immer an angeblichem Abbruch durch Benutzer...
  • Gaim - Statusoptionen

    Gaim - Statusoptionen: Hallo! Ich habe ein Problem mit Gaim: Ich habe aus Versehen, als ich die Buddy-Liste geöffnet hatte, aber als ich noch nicht "Verfügbar" war...
  • [Gelöst] Mit Gaim in den Chat - Wie?

    [Gelöst] Mit Gaim in den Chat - Wie?: N´Abend allerseits! Bin zwar kein Chatter, aber den vom Winboard will ich mir doch mal ansehen. Dazu kommt, das ich von dem ganzen IRC-Gedöns...
  • Problem mit Gaim und MSN

    Problem mit Gaim und MSN: Hallo, ich habe Gaim 1.5.0 und wieder mal ein Problem am Rechner meiner Tochter. Meine Tochter hat sich ein MSN - Konto angelegt, aber jedesmal...
  • GAIM kann sich nicht verbinden

    GAIM kann sich nicht verbinden: Hi Leute, ich hab folgendes Problem: Ich verwende Portable GAIM und kann mich von meinem Arbeitsplatz im Büro nicht verbinden. In den...
  • Ähnliche Themen

    • Gaim Dateitransfer

      Gaim Dateitransfer: Tag! Benutzt von euch einer Gaim im ICQ-Netz mit funktionierendem Dateitransfer? Scheitert bei mir immer an angeblichem Abbruch durch Benutzer...
    • Gaim - Statusoptionen

      Gaim - Statusoptionen: Hallo! Ich habe ein Problem mit Gaim: Ich habe aus Versehen, als ich die Buddy-Liste geöffnet hatte, aber als ich noch nicht "Verfügbar" war...
    • [Gelöst] Mit Gaim in den Chat - Wie?

      [Gelöst] Mit Gaim in den Chat - Wie?: N´Abend allerseits! Bin zwar kein Chatter, aber den vom Winboard will ich mir doch mal ansehen. Dazu kommt, das ich von dem ganzen IRC-Gedöns...
    • Problem mit Gaim und MSN

      Problem mit Gaim und MSN: Hallo, ich habe Gaim 1.5.0 und wieder mal ein Problem am Rechner meiner Tochter. Meine Tochter hat sich ein MSN - Konto angelegt, aber jedesmal...
    • GAIM kann sich nicht verbinden

      GAIM kann sich nicht verbinden: Hi Leute, ich hab folgendes Problem: Ich verwende Portable GAIM und kann mich von meinem Arbeitsplatz im Büro nicht verbinden. In den...
    Oben