FTP Server hinter Fritzbox

Diskutiere FTP Server hinter Fritzbox im Security / Firewall / Virenabwehr Forum im Bereich Software Forum; Hi @all, zu meiner Frage hier habe ich schon Beiträge gefunden, aber leider nicht den Tipp, den ich benötige. Bei mir funktioniert es nämlich...
G

glencairn

Gast
Hi @all,

zu meiner Frage hier habe ich schon Beiträge gefunden, aber leider nicht den Tipp, den ich benötige. Bei mir funktioniert es nämlich noch nicht und zwar ...

Ich habe eine Fritzbox. Über selfhost.de möchte ich meine IP publizieren und das wird mir auch bei selfhost.de schon richtig angezeigt. In meinem Netzwerk habe ich einen FTP Server (www.serverelements.com) bzw. www.freenas.org laufen. Bleibe ich mal beim Beispiel Naslite, so kann ich im localen Netzwerk darauf mit FileZilla arbeiten und im Prinzip ist es so, wie ich es möchte, aber der externe Zugriff will mir einfach nicht gelingen.

Ich suche jetzt jemanden der das schon einmal gemacht hat und mir "zur Seite" stehen kann, um das Problem zu lösen. Bin für jede Hilfe dankbar und mag Sie noch so klein sein.

Viele Grüße an dieser Stelle
Glencairn.
 
G

GaxOely

Gast
Ich habe folgende SYS:
Filezilla FTP server
http://www.dyndns.com/ als weiterleitung.
Und im router diese adresse eingetragen, damit die Ip geleitet wird!
 
G

glencairn

Gast
Hallo,

also ich habe das jetzt auch bei www.dyndns.org gemacht und mich dort angemeldet. Bei der FB habe ich die Änderungen eingetragen. Und dort bei der Portfreigabe die IP meines FTP Servers im eigenen Netz hinterlegt.

Wenn ich per FileZilla auf meinen lokalen Server gehe, dann funktioniert die Verbindung. Gebe ich meine Internet-IP ein (oder dyndns-Domain), dann geht das nicht. Als Laie würde ich sagen die Portfreigabe ist nicht aktiv (Kreuzchen ist in der FB 7170 gemacht!).

Pingen kann ich auf meinen DynDNS Eintrag und erhalte auch meine Internet-IP. Da auf meinem FTP auch Telnet läuft habe ich noch folgendes ausprobiert:

telnet LOKALE_IP_VOM_FTP_SERVER 23

-> Verbindung geht.

telnet LOKALE_IP_DER_FRITZBOX 23000

-> geht nicht. Habe Portfreigabe eingetragen in der Fritzbox. Von Port 23000 auf LOKALE_IP_VOM_FTP_SERVER und dort Port 23.

:confused

Kann doch nicht so schwierig sein. :sleepy

Gruß
Glencairn
 
G

GaxOely

Gast
FTP sollte immer Port 21 Belegen.
Dieser ist auch standardmäßig in der Fritzbox aktiv.
Vielleicht ist deine Windowsfirewall noch an... oder die Nvidia von der Netzwerkkarte?
 
G

glencairn

Gast
Ich trau' mich schon fast nicht mehr.

@Babylein, danke für den Link. Habe es mir durchgelesen. War soweit auch okay und leider war meine Lösung nicht dabei.

Ich habe jetzt DHCP bei meiner FB 7170 ausgetragen. Aber das Ergebnis ist noch das gleiche. Ich kann meinen FTP Server lokal anpingen und auch mit einem FTP Client darauf arbeiten. Meine Domain bei dyndns.org kann ich auch anpingen und es wird die IP der Fritzbox (öffentliche IP vom ISP) zurück gegeben. Das geht also auch. Aber die Portfreischaltung will er wohl einfach nicht fressen -> siehe Anlage.

Die Firmware ist aktuell und hat den Stand 29.04.29.

Alternativen zu DynDns.org (z. B. no-ip.com) brauche ich wohl nicht ausprobieren, weil die Auflösung ja funktioniert. Bei meinem FTP Client habe ich testweise auch mal meine IP Adresse vom ISP angegeben - ohne Erfolg. Auch die interne IP von der Fritzbox habe ich probiert - ohne Erfolg. Das müsste doch beides funktionieren wegen Portweiterleitung. (Vielleicht geht es auch nicht, weil ich im lokalen Netz mich bewege).

Über http://www.web2ftp.de habe ich es auch schon probiert (mit ISP IP und DynDns Domain). Ohne Erfolg.

Dann habe ich mal einen HTTP Server aufgesetzt und den Port 80 freigegeben - kein Zugriff (lokal geht, aber nicht übers Web).

Meine Suche im Internet hat mich bislang nicht weitergebracht.

Ach ja, ich habe auch noch bei der Portweiterschaltung die Option "für alle anderen Ports" verwendet, aber auch das ohne Erfolg.

Irgendwo habe ich noch einen Punkt, auf den mich die Forenbesucher hoffentlich bringen können.

Gute Nacht für heute erstmal.

Glencairn:flenn
 

Anhänge

B

babylein

Mitglied seit
05.11.2006
Beiträge
1.994
Standort
auf der erde oder auch nicht
Ich trau' mich schon fast nicht mehr.

@Babylein, danke für den Link. Habe es mir durchgelesen. War soweit auch okay und leider war meine Lösung nicht dabei.

Ich habe jetzt DHCP bei meiner FB 7170 ausgetragen. Aber das Ergebnis ist noch das gleiche. Ich kann meinen FTP Server lokal anpingen und auch mit einem FTP Client darauf arbeiten. Meine Domain bei dyndns.org kann ich auch anpingen und es wird die IP der Fritzbox (öffentliche IP vom ISP) zurück gegeben. Das geht also auch. Aber die Portfreischaltung will er wohl einfach nicht fressen -> siehe Anlage.

Die Firmware ist aktuell und hat den Stand 29.04.29.

Alternativen zu DynDns.org (z. B. no-ip.com) brauche ich wohl nicht ausprobieren, weil die Auflösung ja funktioniert. Bei meinem FTP Client habe ich testweise auch mal meine IP Adresse vom ISP angegeben - ohne Erfolg. Auch die interne IP von der Fritzbox habe ich probiert - ohne Erfolg. Das müsste doch beides funktionieren wegen Portweiterleitung. (Vielleicht geht es auch nicht, weil ich im lokalen Netz mich bewege).

Über http://www.web2ftp.de habe ich es auch schon probiert (mit ISP IP und DynDns Domain). Ohne Erfolg.

Dann habe ich mal einen HTTP Server aufgesetzt und den Port 80 freigegeben - kein Zugriff (lokal geht, aber nicht übers Web).

Meine Suche im Internet hat mich bislang nicht weitergebracht.

Ach ja, ich habe auch noch bei der Portweiterschaltung die Option "für alle anderen Ports" verwendet, aber auch das ohne Erfolg.

Irgendwo habe ich noch einen Punkt, auf den mich die Forenbesucher hoffentlich bringen können.

Gute Nacht für heute erstmal.

Glencairn:flenn
Hallo
guck mal das 2te bild an , vielleicht muss du den ftp-server ein hagen rein

mfg
 

Anhänge

G

GaxOely

Gast
Im Post #6
Ist das überhaupt deine IP von deiner Netzwerkkarte?

Nachtrag!
Schalte mal die Firewall der Fritzbox aus!
Du klickst in der Portfreigabe ganz unten exposited Host an und dann sind alle Port frei!
Wenn es dann nicht geht liegt es an deiner Netzwerkkarte bzw. Firewall von Windows oder ... welche Netzwerkkarte hast du?
 
automatthias

automatthias

vernunftgeplagt
Mitglied seit
21.04.2006
Beiträge
8.349
FTP sollte immer Port 21 Belegen.
Dieser ist auch standardmäßig in der Fritzbox aktiv.
Vielleicht ist deine Windowsfirewall noch an... oder die Nvidia von der Netzwerkkarte?
Nein. Der Port 21 ist in der Fritzbox standardmäßig NICHT aktiv. Man muss ihn unter den Netzwerkeinstellungen --> Portfreigabe ausdrücklich einschalten.
Das gilt nur, wenn wie bei glencairn der eigene Rechner FTP-Server sein soll.
Wenn man als normaler User von seinem PC aus etwas aus dem Internet über FTP holen will, braucht man Port 21 auf der Fritzbox nicht freizuschalten.

Das zweite ist, wenn Du noch die Windows-Firewall oder was ähnliches am Laufen hast, musst Du da wohl auch den Port 21 frei geben.
 
G

glencairn

Gast
Hallo,

danke für die Antworten.

Auf dem FTP Server läuft www.freenas.org bzw. Naslite und da gibt es keine Windows-Firewall. Testweise meinen Windows-Rechner eingetragen (siehe oben) und ich nutze W2K. Also auch keine Windows-Standard-Firewall. Meine aktive Firewall habe ich sogar ganz beendet.

Keine Chance. Habe jetzt eine andere Netzwerkkarte eingebaut. Fritzbox auch schon aus-/eingeschalten. Auch mit neuer Netzwerkkarte (Typ 3Com) kein positives Ergebnis. Alles gleich bleibend.

Ich habe echt keine Idee mehr. :wut

Vielleicht habt ihr noch weitere Ideen, was ich ausprobieren könnte.

Gruß
Glencairn
 
G

GaxOely

Gast
Nein. Der Port 21 ist in der Fritzbox standardmäßig NICHT aktiv. Man muss ihn unter den Netzwerkeinstellungen --> Portfreigabe ausdrücklich einschalten.
Das gilt nur, wenn wie bei glencairn der eigene Rechner FTP-Server sein soll.
Wenn man als normaler User von seinem PC aus etwas aus dem Internet über FTP holen will, braucht man Port 21 auf der Fritzbox nicht freizuschalten.

Das zweite ist, wenn Du noch die Windows-Firewall oder was ähnliches am Laufen hast, musst Du da wohl auch den Port 21 frei geben.
Achja? Von was reden wir hier? Nicht vom surfen auf FTP
Wenn ich das Häkchen wegmache kommt niemand mehr auf meinen FTP.....
Was sagst du dazu?
Und das ist bei meiner Fritz box genauso!
Ich habe auf meinem Rechner FileZilla Server laufen
 

Anhänge

automatthias

automatthias

vernunftgeplagt
Mitglied seit
21.04.2006
Beiträge
8.349
Achja? Von was reden wir hier? Nicht vom surfen auf FTP
Wenn ich das Häkchen wegmache kommt niemand mehr auf meinen FTP.....
Was sagst du dazu?
Und das ist bei meiner Fritz box genauso!
Ich habe auf meinem Rechner FileZilla Server laufen
Auf meiner Fritzbox ist der Port 21 für FTP-Server standardmäßig AUS.
Wenn ich einen Filezilla Server aufsetzen wollte, müsste ich also das Häkchen setzen. Da sehe ich also keinen Widerspruch zu dem was Du sagst.
Höchstens, dass ich behaupte, die Standardeinstellung ist AUS, d.h. ich kann ftp als Client, aber eben nicht als Server.
 

Anhänge

Travel-pc

Travel-pc

Laptop-Fan
Mitglied seit
25.08.2006
Beiträge
6.063
Standort
Nord-Europa
Hallo,

bei einem Verbindungsaufbau von DEINEM Netzwerk in die Außenwelt hindert dich
nur die firewallsettings in XP , dies wird dann auch erstmalig am Bildschirm
angezeigt und bei "nicht mehr Fragen" ist dies dann Freigeschaltet !!!
( Oder selbst das Progamm dort eintragen)
Aber ankommend ist man hinter einem ROUTER sowohl mit der IP
( daher DNSORG -> ) als mit den Ports gesperrt !!!!!!
Daher muß ANKOMMEND die Anfage vom Port z.b. 21 ( ftp) im ROUTER
freigegeben und auch entsprechend bei NAT in ROUTER natürlich dann
auch dieser Port21 zum einem ZIELRECHNER ( IP !!!! )
UMGELEITET UND FREIGEGEBEN werden. Also bei der Fritzbox Haken rein
und evtl. auch noch den FTP-Server ( Ziel ) mit IP eintragen !

Dann sollte es auch gehen, wenn dann das Passwort stimmt !
;) ;)
 
G

glencairn

Gast
[gelöst] FTP Server hinter Fritzbox

Durch vieles Suchen im Internet nach jemanden der das gleiche Problem wie einer selbst hat, kann man irgendwann fündig werden. Und wie oft findet man tatsächlich jemanden der das Problem hatte? Ich eigentlich oft. Dann findet man noch so Einträge wie "jetzt geht es. Danke" und eine Lösung steht nicht dabei.

Das will ich doch mal nicht so machen.

Also:

1. es geht jetzt
2. Lösung: Beim FTP Server als Gateway die IP der Fritzbox (intern).

Tja. Was soll ich sagen.

Jetzt auf zur nächsten Problemlösung :-)

Viele Grüße und danke an meine Helfer.

Glencairn
 
Thema:

FTP Server hinter Fritzbox

Sucheingaben

fritzbox2

,

fritzbox ftp port weiterleiten

,

freenas hinter der fritzbox

FTP Server hinter Fritzbox - Ähnliche Themen

  • Windows Explorer kann nicht auf FTP-Server zugreifen!!!

    Windows Explorer kann nicht auf FTP-Server zugreifen!!!: Hallo liebe Community, ich hoffe jemand kann mir helfen. Ich habe bisher immer mit Windows Explorer per FTP auf meinen Handy zugegriffen. Doch...
  • GELÖST FTP- Server- Adresse für Passiv-Modus nicht routingfähig

    GELÖST FTP- Server- Adresse für Passiv-Modus nicht routingfähig: Hallo Wissende. Ich möchte gerne auf einen QNAP NAS (QNAP TS-412 Firmware: 4.0.2) einen FTP Server mit SSL/TLS (explizit) einrichten. Den FTP...
  • Firefox 21 kann über FTP-Server von Mozilla bereits heruntergeladen werden

    Firefox 21 kann über FTP-Server von Mozilla bereits heruntergeladen werden: Dieses mal hat es lange fünf Wochen gedauert, bis eine neue Version von Firefox das Licht der Öffentlichkeit erblickt. Da die Version 21 noch...
  • Firefox 20 kann über FTP-Server von Mozilla bereits heruntergeladen werden

    Firefox 20 kann über FTP-Server von Mozilla bereits heruntergeladen werden: Knapp zwei Wochen nach dem letzten Update steht schon wieder eine neue Firefox-Version vor der Tür. Die 20. Auflage des beliebten Browsers kommt...
  • GELÖST Geschw. Problem beim Upload (FTP-Server)

    GELÖST Geschw. Problem beim Upload (FTP-Server): Hi, heute zum ersten mal mit meinem neuen Internetanschluss den FTP Server in Betrieb genommen und die Geschwindigkeit lässt dabei sehr zu...
  • Ähnliche Themen

    Oben