GELÖST Autoremove will zuviel löschen in Debian Wheezy

Diskutiere Autoremove will zuviel löschen in Debian Wheezy im Linux Forum im Bereich Weitere Betriebssysteme; Ich hab ein kleines Problem mit dem autoremove von Debian: apt-get install -f Reading package lists... Done Building dependency tree...
P

Primadonna

Threadstarter
Mitglied seit
22.05.2008
Beiträge
613
Ich hab ein kleines Problem mit dem autoremove von Debian:

Code:
apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  aisleriot ant ant-optional at-spi2-core baobab browser-plugin-gnash ca-certificates-java caja caja-common caribou
  caribou-antler cheese dconf-tools default-jre default-jre-headless empathy empathy-common engrampa engrampa-common eom
  eom-common espeak-data ffmpegthumbnailer ffmpegthumbnailer-caja file-roller finger fonts-cantarell fonts-opensymbol
  fonts-sil-gentium fonts-sil-gentium-basic fonts-stix fuse-utils gcalctool gdebi gdm3 gedit gedit-common gedit-plugins
  gir1.2-atspi-2.0 gir1.2-gdata-0.0 gir1.2-gnomekeyring-1.0 gir1.2-goa-1.0 gir1.2-gtop-2.0 gir1.2-gucharmap-2.90
  gir1.2-javascriptcoregtk-3.0 gir1.2-rb-3.0 gir1.2-tracker-0.14 gir1.2-webkit-3.0 gir1.2-wnck-3.0 glchess glines gnash
  gnash-common gnect gnibbles gnobots2 gnome-backgrounds gnome-dictionary gnome-disk-utility gnome-documents gnome-font-viewer
  gnome-games gnome-games-data gnome-games-extra-data gnome-icon-theme-extras gnome-mag gnome-nettool gnome-orca
  gnome-packagekit gnome-packagekit-data gnome-screenshot gnome-shell-extensions gnome-sudoku gnome-system-log
  gnome-tweak-tool gnome-video-effects gnomine gnotravex gnotski gnuchess gnuchess-book grilo-plugins-0.1 gtali
  gtk2-engines-murrine gtk3-engines-unico gucharmap guile-2.0-libs hamster-applet hddtemp hyphen-en-us iagno
  icedtea-6-jre-cacao icedtea-6-jre-jamvm icedtea-netx icedtea-netx-common inkscape iputils-tracepath java-common
  libapache-pom-java libart-2.0-2 libatk-adaptor libatk-adaptor-data libatk-bridge2.0-0 libatk-wrapper-java
  libatk-wrapper-java-jni libatspi1.0-0 libatspi2.0-0 libavahi-gobject0 libavahi-ui-gtk3-0 libbonoboui2-0 libbonoboui2-common
  libboost-program-options1.49.0 libboost-thread1.49.0 libbrlapi0.5 libcaribou-gtk-module libcaribou-gtk3-module libcmis-0.2-0
  libcolamd2.7.1 libcolorblind0 libcommons-beanutils-java libcommons-collections3-java libcommons-compress-java
  libcommons-digester-java libcommons-logging-java libcommons-parent-java libdb-java libdb-je-java libdb5.1-java
  libdb5.1-java-jni libdee-1.0-4 libdiscid0 libdmapsharing-3.0-2 libdotconf1.0 libespeak1 libexttextcat-data libexttextcat0
  libffmpegthumbnailer4 libgail-common libgdict-1.0-6 libgdict-common libgdu-gtk0 libgeocode-glib0 libgexiv2-1 libgladeui-1-9
  libgnome-mag2 libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-0 libgnomeui-common libgpod-common libgpod4
  libgraphite2-2.0.0 libgrilo-0.1-0 libgtk-vnc-2.0-0 libgtkmm-2.4-1c2a libgtksourceview2.0-0 libgtksourceview2.0-common
  libgupnp-av-1.0-2 libgupnp-dlna-1.0-2 libgvnc-1.0-0 libhsqldb-java libhyphen0 libicu4j-java libjaxp1.3-java libjline-java
  libjpeg62 libjtidy-java liblightdm-gobject-1-0 liblinear-tools liblinear1 liblouis-data liblouis2 liblucene2-java
  libmagick++5 libmate libmate-common libmatebluetooth libmatecanvas libmatecomponent libmatecomponentui libmatekbd
  libmatemenu libmatepanelapplet libmatepolkit libmatesensorsappletplugin libmateui libmatevfs libmateweather
  libmateweather-common libmatewnck libmatewnck-common libminiupnpc5 libmtp-common libmtp-runtime libmtp9 libmythes-1.2-0
  libnatpmp1 liboobs-1-5 libplot2c2 libpstoedit0c2a libraw5 libregexp-java libreoffice libreoffice-base libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge libreoffice-evolution
  libreoffice-filter-binfilter libreoffice-filter-mobiledev libreoffice-gnome libreoffice-gtk libreoffice-help-en-us
  libreoffice-impress libreoffice-java-common libreoffice-math libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-writer librhythmbox-core6 librpm3 librpmio3 libsensors4 libservlet2.5-java
  libsofia-sip-ua-glib3 libsofia-sip-ua0 libsonic0 libspeechd2 libstlport4.6ldbl libsvm-tools libtasn1-3-bin
  libtelepathy-farstream2 libunique-3.0-0 libvisio-0.0-0 libwnck-common libwnck22 libwpd-0.9-9 libwpg-0.2-2 libwps-0.2-2
  libxalan2-java libxerces2-java libxml-commons-external-java libxml-commons-resolver1.1-java libxz-java lightdm-gtk-greeter
  lightsoff lp-solve mahjongg mate-applets mate-applets-common mate-backgrounds mate-bluetooth mate-calc mate-control-center
  mate-desktop mate-desktop-common mate-keyring mate-media mate-media-common mate-media-gstreamer mate-menus mate-mime-data
  mate-netspeed mate-panel mate-panel-common mate-polkit mate-power-manager mate-power-manager-common mate-screensaver
  mate-sensors-applet mate-session-manager mate-settings-daemon mate-settings-daemon-common mate-settings-daemon-gstreamer
  mate-system-monitor mate-system-tools mate-terminal-common mate-text-editor mate-themes mate-user-share mate-utils mate-vfs
  mate-vfs-common mate-window-manager media-player-info minissdpd mobile-broadband-provider-info mozo murrine-themes
  mythes-en-us nautilus-sendto-empathy network-manager-gnome nmap openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib
  p7zip-full perlmagick pstoedit python-brlapi python-corba python-gconf python-gnome2 python-gst0.10 python-gtksourceview2
  python-louis python-mako python-markupsafe python-mate python-mate-desktop python-mate-menu python-notify python-pyatspi
  python-pyatspi2 python-pyorbit python-speechd python-uno python-wnck python-zeitgeist quadrapassel rdesktop rhythmbox
  rhythmbox-data rhythmbox-plugin-cdrecorder rhythmbox-plugins rpm-common rpm2cpio rygel rygel-playbin rygel-preferences
  rygel-tracker seahorse shotwell shotwell-common simple-scan sound-juicer sound-theme-freedesktop speech-dispatcher
  swell-foop system-tools-backends telepathy-gabble telepathy-idle telepathy-logger telepathy-rakia telepathy-salut
  transmission-common transmission-gtk ttf-liberation ttf-sil-gentium-basic tzdata-java uno-libs3 unoconv ure vinagre vino
  xbrlapi xdg-user-dirs-gtk xfonts-mathml xul-ext-adblock-plus xulrunner-10.0 zeitgeist-core
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Der will zuviel löschen :(
Sogar den MATE Desktop...

Weiß jemand abhilfe?
 
Keruskerfürst

Keruskerfürst

Mitglied seit
28.07.2005
Beiträge
3.059
Alter
48
Standort
Horgau
Die richtigen Befehle zum Aufräumen des Systems sind doch:
apt-get autoremove und apt-get autoclean.
 
P

Primadonna

Threadstarter
Mitglied seit
22.05.2008
Beiträge
613
ja, wenn ich autoremove eintippe kommt dasselbe...

Autoclean hab ich noch nie verwendet, aber im Squeeze war das nicht so.
(Das oben ist wheezy - fresh install)
 
P

Primadonna

Threadstarter
Mitglied seit
22.05.2008
Beiträge
613
Dass kann doch nicht sooooooo beta sein, oder? :(
Das baut ja auf Squeeze auf und da kam das nicht....


Wenn man Debian neu installiert und die gesamte Festplatte verwendet: wird dann auch automatisch formatiert?
Neue Partitionen hat er angelegt (Squeeze: ext3, Wheezy: ext4)
 
F

Freeway92

Mitglied seit
10.12.2012
Beiträge
19
Alter
26
Standort
Wunstorf
Das Problem liegt daran das irgendwo eine Fehlerhafte Abhängigkeit eines Pakets vorliegt was bei Wheezy schonmal vorkommen kann da es leider nur eine Beta ist.

Ich würde empfehlen einfach etwas abwarten und bald wird das Problem gelöst sein ;)
 
P

Primadonna

Threadstarter
Mitglied seit
22.05.2008
Beiträge
613
verstehe ich das richtig, dass Abhängigkeit und Paketverwenden 2 verschiedene Dinge sind?
Also dass ein Paket auf einem anderen aufbaut das für Wheezy ist, aber in den Abhängigkeiten drinsteht, dass das Paket für Squeeze verwendet werden soll und damit der Autoremove das dann löschen will?


(Also so ähnlich wie in der sources drinsteht, Repo Wheezy main - aber mit Repo Squeeze main) ?
 
Keruskerfürst

Keruskerfürst

Mitglied seit
28.07.2005
Beiträge
3.059
Alter
48
Standort
Horgau
Wenn man z.B. ein Desktop wie Gnome, KDE installiert, dann wird automatisch auch X11 installiert. Dies ist dann eine Paketabhängigkeit.
Wenn man unter KDE z.B. den Konqueror installiert, dann werden keinen weiteren Pakete mit installiert.
 
Zuletzt bearbeitet:
D

dlonra

Mitglied seit
19.10.2005
Beiträge
1.149
Unter Ubuntu gibt es ja diesen Befehl um Pakete zur reparieren:

sudo dpkg --configure -a

Ahso, ich hab auch noch Synaptic installiert, da gibt es in der Oberfläche im Menü ein reperatur von defekten Paketen.
Es steht bei mir öfters das apt keine Superkuhkräfte hat :-)
 
P

Primadonna

Threadstarter
Mitglied seit
22.05.2008
Beiträge
613
habs bei synaptiv das fix broken packages gemacht, keine Änderung.
Auch dpkh --configur..... auch nix
Immer noch extrem viele Paktete beim autoremove :(


root@debian:/home/general# dpkg --configure -a
root@debian:/home/general# apt-get autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
aisleriot ant ant-optional at-spi2-core baobab browser-plugin-gnash caribou
caribou-antler cheese cups-filters dconf-tools empathy empathy-common
espeak-data file-roller finger fonts-cantarell fonts-opensymbol gcalctool
gdebi gdm3 gedit gedit-common gedit-plugins gir1.2-atspi-2.0
gir1.2-gdata-0.0 gir1.2-gnomekeyring-1.0 gir1.2-goa-1.0 gir1.2-gtop-2.0
gir1.2-gucharmap-2.90 gir1.2-javascriptcoregtk-3.0 gir1.2-rb-3.0
gir1.2-tracker-0.14 gir1.2-webkit-3.0 gir1.2-wnck-3.0 glchess glines gnash
gnash-common gnect gnibbles gnobots2 gnome-backgrounds gnome-dictionary
gnome-disk-utility gnome-documents gnome-font-viewer gnome-games
gnome-games-data gnome-games-extra-data gnome-icon-theme-extras gnome-mag
gnome-nettool gnome-orca gnome-packagekit gnome-packagekit-data
gnome-screenshot gnome-shell-extensions gnome-sudoku gnome-system-log
gnome-tweak-tool gnome-video-effects gnomine gnotravex gnotski gnuchess
gnuchess-book grilo-plugins-0.1 gtali gucharmap guile-2.0-libs
hamster-applet hplip-data hyphen-en-us iagno inkscape iputils-tracepath
libapache-pom-java libatk-adaptor libatk-adaptor-data libatk-bridge2.0-0
libatspi1.0-0 libatspi2.0-0 libavahi-gobject0 libavahi-ui-gtk3-0
libboost-program-options1.49.0 libboost-thread1.49.0 libbrlapi0.5
libcaribou-gtk-module libcaribou-gtk3-module libcmis-0.2-0 libcolamd2.7.1
libcolorblind0 libcommons-beanutils-java libcommons-collections3-java
libcommons-compress-java libcommons-digester-java libcommons-logging-java
libcommons-parent-java libcupscgi1 libcupsfilters1 libcupsmime1 libdb-java
libdb-je-java libdb5.1-java libdb5.1-java-jni libdee-1.0-4 libdiscid0
libdmapsharing-3.0-2 libdotconf1.0 libespeak1 libexttextcat-data
libexttextcat0 libgail-common libgdict-1.0-6 libgdict-common libgdu-gtk0
libgeocode-glib0 libgexiv2-1 libgnome-mag2 libgpod-common libgpod4
libgraphite2-2.0.0 libgrilo-0.1-0 libgtk-vnc-2.0-0 libgupnp-av-1.0-2
libgupnp-dlna-1.0-2 libgutenprint2 libgvnc-1.0-0 libhsqldb-java libhyphen0
libicu4j-java libjaxp1.3-java libjline-java libjtidy-java
liblightdm-gobject-1-0 liblinear-tools liblinear1 liblouis-data liblouis2
liblucene2-java libminiupnpc5 libmythes-1.2-0 libnatpmp1 libraw5
libregexp-java libreoffice libreoffice-base libreoffice-base-core
libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
libreoffice-emailmerge libreoffice-evolution libreoffice-filter-binfilter
libreoffice-filter-mobiledev libreoffice-gnome libreoffice-gtk
libreoffice-help-en-us libreoffice-impress libreoffice-java-common
libreoffice-math libreoffice-report-builder-bin libreoffice-style-galaxy
libreoffice-style-tango libreoffice-writer librhythmbox-core6 libsane-hpaio
libservlet2.5-java libslp1 libsofia-sip-ua-glib3 libsofia-sip-ua0 libsonic0
libspeechd2 libstlport4.6ldbl libsvm-tools libtelepathy-farstream2
libunique-3.0-0 libvisio-0.0-0 libwnck-common libwnck22 libwpd-0.9-9
libwpg-0.2-2 libwps-0.2-2 libxalan2-java libxerces2-java
libxml-commons-external-java libxml-commons-resolver1.1-java libxz-java
lightdm-gtk-greeter lightsoff lp-solve mahjongg media-player-info minissdpd
mobile-broadband-provider-info mythes-en-us nautilus-sendto-empathy
network-manager-gnome nmap perlmagick python-brlapi python-imaging
python-louis python-mako python-markupsafe python-pexpect python-pyatspi
python-pyatspi2 python-renderpm python-reportlab python-reportlab-accel
python-speechd python-uno python-wnck python-zeitgeist quadrapassel rdesktop
rhythmbox rhythmbox-data rhythmbox-plugin-cdrecorder rhythmbox-plugins rygel
rygel-playbin rygel-preferences rygel-tracker seahorse shotwell
shotwell-common simple-scan sound-juicer sound-theme-freedesktop
speech-dispatcher ssl-cert swell-foop telepathy-gabble telepathy-idle
telepathy-logger telepathy-rakia telepathy-salut transmission-common
transmission-gtk ttf-liberation ttf-sil-gentium-basic uno-libs3 unoconv ure
vinagre vino xbrlapi xdg-user-dirs-gtk xfonts-mathml xul-ext-adblock-plus
xulrunner-10.0 zeitgeist-core
0 upgraded, 0 newly installed, 256 to remove and 0 not upgraded.
After this operation, 857 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
 
P

Primadonna

Threadstarter
Mitglied seit
22.05.2008
Beiträge
613
Weiß es jetz...
Ich hab den Iceweasel gelöscht, und dabei wurde was von Gnome auch gelöscht.

Completely removed the following packages:
iceweasel

Removed the following packages:
gnome-core
task-gnome-desktop


gestern hab ich dann einfach mal autoremove gemacht...
Hatte dann keine Oberfläche mehr und bin nun (mal wieder) am Debian neu aufsetzen .
 
Keruskerfürst

Keruskerfürst

Mitglied seit
28.07.2005
Beiträge
3.059
Alter
48
Standort
Horgau
Hatte dann keine Oberfläche mehr und bin nun (mal wieder) am Debian neu aufsetzen .
Das ist aber gar nicht nötig.
Code:
apt-get install gnome
behebt das Problem mit dem fehlenden Desktop.
 
P

Primadonna

Threadstarter
Mitglied seit
22.05.2008
Beiträge
613
ja, ich verwende aber MATE
 
Keruskerfürst

Keruskerfürst

Mitglied seit
28.07.2005
Beiträge
3.059
Alter
48
Standort
Horgau
Dann eben

apt-get install "Dein bevorzugter Desktop"
 
Cyron

Cyron

SPONSOREN
Mitglied seit
25.12.2004
Beiträge
3.280
Alter
30
Standort
far beyond /dev/null
Naja apt-get ist einfach Mist. Die Abhängigkeitsauflösung ist der größte Murks seit der Erfindung von Relais ... oder vielleicht schon länger.

Aptitude unterscheidet Pakete die du installiert hast und Pakete die automatisch installiert wurden. Und entscheidet entsprechend die Automatischen so zu installieren das möglichst viele Manuell installierte funktionsfähig bleiben. Das Problem ist bei dir nun das apt-get schon murks gemacht hat. Aber einen Versuch ist es wert:

poste mal die Ausgaben von
Code:
sudo aptitude install
und
Code:
sudo apt-get install
 
Thema:

Autoremove will zuviel löschen in Debian Wheezy

Autoremove will zuviel löschen in Debian Wheezy - Ähnliche Themen

  • Fehlermeldung über zuviele Mobile Partnerschaften

    Fehlermeldung über zuviele Mobile Partnerschaften: Ich erhalte nachstehende Fehlermeldung per Email: Sie verfügen über 10 Telefonpartnerschaften von den maximal zulässigen 10...
  • Alte Silverlight löschen . ZUviele UPDATEs mit Fehleranzeige.

    Alte Silverlight löschen . ZUviele UPDATEs mit Fehleranzeige.: Hallo, nachdem ich Windows 10 kurz nach Einrichtung wieder zurück auf Windows 7 ging. Haben sich Probleme eingestellt. Unter anderem sind zuviel...
  • Zuviele Anmeldugen auf meinem Konto

    Zuviele Anmeldugen auf meinem Konto: Kann keine Anmeldungen zum abstellen finden, um wieder auf mein konto zugreifen zu können
  • cmd.exe belegt zuviel Arbeitsspeicher

    cmd.exe belegt zuviel Arbeitsspeicher: Hallo mal wieder zusammen, ich würde meine Frage auch gerne hier stellen, da ich das Gefühl habe es hängt wohl eher an Windows. Siehe hier...
  • Microsoft Lumia 550 verbraucht viel zuviel Datenvolumen

    Microsoft Lumia 550 verbraucht viel zuviel Datenvolumen: Guten Abend Zusammen, ich habe mir vor kurzem ein Microsoft Lumia 550 mit Windows 10 bei unserem örtlichen Telekomhändler gekauft. Bisher hatte...
  • Ähnliche Themen

    Oben