autom. Updates werden nicht installiert

Diskutiere autom. Updates werden nicht installiert im WinXP - Allgemeines Forum im Bereich Windows XP Forum; Hi @ all ! Nach einer Rep. Installation von XP pro. funzt das System bis auf die autom. Updates wieder sehr gut. Es werden in etwa 77 Updates...
T

t6thSenSe

Threadstarter
Mitglied seit
20.05.2002
Beiträge
16
Hi @ all !
Nach einer Rep. Installation von XP pro. funzt das System bis auf die autom. Updates wieder sehr gut.
Es werden in etwa 77 Updates angezeigt, die bereits downgeloadet sind, aber nicht installiert werden (können).
Die WGA Prüfung habe ich bereits mehrmals durchgeführt, hilft aber trotzdem nicht weiter.
Hat hier jemand einen Ansatz od. Rat für mich ???

lg aus Österreich
t6thSenSe
 
HaraldL

HaraldL

Mitglied seit
26.07.2006
Beiträge
5.804
Standort
Niederbayern
Leider nein, aber exakt das gleiche Problem bei einem Kundenrechner heute nachmittag. In den einzelnen KBxxx.LOG-Dateien im Windows-Ordner deutet alles auf ein Problem mit dem Windows-Installer hin. Habe diesen sowie alle dazu gehörenden weiteren Updates (Paketinstaller, XP-Updates die den MSI betreffen) bereits deinstalliert und neu installiert, der Dienst läßt sich starten aber keine Updates werden installiert (egal ob vom WSUS3 oder direkt über Microsoft Update). Manuell kann ich die über MU gefundenen Updates über den Link "weitere Infos" herunterladen und installieren, ist aber keine Lösung.

Werde den Rechner daher neu aufsetzen, Daten sind sowieso keine drauf weil es ein reiner Netzwerkarbeitsplatz ist. Habe zwar in der letzten Zeit keine Rep-Installation durchgeführt aber ein Problem mit den Updates gab es dabei früher noch nie.
 
T

t6thSenSe

Threadstarter
Mitglied seit
20.05.2002
Beiträge
16
Hi @all !
Naja, die Lösungsvorschläge halten sich in Grenzen;)
Hab dazu mal eine offizielle Anfrage an das MS Update Supp.Team gesendet,
mal sehen was da so kommt.
Werde die Vorschläge von MS posten, wenn Interesse besteht...

cu
t6thSenSe
 
I

imaetz70

Mitglied seit
07.12.2005
Beiträge
9.246
Alter
48
Standort
Hamburg
eventuell mal auf die MS-Updateseite wechseln, denke dort dürfte sich auch etwas für den windows-installer finden lassen, damit er wieder richtig funktioniert. scheinbar fehlte ein systemneustart für eine abzuschlißenede installtion eines updates, was wohl durch die reparatur wieder als offen in der registry steht. das zu schließen, dürfte leider schwer fallen. leider verlangen MS-Updates meist nen neustart des PC.. eventuell hilft dir das updatepack von winfuture hier weiter.. geh mal dahin und setz das drüber.. winfuture stellen trotz verbot von MS diese packs wieder her und wenn du das nutzt, dürfte dir ansich aber nichts passieren seitens MS.

das wurde schonmal hier diskutiert, aber ich denke in deinem fall sollte es dir helfen..
 
HaraldL

HaraldL

Mitglied seit
26.07.2006
Beiträge
5.804
Standort
Niederbayern
eventuell mal auf die MS-Updateseite wechseln, denke dort dürfte sich auch etwas für den windows-installer finden lassen, damit er wieder richtig funktioniert.
Hatte ich bereits versucht. Wenn ich dort die den Installer betreffenden Updates zu installieren versuche bricht er genauso ab. Gehe ich über die jeweiligen Info-Links und lade das Update manuell herunter und installiere ich es manuell dann klappt es. Habe auf diesem Weg bereits alle den Installer betreffenden Updates manuell eingespielt, das automatische Update klappt trotzdem nicht.

Offtopic: Habe den betroffenen Rechner inzwischen neu aufgesetzt nur hat der scheinbar ein Hardwareproblem, bootet während des Arbeitens sporadisch neu ohne Bluescreen oder Eintrag im Ereignisprotokoll (ja die Einstellung bei Fehlern einen automatischen Neustart durchzuführen ist abgeschaltet). Der Rechner ist nagelneu da muß wohl die Garantie herhalten. Evtl. probiere ich noch ein anderes Netzteil falls ich ein passendes finde ansonsten geht er zurück.
 
Peter Schirmer

Peter Schirmer

Dienstleister / Moderator
Mitglied seit
14.04.2006
Beiträge
7.060
Alter
39
Standort
7th Avenue, Ecke XP und Vista, 8ter Stock, Wohnung
Hi,

halte den Dienst "Automatische Updates" doch einmal an; zu finden unter "Start => Einstellungen => Systemsteuerung => Verwaltung => Dienste

Dann unter C:\Windows den Ordner "SoftwareDistribution" umbenennen. Anschließend den Dienst "Automatische Updates" wieder starten.

Läuft's nun?

Peter
 
Peter Schirmer

Peter Schirmer

Dienstleister / Moderator
Mitglied seit
14.04.2006
Beiträge
7.060
Alter
39
Standort
7th Avenue, Ecke XP und Vista, 8ter Stock, Wohnung
Poste doch einmal die letzten 20 Zeilen der WindowsUpdate.log, zu finden unter c:\WINDOWS\WindowsUpdate.log bzw c:\WINDOWS\Windows Update.log (beachte die Leerzeichen!).

Da sollte sich auch ein Hinweis auf den Fehler finden, meiste eine Fehlernummer bzw. eine Liste der Updates, die zur Installation vorgesehen waren.
 
HaraldL

HaraldL

Mitglied seit
26.07.2006
Beiträge
5.804
Standort
Niederbayern
Ich kann leider nicht mehr nachschauen da ich, wie ich weiter oben bereits schrieb, die Kiste plattgemacht und neu installiert habe. Aber evtl. kann t6thSenSe die Zeilen posten. Interessant sind übrigens auch die KBxxx Logdateien im Windows-Ordner (nach Datum sortieren, die neuesten sind die fehlgeschlagenen), auch dort steht ein Fehlergrund drin (irgendwas mit setup.ver oder install.ver falsche Version)
 
Peter Schirmer

Peter Schirmer

Dienstleister / Moderator
Mitglied seit
14.04.2006
Beiträge
7.060
Alter
39
Standort
7th Avenue, Ecke XP und Vista, 8ter Stock, Wohnung
@t6thSenSe:

Poste Du doch einmal die aktuellen 20 Zeilen der Datei "c:\WINDOWS\WindowsUpdate.log" bzw "c:\WINDOWS\Windows Update.log" (Achtung, Leerzeichen beachten!)

Vielleicht gibt's dort eine aussagekräftige Fehlermeldung.

Peter
 
I

imaetz70

Mitglied seit
07.12.2005
Beiträge
9.246
Alter
48
Standort
Hamburg
da du die kiste neu gemacht hast, ist es gut möglich, dass einige updates erst installiert werden, wenn vorherige vorhanden sind...

hoffe du hast das SP2 auch installiert, denn ohne wird das nix mit den ganzen updates, da einige das SP2 vorschreiben wollen...
 
T

Tante_Trud

Mitglied seit
21.06.2006
Beiträge
29
Standort
Oldenburg
Man kann sich einfach den WindowsUpdateAgent30-x86 herunterladen und dann in der Eingabeaufforderung unter Windows das ding mit dem Befehl /wuforce starten. Der Befehl erzwingt die Installation und dann sollte es mit den Updates auch wieder funktionieren. (falls nur der 20 gefunden wird mit dem geht das auch)

Grüße
 
HaraldL

HaraldL

Mitglied seit
26.07.2006
Beiträge
5.804
Standort
Niederbayern
hoffe du hast das SP2 auch installiert, denn ohne wird das nix mit den ganzen updates, da einige das SP2 vorschreiben wollen...
Ist ein nagelneuer DELL-PC, in der XP-Pro-CD ist SP2 integriert. Und über den Firmen-WSUS-3.0 sehe ich ja ob irgendwelche Updates fehlen.

Wäre es ein PC mit wichtigen Daten oder extrem vielen Programmen oder komplizierten Lizenzen drauf hätte ich länger herumprobiert. Aber da es ein simpler Netzwerk-Arbeitsplatz mit wenigen Programmen ist der seine Daten sowieso auf dem Server speichert spiele ich mich nicht 2 Tage herum, ich muß der Firma die Zeit ja in Rechnung stellen die würden sich bedanken.

Ich habe jetzt schon mehrmals eine Reparaturinstallation von praktisch identisch konfigurierten Rechnern durchgeführt, so ein Problem hat sich dabei jedoch nie gezeigt. Muß mit irgendwelchen Windowsupdates der letzten 2-3 Monate zusammenhängen, vorher ging das einwandfrei.

@Tante_Trud: Der 3.0er Update Agent wird beim ersten Kontakt mit dem WSUS 3.0 automatisch aufgespielt und war auch drauf, an dem lag es (leider) nicht das wäre zu einfach gewesen.
 
T

t6thSenSe

Threadstarter
Mitglied seit
20.05.2002
Beiträge
16
hi !
hier die letzten 20 der WinLog:
21:25:56:546 912 254 AU >>## RESUMED ## AU: Installing update [UpdateId = {BBE805EE-2CF7-4110-9BE8-4FE32B144E5A}]
2007-08-07 21:25:56:546 912 254 AU # WARNING: Install skipped
2007-08-07 21:25:56:546 912 254 AU >>## RESUMED ## AU: Installing update [UpdateId = {F12451F5-3F5D-46DC-9718-ECBC7BB6304F}]
2007-08-07 21:25:56:546 912 254 AU # WARNING: Install skipped
2007-08-07 21:25:56:546 912 254 AU >>## RESUMED ## AU: Installing update [UpdateId = {D215BFF6-A748-4474-B477-B10E4099DE8F}]
2007-08-07 21:25:56:546 912 254 AU # WARNING: Install skipped
2007-08-07 21:25:56:546 912 254 AU >>## RESUMED ## AU: Installing update [UpdateId = {FD4C36F8-71C3-4059-9728-3AFB5BC17109}]
2007-08-07 21:25:56:546 912 254 AU # WARNING: Install skipped
2007-08-07 21:25:56:546 912 254 AU >>## RESUMED ## AU: Installing update [UpdateId = {C5A7BCFB-9DD1-446D-B9AC-ADE49460AA07}]
2007-08-07 21:25:56:546 912 254 AU # WARNING: Install skipped
2007-08-07 21:25:56:546 912 254 AU >>## RESUMED ## AU: Installing update [UpdateId = {1AFB1AFE-9AAF-4DC4-9DAC-C75303A84655}]
2007-08-07 21:25:56:546 912 254 AU # WARNING: Install skipped
2007-08-07 21:25:56:546 912 254 AU Install call completed.
2007-08-07 21:25:56:546 912 254 AU # WARNING: Install call failed, reboot required = No, error = 0x80004002
2007-08-07 21:25:56:546 912 254 AU #########
2007-08-07 21:25:56:546 912 254 AU ## END ## AU: Installing updates [CallId = {72B48960-EDD0-465B-A815-526B875E14A6}]
2007-08-07 21:25:56:546 912 254 AU #############
2007-08-07 21:25:56:546 912 254 AU Install complete for all calls, reboot NOT needed
2007-08-07 21:25:56:546 912 254 AU Setting AU scheduled install time to 2007-08-08 01:00:00
2007-08-07 21:26:54:593 3040 d08 CDM CancelCDMOperation
und hier noch die log eines der fehlgeschlagenen updates:

76.219: AnalyzeComponents: Hotpatch analysis disabled; skipping.
76.219: AnalyzeComponents: Hotpatching is disabled.
76.219: FindFirstFile c:\windows\$hf_mig$\*.*
81.360: KB933566 Setup hat folgenden Fehler festgestellt: Die Datei update.ver ist nicht richtig.
81.719: KB933566 Setup hat folgenden Fehler festgestellt: Die Datei update.ver ist nicht richtig.
81.719: KB933566 Setup hat folgenden Fehler festgestellt: Die Datei update.ver ist nicht richtig.
82.110: AnalyzeForBranching used 204 ticks.
93.266: AnalyzePhaseTwo used 11156 ticks
93.266: AnalyzePhaseThree used 0 ticks
93.266: AnalyzePhaseFive used 0 ticks
99.797: AnalyzePhaseSix used 6531 ticks
99.797: AnalyzeComponents used 64516 ticks
99.797: Downloading 0 files
99.797: bPatchMode = TRUE
99.797: Inventory complete: ReturnStatus=0, 68266 ticks
99.813: Num Ticks for invent : 68282
99.875: [dumpDownloadTask] We have all necessary files for the package to install. Return STATUS_READY_TO_INSTALL
99.875: dumpDownloadTask returned 0xf201 (ready to install)
100.235: Die Installation des KB933566 wurde nicht abgeschlossen.
100.235: Update.exe extended error code = 0xf201
von MS gibts, wie fast zu erwarten war, noch keine reaktion:thumbdown

lg aus österreich
t6thSenSE

ps: nach den fehlermeld. hab ich schon gegoogelt, führt leider zu nix...:flenn
 
T

t6thSenSe

Threadstarter
Mitglied seit
20.05.2002
Beiträge
16
hi nochmal !
die fehlermeldung in der WinLog lautet:

21:25:17:093 3040 f54 CDM WARNING: CCdm::ExecuteSearchForOneDriverUpdate failed, error = 0x80240024
2007-08-07 21:25:17:093 3040 f54 CDM WARNING: CCdm::FindMatchingDriver failed, error = 0x80240024
2007-08-07 21:25:17:093 3040 f54 CDM WARNING: FindMatchingDriver failed, error = 0x80240024
2007-08-07 21:25:19:218 912 1dc Report REPORT EVENT: {98004763-542C-43F6-988F-2ABDB5AAC1EF} 2007-08-07 21:25:13:984+0200 1 147 101 {00000000-0000-0000-0000-000000000000} 0 0 CDM Success Software Synchronization Windows Update Client successfully detected 0 updates.
2007-08-07 21:25:56:531 912 254 AU >>## RESUMED ## AU: Installing update [UpdateId = {ABB18003-B0AF-4162-BD1D-180941734EBA}]
2007-08-07 21:25:56:531 912 254 AU # WARNING: Install skipped
2007-08-07 21:25:56:531 912 f4 Agent * WARNING: Exit code = 0x80004002
 
HaraldL

HaraldL

Mitglied seit
26.07.2006
Beiträge
5.804
Standort
Niederbayern
Setup hat folgenden Fehler festgestellt: Die Datei update.ver ist nicht richtig.
Exakt die gleiche Meldung hatte ich auch bei allen ca. 80 fehlgeschlagenen Updates. Wäre interessant wenn jemand anderes jetzt bei einem voll gepatchten XP inkl. WMP11 und IE7 ebenfalls eine Reparaturinstallation macht, ob dann die gleichen Probleme auftauchen. Wenn mir langweilig sein sollte probier ich das mal unter VMware aus.
 
Peter Schirmer

Peter Schirmer

Dienstleister / Moderator
Mitglied seit
14.04.2006
Beiträge
7.060
Alter
39
Standort
7th Avenue, Ecke XP und Vista, 8ter Stock, Wohnung
Poste doch einmal die gesamte WindowsUpdate.log als Anhang.

Was sagt msconfig.exe? Deaktiviere mal alle Dienste, die NICHT von MS stammen und starte den Rechner neu.

Hast Du denn irgendwelche Dienste / Dinge im Hintergrund laufen?
 
T

t6thSenSe

Threadstarter
Mitglied seit
20.05.2002
Beiträge
16
Hi @ all !
Also der schwarze Peter liegt hier bei MS. Sobald man ein Rep. Installation durchführt bzw. durchgeführt hat werden die autom. Updates zwar heruntergeladen, aber deren Installation schlägt fehl. MS rät zu folgender Vorgangsweise:
1: Reparaturprogramm von MS downloaden
http://download.mshelper.de/mshregs/winUpdRstre.exe
2. Prog ausführen (kann ein paar Minuten dauern bis beendet)

Hat bei mir auf Anhieb geklappt !:sing


lg
t6thSenSe
 
Thema:

autom. Updates werden nicht installiert

autom. Updates werden nicht installiert - Ähnliche Themen

  • Update Heute ca. 15 Uhr autom.

    Update Heute ca. 15 Uhr autom.: Seit dieser Zeit kann ich auf meinem Lenovo Tabl. den Internet explor nicht starten Er geht auf und schließt gleich wieder. Ich schreibe jetzt...
  • nach autom. Update keinen Zugriff auf Programm

    nach autom. Update keinen Zugriff auf Programm: Guten Tag Geplagte, Windows 10 64b startete gestern selbstständig ein update. Leider startet das Programm jetzt gar nicht mehr. Ich kann...
  • Autom. Treiber-Update Synaptics-Mouse

    Autom. Treiber-Update Synaptics-Mouse: Jetzt hat es mich doch tatsächlich auch mal erwischt, dass die automatischen Treiber-Updates völlig vermurkst sind. Win 10 Home 1709 - 16299.334...
  • Autom. Windows 10 Update endet mit Fehlercode 0x8007001f

    Autom. Windows 10 Update endet mit Fehlercode 0x8007001f: Hallo mitsammen, mein PC hat aktuell die Version 1703 und seit 3 Wochen startet sich der Update Assistent und bricht nach mehren Stunden mit...
  • autom. updates

    autom. updates: das neue Dez. Funktionsupdate für Windows 10 Version 1709 vom 13.Dez.2017 ist fehlgeschlagen - PC ist neu und auf neuestem update Stand - Version...
  • Ähnliche Themen

    • Update Heute ca. 15 Uhr autom.

      Update Heute ca. 15 Uhr autom.: Seit dieser Zeit kann ich auf meinem Lenovo Tabl. den Internet explor nicht starten Er geht auf und schließt gleich wieder. Ich schreibe jetzt...
    • nach autom. Update keinen Zugriff auf Programm

      nach autom. Update keinen Zugriff auf Programm: Guten Tag Geplagte, Windows 10 64b startete gestern selbstständig ein update. Leider startet das Programm jetzt gar nicht mehr. Ich kann...
    • Autom. Treiber-Update Synaptics-Mouse

      Autom. Treiber-Update Synaptics-Mouse: Jetzt hat es mich doch tatsächlich auch mal erwischt, dass die automatischen Treiber-Updates völlig vermurkst sind. Win 10 Home 1709 - 16299.334...
    • Autom. Windows 10 Update endet mit Fehlercode 0x8007001f

      Autom. Windows 10 Update endet mit Fehlercode 0x8007001f: Hallo mitsammen, mein PC hat aktuell die Version 1703 und seit 3 Wochen startet sich der Update Assistent und bricht nach mehren Stunden mit...
    • autom. updates

      autom. updates: das neue Dez. Funktionsupdate für Windows 10 Version 1709 vom 13.Dez.2017 ist fehlgeschlagen - PC ist neu und auf neuestem update Stand - Version...
    Oben