Arbeitsstunden???

Diskutiere Arbeitsstunden??? im MS Office 2007 Forum im Bereich Office Produkte; Moin moin Gibt es für Exel eine Formel um Arbeitsstunden zu errechen. Meinte für die Nachtschicht. Von 22:30 - 6:30 zeigt die Formel immer...
C

cactusjack

Threadstarter
Mitglied seit
18.12.2006
Beiträge
61
Moin moin

Gibt es für Exel eine Formel um Arbeitsstunden zu errechen.
Meinte für die Nachtschicht.
Von 22:30 - 6:30 zeigt die Formel immer minusstunden an.
Mann muss aber plusstunden haben.
Bitte um eine Formel
 
Zyndstoff

Zyndstoff

Mitglied seit
26.10.2010
Beiträge
2.445
Alter
57
Standort
BERLIN
Du musst mit Datum rechnen, dann geht es auch.
Also Zelle A1 = 01.03.2011 22:30
Zelle B1 = 02.03.2011 06:30

Zelle C1 = B1-A1
Ergebnis: 08:00

Besser wäre eine VBA Funktion mit datediff()
 
HaraldL

HaraldL

Mitglied seit
26.07.2006
Beiträge
5.804
Standort
Niederbayern
Es geht auch ohne Datum, mit einer WENN-Formel: Angenommen die Zeiten stehen in B2 und C2 würde es heißen:
=WENN(C2>B2;C2-B2;C2+1-B2)*24
Also falls die Endezeit größer als die Anfangszeit ist wird normal subtrahiert, anderenfalls wird 1 (=1 Tag) dazugezählt. Die WENN-Funktion ist so aufgebaut: =WENN(Bedingung ; falls ja ; falls nein)
 
frankbier

frankbier

Mitglied seit
20.10.2005
Beiträge
7.402
Standort
WinBoard
Activity benutze ich schon lang dafür und kann ich nur empfehlen.:up

Dann brauchst du dir auch keine sorgen, um Formeln zu machen.
 
Zyndstoff

Zyndstoff

Mitglied seit
26.10.2010
Beiträge
2.445
Alter
57
Standort
BERLIN
Es geht auch ohne Datum, mit einer WENN-Formel: Angenommen die Zeiten stehen in B2 und C2 würde es heißen:

Also falls die Endezeit größer als die Anfangszeit ist wird normal subtrahiert, anderenfalls wird 1 (=1 Tag) dazugezählt. Die WENN-Funktion ist so aufgebaut: =WENN(Bedingung ; falls ja ; falls nein)
:up
Hübsche Lösung, gefällt. :D
 
Thema:

Arbeitsstunden???

Oben