Apache mit PHP/mySQL

Diskutiere Apache mit PHP/mySQL im Internet Forum Forum im Bereich Software Forum; Salü Die Installation von PHP auf dem Apache 2.0.39 auf Linux bereitet mir einige Schwierigkeiten. Den Apache konnte ich problemlos installieren...
N

Never_Born

Gast
Salü

Die Installation von PHP auf dem Apache 2.0.39 auf Linux bereitet mir einige Schwierigkeiten. Den Apache konnte ich problemlos installieren, jedoch das PHP will nicht so recht. Ich bin nach der Anleitung auf php.net vorgegangen. Bei "make" von PHP gibt's aber einen Fehler:
php_functions.c:93:27: missing binary operator before '!'
Dies aber nur, wenn ich das "apxs2" angebe! Ich weiss zwar nicht, was das ist, aber ohne das, kann ich den Apache (nach dem anpassen der httpd.conf) nicht mehr starten (Fehler bei der Zeile "LoadModule").

Kann mir da jemand helfen, oder mir eine Anleitung im Internet geben, mit der es auch bei mir funktioniert?

Danke
Never_Born
 
mastermind

mastermind

Dabei seit
02.02.2002
Beiträge
286
Hi,

vieleicht bringt dich das weiter LAMP

Ansonsten "php_functions.c:93:27: missing binary operator before '!'" mhhh ... er Erwartet irgend einen Befehl oder Parameter.

Habe zu apxs2 mal Hier eingegeben.
Ergebnis

Vieleicht hilft dir das weiter. Hoffe ich zumindest....
 
N

Never_Born

Gast
Ist ne gute Anleitung, leider für den Apache 1.3 und nicht 2.0.39. Geht nämlich nicht.
 
N

Never_Born

Gast
Hat noch niemand einen Apache 2.0.x auf Linux installiert?

Bei mir kommt immer noch derselbe Fehler wenn ich "apxs2" angebe, und ein paar andere Meldungen: [all-recursive] Error 1


Gruss
Never_Born
 
N

Never_Born

Gast
Juhuuu, es geht! Das heisst, ich konnte es ohne Fehler "installieren".

Die Lösung findet man hier:
[email protected]
23-Jun-2002 09:36


Edit the file sapi/apache2filter/php_functions.c and jump down to line 93.
You'll see a bit that looks like this:

#if !MODULE_MAGIC_AT_LEAST(20020506,0)
ADD_STRING(boundary);
#endif

Change the "MODULE_MAGIC_AT_LEAST" bit to read
"AP_MODULE_MAGIC_AT_LEAST". The former is deprecated and
expands to "this macro shouldn't be used" or something like
that.

It's possible that there are other places where this needs to change, too.
Gruss
Never_Born
 
N

Never_Born

Gast
...und mit "make install -i" funktioniert dann auch das Installieren. Und es läuft sogar!!! *freu* :devil
 
mastermind

mastermind

Dabei seit
02.02.2002
Beiträge
286
Schön !!

Sorry das ich nicht mehr hier rein geschaut hab. hatte ich glatt vergessen :( .

Super das es jetzt läuft!
 
N

Never_Born

Gast
Macht nichts!

Jetzt fehlt nur noch MySQL, evt. SSL und natürlich die automatische Aktualisierung der IP...
 
N

Never_Born

Gast
Ich hab nun mySQL installiert, und dann auch gleich phpMyAdmin. Es läuft alles bis auf die Tatsache, dass ich nur die Datenbank "test" sehe und keine neue erstellen kann. Warum?
 
mastermind

mastermind

Dabei seit
02.02.2002
Beiträge
286
Hi,

hast du dich richtig connected mit der Datenbank?
Du mußt dich als erstes als "root" und (ich glaub) ohne Passwort anmelden. Als nächstes mußt du glaub nen Useraccount mit alles rechten anlegen. Ich hab das nuur ein paar mal unter Windows und nen Klicki tool gemacht keine Ahnung wie man das direct unter PHPmyAdmin macht.
 
Pascal

Pascal

Dabei seit
01.05.2001
Beiträge
8.517
Alter
38
Ort
Internet, Links, beim nächsten Router Rechts, dana
Hallo

Ich habe hier einen Susi 8.0. Ich habe ebenfalls MYSQL isntalliert. Jedoch habe ich das Problem, das jeder die DB's sehen kann (keine PW aufforderung) und dass jeder DB's erstellen kann udn auch löschen ist möglich.


Was muss ich ändern, dass jeder User nur seine DB's sieht und diese auch löschen kann.

thanks
 
N

Never_Born

Gast
Mit root ohne Passwort hat es geklappt! Da hatte es dann so ein Link "Users", da kam ich aber nicht wirklich weiter. Dann hab ich das hier gefunden:
shell> mysql -u root mysql
mysql> UPDATE user SET Password=PASSWORD('new_password')
-> WHERE user='root';
mysql> FLUSH PRIVILEGES;
Das war wohl nicht so gut! Jetzt bin ich wieder gleich weit wie vorher... aber es geht auch ohne Passwort nicht mehr!
 
N

Never_Born

Gast
Eine Passwortabfrage kannst du im Apache machen, oder auch im phpMyAdmin. Wie man nur gewisse DB's anzeigen lässt, weiss ich auch nicht.

Ich hab keinen Zugriff mehr auf meinen MySQL-Server! Gibt's eine Möglichkeit, wie ich den wieder bekomme? Ich hab das RPM-File schon deinstalliert und wieder installiert, hat aber nichts genützt. Wo wird denn das gespeichert?



Update: Mein Problem hat sich erledigt -> war wohl der Neustart...



Last edited by Never_Born at 01.07.2002, 19:21
 
N

Never_Born

Gast
Hallo nochmals

Ich such trotzdem noch ein Tutorial oder so für phpMyAdmin 2.3.0-rc2. Ich hab nichts gescheites gefunden.

Grüsse
Never_Born
 
Thema:

Apache mit PHP/mySQL

Apache mit PHP/mySQL - Ähnliche Themen

  • 2008R2: Apache, PHP, MySQL - Update's

    2008R2: Apache, PHP, MySQL - Update's: Moin aus Meißendorf, wie die Überschrift schon vermuten lässt, habe ich erhebliche Probleme, die o.g. Versionen zu aktualisieren; vermutlich sehe...
  • Apache PHP: php_oci8.dll lädt nicht

    Apache PHP: php_oci8.dll lädt nicht: System: WinXP sp3 Apache 2.2 / PHP 5.2.9 (von apachefriends.org) Oracle 10g Win32 Client Der Oracle Client funktioniert, ODBC Zugriff auf Oracle...
  • .php Dateien in Apache einbinden

    .php Dateien in Apache einbinden: hi! kennt jemand ein brauchbares manual zum thema .php dateien in apache einbinden bzw. wie man die .php dateien schlussendlich im browser...
  • Windows, Apache, Mysql, PHP, FTP SErver usw...

    Windows, Apache, Mysql, PHP, FTP SErver usw...: DAMIT: http://www.apachefriends.org/de/xampp-windows.html geiles, teil, habs selbst auf nem dlserver im einsatz. Vorsicht,hat verzeichniss mit...
  • Ähnliche Themen
  • 2008R2: Apache, PHP, MySQL - Update's

    2008R2: Apache, PHP, MySQL - Update's: Moin aus Meißendorf, wie die Überschrift schon vermuten lässt, habe ich erhebliche Probleme, die o.g. Versionen zu aktualisieren; vermutlich sehe...
  • Apache PHP: php_oci8.dll lädt nicht

    Apache PHP: php_oci8.dll lädt nicht: System: WinXP sp3 Apache 2.2 / PHP 5.2.9 (von apachefriends.org) Oracle 10g Win32 Client Der Oracle Client funktioniert, ODBC Zugriff auf Oracle...
  • .php Dateien in Apache einbinden

    .php Dateien in Apache einbinden: hi! kennt jemand ein brauchbares manual zum thema .php dateien in apache einbinden bzw. wie man die .php dateien schlussendlich im browser...
  • Windows, Apache, Mysql, PHP, FTP SErver usw...

    Windows, Apache, Mysql, PHP, FTP SErver usw...: DAMIT: http://www.apachefriends.org/de/xampp-windows.html geiles, teil, habs selbst auf nem dlserver im einsatz. Vorsicht,hat verzeichniss mit...
  • Oben