ALSA ismod Probleme

Diskutiere ALSA ismod Probleme im Linux Forum im Bereich Weitere Betriebssysteme; Hi! Weil alsa bei dem 2.4.20er Kernel von kernel.org nicht dabei war hab ich das selbst compiliert. Hab mir die sourcen der Version...
M

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Hi!

Weil alsa bei dem 2.4.20er Kernel von kernel.org nicht dabei war hab ich das selbst compiliert. Hab mir die sourcen der Version 0.9.0-cvs20020913 heruntergeladen. Hat alles ordnungsgemäß geklappt. Module sind alle da. Nur jetzt bekomm ich ismod errors und yast will auch nicht. In yast steht dann: Das Kernelmodul snd-cmipci für die Soundunterstützung konnte nicht geladen werden. EIN MÖGLICHER Grund dafür können falsche Modulparameter sein, sowie ungültige IO- oder IRQ- Parameter. Kann mir jemand sagen wie ich das beheben kann?

morpheus
 
stpe

stpe

Dabei seit
14.11.2001
Beiträge
2.729
lade das modul mal mit "modprobe [modulname]" und poste bei erfolg eine "juhu-es-geht-meldung" ;) und bei misserfolg die fehlermeldung.
 
M

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Funktioniert leider nicht.

Hier die Fehlermeldung:

deepthought:~ # modprobe snd-cmipci
/lib/modules/2.4.20/kernel/sound/pci/snd-cmipci.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including inva lid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20/kernel/sound/pci/snd-cmipci.o: insmod /lib/modules/2.4.20/ke rnel/sound/pci/snd-cmipci.o failed
/lib/modules/2.4.20/kernel/sound/pci/snd-cmipci.o: insmod snd-cmipci failed
deepthought:~ #
 
M

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
An der alsa Version kann es nicht liegen. Ich hab mir eine ältere heruntergeladen und kompiliert und ich bekomm den gleichen Fehler. Irgendwie ist der da, seitdem ich die Kernel Source Update RPM für den Kernel 2.4.19 von SuSE installiert hab.
 
stpe

stpe

Dabei seit
14.11.2001
Beiträge
2.729
dem module fehlt das sound-device.

rufe den modprobe noch einmal mit hilfe von "strace" auf (hilfe dazu mit "man strace"). hier kannst Du sehen, auch welches device das module zugreifen moechte (irgendwas mit /dev/...). jetzt kannst Du mit "mknod" (konsultiere fuer die parameter auch hier das manual) das gewuenschte device anlegen.

danach sollte das laden des sound-modules wieder funktionieren.

leider kann ich Dir die parameter fuer die beiden o.g. befehle nicht aus dem kopf nennen, und im moment habe ich leider keine zeit :( - aber mit diesen hinweisen solltest Du schon ans ziel kommen, denke ich.
 
G

Guest

Gast
Ich hab das mal gemacht, wie ich es für richtig hielt. Hier ein kleiner Ausschnitt der kompletten ausgabe:
lstat64("/lib/modules/2.4.20/kernel/sound/pci/snd-cmipci.o", {st_mode=S_IFREG|0644, st_size=35708, ...}) = 0
stat64("/lib/modules/2.4.20/kernel/sound/pci/snd-cmipci.o", {st_mode=S_IFREG|0644, st_size=35708, ...}) = 0
create_module("snd-cmipci", 20876) = 0xe1ea4000
brk(0x81ac000) = 0x81ac000
init_module("snd-cmipci", 0x81a5a40) = -1 ENODEV (No such device)
write(2, "/lib/modules/2.4.20/kernel/sound"..., 51) = 51
write(2, "init_module: No such device", 27) = 27
write(2, "\n", 1) = 1
fstat64(1, {st_mode=S_IFCHR|0600, st_rdev=makedev(136, 1), ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x4001d000
write(1, "Hint: insmod errors can be cause"..., 106) = 106
write(1, " You may find more informat"..., 71) = 71
delete_module("snd-cmipci") = 0
flock(3, LOCK_UN) = 0
close(3) = 0
chdir("/var/log/ksymoops") = -1 ENOENT (No such file or directory)
write(2, "/lib/modules/2.4.20/kernel/sound"..., 51) = 51
write(2, "insmod /lib/modules/2.4.20/kerne"..., 63) = 63
write(2, "\n", 1) = 1
query_module(NULL, 0, NULL, 0) = 0
query_module(NULL, QM_MODULES, { /* 22 entries */ }, 22) = 0

Ich kann damit nicht wirklich was anfangen. Ich hab zur sicherheit nochmal die komplette Log- Datei angefügt.
 
M

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Was war jetzt los??? K.A. warum ich nicht eingeloggt war. Ist ja auch egal OK hier noch mal das File.
 

Anhänge

  • starce.log
    156,3 KB · Aufrufe: 203
stpe

stpe

Dabei seit
14.11.2001
Beiträge
2.729
probier mal den befehl:

ln -s /dev/sound /dev/snd-cmipci
 
M

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Hat leider nicht funktioniert. Ich hab mal einen Screenshoot von YaST gemacht. Kann das an den Einstellungen liegen? Weiß nicht, was ich bei snd_fm_port und dem anderen für Optionen angeben muss.
 

Anhänge

  • yast_sound.jpg
    yast_sound.jpg
    55,6 KB · Aufrufe: 406
stpe

stpe

Dabei seit
14.11.2001
Beiträge
2.729
denke nicht, dass es an diesen parametern liegt. dem module fehlt einfach das device unter /dev.

welches das ist, konnte ich aus dem strace.log leider nicht ermitteln.
 
M

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Wie kann ich das device denn rausbekommen?

Nochwas. Der geupdatete SuSE Kernel hat die gleichen Probleme. Ich ahb aber nichts gelöscht oder so.

Kann das an der modules.conf liegen?????
 
stpe

stpe

Dabei seit
14.11.2001
Beiträge
2.729
k.a.

kann Dir leider so nicht weiterhelfen - vielleicht hilft Dir die seite des soundkartenherstellers, die suse-page oder das usenet besser weiter - ich hatte mit dieser soundkarte leider bisher nie etwas zu tun. deswegen kann ich Dir leider auch nicht beantworten, was wo noch fehlen koennte.
 
M

morpheus2051

Threadstarter
Dabei seit
13.02.2002
Beiträge
376
Ich glaub ich hab das Problem. In /dev hab ich zwei ungültige Verknüpfungen gefunden:

1.: snd zu /proc/asound/dev

2.: sound zu /dev/snd-cmipci

zu 1.: Das Verzeichnis asound ist nicht vorhanden.
zu 2.: snd-cmipci gibts im /dev Verzeichnis nicht. Was ist das eigendlich für eine snd-cmipci? Ist das min Kernel Modul?
 
Thema:

ALSA ismod Probleme

Oben